iw: enable HE PHY information for iw-tiny
authorDavid Bauer <mail@david-bauer.net>
Sun, 3 Jan 2021 20:43:57 +0000 (21:43 +0100)
committerDavid Bauer <mail@david-bauer.net>
Thu, 14 Jan 2021 00:03:34 +0000 (01:03 +0100)
Currently PHY information obtained from "iw phy" lacks information about
a PHYs HE capabilities when using the by default installed iw-tiny.

As there are already 802.11ax supported devices, enabled printing this
information for the by-default installed iw variant.

Signed-off-by: David Bauer <mail@david-bauer.net>
package/network/utils/iw/Makefile
package/network/utils/iw/patches/200-reduce_size.patch

index 90e678291170c79591f570b465c0b2a1444ba102..6eb10c837fdec953daa9b7cf29036d99b55cf75b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iw
 PKG_VERSION:=5.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/software/network/iw
index 24eb96537b0f96da473a855af0969720de023b51..1e8286300b61ab0720341d0561e9cd593b8328ae 100644 (file)
  
 --- a/info.c
 +++ b/info.c
-@@ -167,6 +167,7 @@ static int print_phy_handler(struct nl_m
-                           tb_band[NL80211_BAND_ATTR_VHT_MCS_SET])
-                               print_vht_info(nla_get_u32(tb_band[NL80211_BAND_ATTR_VHT_CAPA]),
-                                              nla_data(tb_band[NL80211_BAND_ATTR_VHT_MCS_SET]));
-+#ifdef IW_FULL
-                       if (tb_band[NL80211_BAND_ATTR_IFTYPE_DATA]) {
-                               struct nlattr *nl_iftype;
-                               int rem_band;
-@@ -174,6 +175,7 @@ static int print_phy_handler(struct nl_m
-                               nla_for_each_nested(nl_iftype, tb_band[NL80211_BAND_ATTR_IFTYPE_DATA], rem_band)
-                                       print_he_info(nl_iftype);
-                       }
-+#endif
-                       if (tb_band[NL80211_BAND_ATTR_FREQS]) {
-                               if (!band_had_freq) {
-                                       printf("\t\tFrequencies:\n");
-@@ -216,6 +218,7 @@ next:
+@@ -216,6 +216,7 @@ next:
                                }
                        }
  
@@ -62,7 +46,7 @@
                        if (tb_band[NL80211_BAND_ATTR_RATES]) {
                        printf("\t\tBitrates (non-HT):\n");
                        nla_for_each_nested(nl_rate, tb_band[NL80211_BAND_ATTR_RATES], rem_rate) {
-@@ -232,6 +235,7 @@ next:
+@@ -232,6 +233,7 @@ next:
                                printf("\n");
                        }
                        }
@@ -70,7 +54,7 @@
                }
        }
  
-@@ -297,6 +301,7 @@ next:
+@@ -297,6 +299,7 @@ next:
                printf("\tCoverage class: %d (up to %dm)\n", coverage, 450 * coverage);
        }
  
@@ -78,7 +62,7 @@
        if (tb_msg[NL80211_ATTR_CIPHER_SUITES]) {
                int num = nla_len(tb_msg[NL80211_ATTR_CIPHER_SUITES]) / sizeof(__u32);
                int i;
-@@ -308,6 +313,7 @@ next:
+@@ -308,6 +311,7 @@ next:
                                        cipher_name(ciphers[i]));
                }
        }
@@ -86,7 +70,7 @@
  
        if (tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_TX] &&
            tb_msg[NL80211_ATTR_WIPHY_ANTENNA_AVAIL_RX])
-@@ -327,11 +333,13 @@ next:
+@@ -327,11 +331,13 @@ next:
                        printf("\t\t * %s\n", iftype_name(nla_type(nl_mode)));
        }
  
  
        if (tb_msg[NL80211_ATTR_INTERFACE_COMBINATIONS]) {
                struct nlattr *nl_combi;
-@@ -428,6 +436,7 @@ broken_combination:
+@@ -428,6 +434,7 @@ broken_combination:
                        printf("\tinterface combinations are not supported\n");
        }
  
        if (tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS]) {
                printf("\tSupported commands:\n");
                nla_for_each_nested(nl_cmd, tb_msg[NL80211_ATTR_SUPPORTED_COMMANDS], rem_cmd)
-@@ -525,6 +534,7 @@ broken_combination:
+@@ -525,6 +532,7 @@ broken_combination:
                                printf("\t\t * wake up on TCP connection\n");
                }
        }
  
        if (tb_msg[NL80211_ATTR_ROAM_SUPPORT])
                printf("\tDevice supports roaming.\n");
-@@ -563,6 +573,7 @@ broken_combination:
+@@ -563,6 +571,7 @@ broken_combination:
                }
        }
  
        if (tb_msg[NL80211_ATTR_FEATURE_FLAGS]) {
                unsigned int features = nla_get_u32(tb_msg[NL80211_ATTR_FEATURE_FLAGS]);
  
-@@ -627,6 +638,7 @@ broken_combination:
+@@ -627,6 +636,7 @@ broken_combination:
                if (features & NL80211_FEATURE_ND_RANDOM_MAC_ADDR)
                        printf("\tDevice supports randomizing MAC-addr in net-detect scans.\n");
        }
  
        if (tb_msg[NL80211_ATTR_TDLS_SUPPORT])
                printf("\tDevice supports T-DLS.\n");
-@@ -762,6 +774,7 @@ TOPLEVEL(list, NULL, NL80211_CMD_GET_WIP
+@@ -762,6 +772,7 @@ TOPLEVEL(list, NULL, NL80211_CMD_GET_WIP
         "List all wireless devices and their capabilities.");
  TOPLEVEL(phy, NULL, NL80211_CMD_GET_WIPHY, NLM_F_DUMP, CIB_NONE, handle_info, NULL);
  
  static int handle_commands(struct nl80211_state *state, struct nl_msg *msg,
                           int argc, char **argv, enum id_input id)
  {
-@@ -773,6 +786,7 @@ static int handle_commands(struct nl8021
+@@ -773,6 +784,7 @@ static int handle_commands(struct nl8021
  }
  TOPLEVEL(commands, NULL, NL80211_CMD_GET_WIPHY, 0, CIB_NONE, handle_commands,
         "list all known commands and their decimal & hex value");