mt76: move mt76x2e firmware to kmod-mt76x2-common and use it for mt76x2u
authorFelix Fietkau <nbd@nbd.name>
Sun, 14 Oct 2018 16:46:32 +0000 (18:46 +0200)
committerFelix Fietkau <nbd@nbd.name>
Sun, 14 Oct 2018 16:47:44 +0000 (18:47 +0200)
USB and PCIe devices can run the same firmware

Signed-off-by: Felix Fietkau <nbd@nbd.name>
package/kernel/mt76/Makefile

index a0b966c75a92aac86f0f1572749e1c4cfe5ce5c1..5238b4c73c9c2acc71489d87edaed49f05845407 100644 (file)
@@ -183,7 +183,7 @@ define Package/kmod-mt76/install
        true
 endef
 
        true
 endef
 
-define KernelPackage/mt76x2/install
+define KernelPackage/mt76x2-common/install
        $(INSTALL_DIR) $(1)/lib/firmware
        cp \
                $(PKG_BUILD_DIR)/firmware/mt7662_rom_patch.bin \
        $(INSTALL_DIR) $(1)/lib/firmware
        cp \
                $(PKG_BUILD_DIR)/firmware/mt7662_rom_patch.bin \
@@ -191,6 +191,12 @@ define KernelPackage/mt76x2/install
                $(1)/lib/firmware
 endef
 
                $(1)/lib/firmware
 endef
 
+define KernelPackage/mt76x2u/install
+       $(INSTALL_DIR) $(1)/lib/firmware/mediatek
+       ln -sf ../mt7662.bin $(1)/lib/firmware/mediatek/mt7662u.bin
+       ln -sf ../mt7662_rom_patch.bin $(1)/lib/firmware/mediatek/mt7662u_rom_patch.bin
+endef
+
 define KernelPackage/mt7603/install
        $(INSTALL_DIR) $(1)/lib/firmware
        cp $(if $(CONFIG_TARGET_ramips_mt76x8), \
 define KernelPackage/mt7603/install
        $(INSTALL_DIR) $(1)/lib/firmware
        cp $(if $(CONFIG_TARGET_ramips_mt76x8), \