toolchain/gdb: use expat library to be able to parse target machine definitions
authorFelix Fietkau <nbd@openwrt.org>
Fri, 10 Jul 2015 19:42:12 +0000 (19:42 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 10 Jul 2015 19:42:12 +0000 (19:42 +0000)
Fixes gdbserver debugging with at least mvebu, possibly others

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 46298

toolchain/gdb/Makefile

index d3f1e8c0aad2f6c6b2626c8eaa9a7243a855b90a..fa5179a5dc524ec11f8ad791f948a99f019b3f95 100644 (file)
@@ -17,22 +17,20 @@ HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-               gdb_cv_func_sigsetjmp=yes \
-               CFLAGS="-O2" \
-               $(HOST_BUILD_DIR)/configure \
-               --prefix=$(TOOLCHAIN_DIR) \
-               --build=$(GNU_HOST_NAME) \
-               --host=$(GNU_HOST_NAME) \
-               --target=$(REAL_GNU_TARGET_NAME) \
-               --disable-werror \
-               --without-uiout \
-               --disable-tui --disable-gdbtk --without-x \
-               --without-included-gettext \
-               --enable-threads \
-       );
-endef
+HOST_CONFIGURE_VARS += \
+       gdb_cv_func_sigsetjmp=yes
+
+HOST_CONFIGURE_ARGS = \
+       --prefix=$(TOOLCHAIN_DIR) \
+       --build=$(GNU_HOST_NAME) \
+       --host=$(GNU_HOST_NAME) \
+       --target=$(REAL_GNU_TARGET_NAME) \
+       --disable-werror \
+       --without-uiout \
+       --disable-tui --disable-gdbtk --without-x \
+       --without-included-gettext \
+       --enable-threads \
+       --with-expat
 
 define Host/Install
        mkdir -p $(TOOLCHAIN_DIR)/bin
 
 define Host/Install
        mkdir -p $(TOOLCHAIN_DIR)/bin