strace: fix build on aarch64
authorStijn Tintel <stijn@linux-ipv6.be>
Thu, 28 Jun 2018 10:00:10 +0000 (13:00 +0300)
committerStijn Tintel <stijn@linux-ipv6.be>
Wed, 5 Sep 2018 21:49:15 +0000 (23:49 +0200)
As of version 4.21, strace enforces mpers by default. The current
implementation of aarch64 compat in strace assumes it's identical to
ARMv7 EABI and therefore tries to enable m32 personality support. As
there is no -m32 support on aarch64, this causes the build to fail.

Restore previous strace behavior to fix build on aarch64.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Tested-by: Karl Palsson <karlp@tweak.net.au>
package/devel/strace/Makefile

index 3704aa8b150db3634989f43b5ac88885c9d7f511..ded6d3bb843c96b777f83232649f25dbedd9094a 100644 (file)
@@ -30,6 +30,10 @@ include $(INCLUDE_DIR)/package.mk
 
 HOST_CFLAGS += -I$(LINUX_DIR)/user_headers/include
 
+ifeq ($(ARCH),aarch64)
+  CONFIGURE_ARGS += --enable-mpers=check
+endif
+
 CONFIGURE_VARS+= \
        LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
        CPPFLAGS_FOR_BUILD="$(HOST_CPPFLAGS)" \