add nvram fixup script
authorFelix Fietkau <nbd@openwrt.org>
Wed, 27 Jun 2007 05:26:20 +0000 (05:26 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 27 Jun 2007 05:26:20 +0000 (05:26 +0000)
SVN-Revision: 7742

package/nvram/Makefile
package/nvram/files/nvram.init [new file with mode: 0755]

index 87e8b0659eaeed14317666a56fc4af5849cbc730..318e4d593e8b035fe02c99ded443380701454c6f 100644 (file)
@@ -40,6 +40,8 @@ define Build/UninstallDev
 endef
 
 define Package/nvram/install
 endef
 
 define Package/nvram/install
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/nvram.init $(1)/etc/init.d/nvram
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/lib{nvram,shared}*.so $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_BUILD_DIR)/lib{nvram,shared}*.so $(1)/usr/lib/
        $(INSTALL_DIR) $(1)/usr/sbin
diff --git a/package/nvram/files/nvram.init b/package/nvram/files/nvram.init
new file mode 100755 (executable)
index 0000000..164fdb5
--- /dev/null
@@ -0,0 +1,70 @@
+#!/bin/sh /etc/rc.common
+# NVRAM setup
+#
+# This file handles the NVRAM quirks of various hardware.
+
+START=02
+alias debug=${DEBUG:-:}
+
+nvram_default() {
+       [ -z "$(nvram get $1)" ] && nvram set "$1=$2"
+}
+
+nvram_set() { # for the linksys fixup part
+       [ "$(nvram get "$1")" = "$2" -a "$2" != "" ] || {
+               COMMIT=1
+               /usr/sbin/nvram set "$1=$2"
+       }
+}
+
+fixup_linksys() {
+       # work around braindead CFE defaults in linksys routers
+       boardtype=$(nvram get boardtype)
+       boardnum=$(nvram get boardnum)
+       boardflags=$(($(nvram get boardflags)))
+       adm_switch="$(( ($boardflags & 0x80) >> 7 ))"
+
+       [ -n "$(nvram get vxkilled)" ] && boardtype=0 # don't mess with the ram settings on the hacked cfe
+       case "$(( $boardtype ))" in
+               "1800") #0x708
+                       if [ "$adm_switch" = 0 ]; then
+                               nvram_set sdram_init "$(printf 0x%04x $(( $(/usr/sbin/nvram get sdram_init) | 0x0100 )))"
+                               [ "$COMMIT" = 1 ] && {
+                                       nvram_set clkfreq 216
+                                       nvram_set sdram_ncdl 0x0
+                                       nvram_set pa0itssit 62
+                                       nvram_set pa0b0 0x15eb
+                                       nvram_set pa0b1 0xfa82
+                                       nvram_set pa0b2 0xfe66
+                                       nvram_set pa0maxpwr 0x4e
+                               }
+                       fi
+               ;;
+               "1127") #0x467
+                       nvram_set sdram_init "$(printf 0x%04x $(( $(/usr/sbin/nvram get sdram_init) | 0x0100 )))"
+                       [ "$COMMIT" = 1 ] && {
+                               nvram_set sdram_ncdl 0x0
+                               nvram_set pa0itssit 62
+                               nvram_set pa0b0 0x168b
+                               nvram_set pa0b1 0xfabf
+                               nvram_set pa0b2 0xfeaf
+                               nvram_set pa0maxpwr 0x4e
+                       }
+               ;;
+       esac
+       [ "$COMMIT" = "1" ] && nvram commit
+}
+
+start() {
+       fixup_linksys
+
+       # OFDM Power Offset is set incorrectly on many boards.
+       # Setting it to 0 will increase the tx power to normal levels.
+       nvram_set opo 0x0
+
+       [ "$(nvram get il0macaddr)" = "00:90:4c:5f:00:2a" ] && {
+               # if default wifi mac, set two higher than the lan mac
+               nvram set il0macaddr=$(nvram get et0macaddr|
+               awk '{OFS=FS=":";for(x=7,y=2;--x;){$x=sprintf("%02x",(y+="0x"$x)%256);y/=256}print}')
+       }
+}