ath79: fix SUPPORTED_DEVICES for ubnt_nanostation-m
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 21 Oct 2019 14:17:01 +0000 (16:17 +0200)
committerJohn Crispin <john@phrozen.org>
Tue, 22 Oct 2019 09:40:56 +0000 (11:40 +0200)
The ar71xx images for the Ubiquiti NanoStation M (XM) devices use
"nanostation-m" as board name, but the ath79 images are only
compatible with the "nano-m" board name, so sysupgrade complains.

By changing this additional supported device, sysupgrade smoothly
upgrades from ar71xx to ath79.

Ref: openwrt#2418

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
(cherry picked from commit f473ce6f231bb9f8913be50e850c771b3463fa14)

target/linux/ath79/image/generic-ubnt.mk

index 97a479a14a0213d2accd180ab29059b3dc32157b..c51d743a354546bdad996203160120c9e063b5f2 100644 (file)
@@ -109,7 +109,7 @@ TARGET_DEVICES += ubnt_rocket-m
 define Device/ubnt_nanostation-m
   $(Device/ubnt-xm)
   DEVICE_TITLE := Ubiquiti Nanostation M
-  SUPPORTED_DEVICES += nano-m
+  SUPPORTED_DEVICES += nanostation-m
 endef
 TARGET_DEVICES += ubnt_nanostation-m