Add a requireheader for squid, should fix it (#2205)
authorFlorian Fainelli <florian@openwrt.org>
Sun, 12 Aug 2007 11:53:23 +0000 (11:53 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Sun, 12 Aug 2007 11:53:23 +0000 (11:53 +0000)
SVN-Revision: 8404

include/prereq.mk

index 660f67cb1bb9349ef127bb7034aefbb5df1a8f9c..8e5490ccff80161233cc76bede40f16f0e22d696 100644 (file)
@@ -47,4 +47,12 @@ define RequireCommand
   $$(eval $$(call Require,$(1),$(2)))
 endef
 
   $$(eval $$(call Require,$(1),$(2)))
 endef
 
+define RequireHeader
+  define Require/$(1)
+    [ -e "$(1)" ]
+  endef
+  
+  $$(eval $$(call Require,$(1),$(2)))
+endef
+
 .NOTPARALLEL:
 .NOTPARALLEL: