brcm2708: Add feature flag rootfs-part
authorDaniel F. Dickinson <cshored@thecshore.com>
Thu, 27 Dec 2018 03:33:57 +0000 (22:33 -0500)
committerYousong Zhou <yszhou4tech@gmail.com>
Wed, 30 Oct 2019 02:38:02 +0000 (02:38 +0000)
Even with squashfs brcm2708 requires ROOTFS_PART_SIZE because the overlay
exists as a loopback device on the space not used by squashfs in the root
partition. Also for ext4 (the other fs option) ROOTFS_PART_SIZE is required,
so use feature flag rootfs-part to enable it.

Fixes FS#2166

Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com>
(cherry picked from commit 3bb44f42990a75e66972016cde75bed6a3f09ef9)
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
target/linux/brcm2708/Makefile

index 870029c4c84d48cb8aae1ca90ea3e8582f26c1b5..b1ee089c9ad9b20e4986ece4c1cc2799c1da1be5 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=brcm2708
 BOARDNAME:=Broadcom BCM27xx
-FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs
+FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs rootfs-part
 MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 SUBTARGETS:=bcm2708 bcm2709 bcm2710