binutils: use nls.mk to fix libbfd link errors in other packages
authorFelix Fietkau <nbd@openwrt.org>
Wed, 20 Jan 2016 23:50:36 +0000 (23:50 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 20 Jan 2016 23:50:36 +0000 (23:50 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48422

package/devel/binutils/Makefile

index 8e25a1e..79f5dcc 100644 (file)
@@ -26,13 +26,14 @@ PKG_LICENSE:=GPL-3.0+
 PKG_BUILD_PARALLEL:=1
 PKG_USE_MIPS16:=0
 
+include $(INCLUDE_DIR)/nls.mk
 include $(INCLUDE_DIR)/package.mk
 
 define Package/libbfd
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE:=libbfd
-  DEPENDS:=+zlib
+  DEPENDS:=+zlib $(ICONV_DEPENDS) $(INTL_DEPENDS)
 endef
 
 define Package/libopcodes