ath79: Add support for OpenMesh MR1750 v2
authorSven Eckelmann <sven@narfation.org>
Mon, 23 Nov 2020 12:41:34 +0000 (13:41 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 19 Jan 2021 20:41:26 +0000 (21:41 +0100)
Device specifications:
======================

* Qualcomm/Atheros QCA9558 ver 1 rev 0
* 720/600/240 MHz (CPU/DDR/AHB)
* 128 MB of RAM
* 16 MB of SPI NOR flash
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 3T3R 2.4 GHz Wi-Fi (11n)
* 3T3R 5 GHz Wi-Fi (11ac)
* 6x GPIO-LEDs (2x wifi, 2x status, 1x lan, 1x power)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default))
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 1x ethernet
  - AR8035 ethernet PHY (RGMII)
  - 10/100/1000 Mbps Ethernet
  - 802.3af POE
  - used as LAN interface
* 12-24V 1A DC
* internal antennas

Flashing instructions:
======================

Various methods can be used to install the actual image on the flash.
Two easy ones are:

ap51-flash
----------

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the image to the u-boot when the device boots up.

initramfs from TFTP
-------------------

The serial console must be used to access the u-boot shell during bootup.
It can then be used to first boot up the initramfs image from a TFTP server
(here with the IP 192.168.1.21):

   setenv serverip 192.168.1.21
   setenv ipaddr 192.168.1.1
   tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr

The actual sysupgrade image can then be transferred (on the LAN port) to the
device via

  scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/

On the device, the sysupgrade must then be started using

  sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin

Signed-off-by: Sven Eckelmann <sven@narfation.org>
[rebase, add LED migration]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/qca9558_openmesh_mr1750-v2.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/01_leds
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
target/linux/ath79/image/generic.mk

index fb025c95ea04a520e214b96e30048029435fb739..dda9d6be9c1470ea536b4dc024f6c86060b18274 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2020.04
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2020.04
-PKG_RELEASE:=19
+PKG_RELEASE:=20
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
index dfb77112a7ea62c3bbaef0392f1bfb7b10c7d580..4b8476681433d707c9957c522523292d57dfd908 100644 (file)
@@ -53,6 +53,7 @@ openmesh,mr600-v2|\
 openmesh,mr900-v1|\
 openmesh,mr900-v2|\
 openmesh,mr1750-v1|\
 openmesh,mr900-v1|\
 openmesh,mr900-v2|\
 openmesh,mr1750-v1|\
+openmesh,mr1750-v2|\
 openmesh,om5p|\
 openmesh,om5p-ac-v2|\
 samsung,wam250|\
 openmesh,om5p|\
 openmesh,om5p-ac-v2|\
 samsung,wam250|\
diff --git a/target/linux/ath79/dts/qca9558_openmesh_mr1750-v2.dts b/target/linux/ath79/dts/qca9558_openmesh_mr1750-v2.dts
new file mode 100644 (file)
index 0000000..0271db0
--- /dev/null
@@ -0,0 +1,16 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9558_openmesh_mr.dtsi"
+
+/ {
+       compatible = "openmesh,mr1750-v2", "qca,qca9558";
+       model = "OpenMesh MR1750 v2";
+};
+
+&led_wifi2g {
+       linux,default-trigger = "phy1tpt";
+};
+
+&led_wifi5g {
+       linux,default-trigger = "phy0tpt";
+};
index 2cdad7dd7744937ae57986dadbbd7e254b8981a4..c6ade98c8faad018c75bd0e349c648645c5a046c 100755 (executable)
@@ -160,7 +160,8 @@ engenius,eap300-v2|\
 enterasys,ws-ap3705i|\
 openmesh,mr900-v1|\
 openmesh,mr900-v2|\
 enterasys,ws-ap3705i|\
 openmesh,mr900-v1|\
 openmesh,mr900-v2|\
-openmesh,mr1750-v1)
+openmesh,mr1750-v1|\
+openmesh,mr1750-v2)
        ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
        ;;
 compex,wpj344-16m|\
        ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
        ;;
 compex,wpj344-16m|\
index ef6b70c9023a8871616e704b963d10a2000b890e..0c08871f996e2b5eee52d9b733a5c0171738880f 100755 (executable)
@@ -51,6 +51,7 @@ ath79_setup_interfaces()
        openmesh,mr900-v1|\
        openmesh,mr900-v2|\
        openmesh,mr1750-v1|\
        openmesh,mr900-v1|\
        openmesh,mr900-v2|\
        openmesh,mr1750-v1|\
+       openmesh,mr1750-v2|\
        pcs,cap324|\
        pisen,ts-d084|\
        pisen,wmb001n|\
        pcs,cap324|\
        pisen,ts-d084|\
        pisen,wmb001n|\
index d1a47676482759512ab46d3cb692d9f5ec839f03..84323046f641d81d1db484e8e9eac297e44848af 100644 (file)
@@ -96,7 +96,8 @@ case "$FIRMWARE" in
                caldata_extract "art" 0x5000 0x844
                ath10k_patch_mac $(mtd_get_mac_binary art 0xc)
                ;;
                caldata_extract "art" 0x5000 0x844
                ath10k_patch_mac $(mtd_get_mac_binary art 0xc)
                ;;
-       openmesh,mr1750-v1)
+       openmesh,mr1750-v1|\
+       openmesh,mr1750-v2)
                caldata_extract "ART" 0x5000 0x844
                ath10k_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
                ;;
                caldata_extract "ART" 0x5000 0x844
                ath10k_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
                ;;
index 1d8909f688795fdcb3bb49d903f88fdd1acf9d67..ea5cafa66b63c92b3988303a1472a8f13e13b8c6 100644 (file)
@@ -25,7 +25,8 @@ openmesh,mr600-v2)
        ;;
 openmesh,mr900-v1|\
 openmesh,mr900-v2|\
        ;;
 openmesh,mr900-v1|\
 openmesh,mr900-v2|\
-openmesh,mr1750-v1)
+openmesh,mr1750-v1|\
+openmesh,mr1750-v2)
        migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g" ":wan=:lan"
        ;;
 pcs,cap324)
        migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g" ":wan=:lan"
        ;;
 pcs,cap324)
index 01a9f619433c8861d9d0e04b798f8b4434d2d933..575761d0797547a2db322b9a9a7aa6fb77c66542 100644 (file)
@@ -55,6 +55,7 @@ platform_do_upgrade() {
        openmesh,mr900-v1|\
        openmesh,mr900-v2|\
        openmesh,mr1750-v1|\
        openmesh,mr900-v1|\
        openmesh,mr900-v2|\
        openmesh,mr1750-v1|\
+       openmesh,mr1750-v2|\
        openmesh,om2p-v2|\
        openmesh,om2p-v4|\
        openmesh,om2p-hs-v1|\
        openmesh,om2p-v2|\
        openmesh,om2p-v4|\
        openmesh,om2p-hs-v1|\
index 92e9458b378625b1bd72689bc57aa08c23385afb..3b5cb6bdfa6403f581fc4fd6d87696ee2850dddc 100644 (file)
@@ -1601,6 +1601,17 @@ define Device/openmesh_mr1750-v1
 endef
 TARGET_DEVICES += openmesh_mr1750-v1
 
 endef
 TARGET_DEVICES += openmesh_mr1750-v1
 
+define Device/openmesh_mr1750-v2
+  $(Device/openmesh_common_64k)
+  SOC := qca9558
+  DEVICE_MODEL := MR1750
+  DEVICE_VARIANT := v2
+  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  OPENMESH_CE_TYPE := MR1750
+  SUPPORTED_DEVICES += mr1750v2
+endef
+TARGET_DEVICES += openmesh_mr1750-v2
+
 define Device/openmesh_om2p-v2
   $(Device/openmesh_common_256k)
   SOC := ar9330
 define Device/openmesh_om2p-v2
   $(Device/openmesh_common_256k)
   SOC := ar9330