kernel: bump 5.10 to 5.10.102
authorJohn Audia <graysky@archlinux.us>
Wed, 23 Feb 2022 11:58:46 +0000 (06:58 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 1 Mar 2022 20:38:36 +0000 (21:38 +0100)
Removed upstreamed:
bcm4908/patches-5.10/180-i2c-brcmstb-fix-support-for-DSL-and-CM-variants.patch[1]

All other patches automatically rebased.

1. https://git.kernel.org/pub/scm/linux/kernel/git/stable/linux.git/commit/?h=v5.10.102&id=f333c1916fd6b55900029bf8f918cc00009e2111

Build system: x86_64
Build-tested: bcm2711/RPi4B, mt7622/RT3200
Run-tested: bcm2711/RPi4B, mt7622/RT3200

Signed-off-by: John Audia <graysky@archlinux.us>
19 files changed:
include/kernel-5.10
target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
target/linux/ath79/patches-5.10/920-mikrotik-rb4xx.patch
target/linux/ath79/patches-5.10/939-mikrotik-rb91x.patch
target/linux/bcm27xx/patches-5.10/950-0151-hid-usb-Add-device-quirks-for-Freeway-Airmouse-T3-an.patch
target/linux/bcm27xx/patches-5.10/950-0348-gpio-Add-gpio-fsm-driver.patch
target/linux/bcm4908/patches-5.10/086-v5.12-0001-phy-phy-brcm-usb-improve-getting-OF-matching-data.patch
target/linux/bcm4908/patches-5.10/086-v5.12-0002-phy-phy-brcm-usb-specify-init-function-format-at-str.patch
target/linux/bcm4908/patches-5.10/086-v5.12-0005-phy-phy-brcm-usb-support-PHY-on-the-BCM4908.patch
target/linux/bcm4908/patches-5.10/180-i2c-brcmstb-fix-support-for-DSL-and-CM-variants.patch [deleted file]
target/linux/generic/pending-5.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/generic/pending-5.10/710-bridge-add-knob-for-filtering-rx-tx-BPDU-pack.patch
target/linux/generic/pending-5.10/801-gpio-gpio-cascade-add-generic-GPIO-cascade.patch
target/linux/generic/pending-5.10/834-ledtrig-libata.patch
target/linux/ipq806x/patches-5.10/099-1-mtd-nand-raw-qcom_nandc-add-boot_layout_mode-support.patch
target/linux/oxnas/patches-5.10/999-libata-hacks.patch
target/linux/ramips/patches-5.10/802-GPIO-MIPS-ralink-add-gpio-driver-for-ralink-SoC.patch
target/linux/realtek/patches-5.10/002-5.13-gpio-add-realtek-otto-gpio-support.patch
target/linux/realtek/patches-5.10/301-gpio-add-rtl8231-driver.patch

index 47c2fd41f5b3fdc4170fcb87ff5780dfc777e175..0522a1432ff7109222cac051757f8a945952b3e0 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.10 = .101
-LINUX_KERNEL_HASH-5.10.101 = 0749258cb7ee47c478dfc34857e8930d41bfe0b074e80e9f57cbfa56d0ba1c8e
+LINUX_VERSION-5.10 = .102
+LINUX_KERNEL_HASH-5.10.102 = e6414895b1c2e406a41a8744160e2b4ef2095e6cebe5363be460d1b198f0e379
index e0bd900479aa207060507a03292a9fcbd8b69e72..cee1db1545f7b4890e725eb817948442c4413592 100644 (file)
  
  #define       IP6_MF          0x0001
  #define       IP6_OFFSET      0xFFF8
-@@ -557,8 +557,8 @@ static inline void __ipv6_addr_set_half(
+@@ -560,8 +560,8 @@ static inline void __ipv6_addr_set_half(
        }
  #endif
  #endif
  }
  
  static inline void ipv6_addr_set(struct in6_addr *addr,
-@@ -617,6 +617,8 @@ static inline bool ipv6_prefix_equal(con
+@@ -620,6 +620,8 @@ static inline bool ipv6_prefix_equal(con
        const __be32 *a1 = addr1->s6_addr32;
        const __be32 *a2 = addr2->s6_addr32;
        unsigned int pdw, pbi;
  
        /* check complete u32 in prefix */
        pdw = prefixlen >> 5;
-@@ -625,7 +627,9 @@ static inline bool ipv6_prefix_equal(con
+@@ -628,7 +630,9 @@ static inline bool ipv6_prefix_equal(con
  
        /* check incomplete u32 in prefix */
        pbi = prefixlen & 0x1f;
                return false;
  
        return true;
-@@ -746,13 +750,13 @@ static inline void ipv6_addr_set_v4mappe
+@@ -749,13 +753,13 @@ static inline void ipv6_addr_set_v4mappe
   */
  static inline int __ipv6_addr_diff32(const void *token1, const void *token2, int addrlen)
  {
                if (xb)
                        return i * 32 + 31 - __fls(ntohl(xb));
        }
-@@ -938,17 +942,18 @@ static inline int ip6_multipath_hash_pol
+@@ -941,17 +945,18 @@ static inline int ip6_multipath_hash_pol
  static inline void ip6_flow_hdr(struct ipv6hdr *hdr, unsigned int tclass,
                                __be32 flowlabel)
  {
index 3129fac3abac110e8b0687b7aeb64a94a879e123..4ed13deb5c4f8eb23553eb324c275b4c39800b50 100644 (file)
@@ -42,7 +42,7 @@
  menu "SPI GPIO expanders"
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -120,6 +120,7 @@ obj-$(CONFIG_GPIO_PL061)           += gpio-pl061.
+@@ -121,6 +121,7 @@ obj-$(CONFIG_GPIO_PL061)           += gpio-pl061.
  obj-$(CONFIG_GPIO_PMIC_EIC_SPRD)      += gpio-pmic-eic-sprd.o
  obj-$(CONFIG_GPIO_PXA)                        += gpio-pxa.o
  obj-$(CONFIG_GPIO_RASPBERRYPI_EXP)    += gpio-raspberrypi-exp.o
index 4f4344b40f950a8238b32657854ca683be40a0f7..4cf6bb08dfb4e532908e8b738ce7ba240a211b18 100644 (file)
@@ -27,7 +27,7 @@
        depends on MFD_SYSCON
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -72,6 +72,7 @@ obj-$(CONFIG_GPIO_IT87)                      += gpio-it87.o
+@@ -73,6 +73,7 @@ obj-$(CONFIG_GPIO_IT87)                      += gpio-it87.o
  obj-$(CONFIG_GPIO_IXP4XX)             += gpio-ixp4xx.o
  obj-$(CONFIG_GPIO_JANZ_TTL)           += gpio-janz-ttl.o
  obj-$(CONFIG_GPIO_KEMPLD)             += gpio-kempld.o
@@ -35,7 +35,7 @@
  obj-$(CONFIG_GPIO_LOGICVC)            += gpio-logicvc.o
  obj-$(CONFIG_GPIO_LOONGSON1)          += gpio-loongson1.o
  obj-$(CONFIG_GPIO_LOONGSON)           += gpio-loongson.o
-@@ -121,6 +122,7 @@ obj-$(CONFIG_GPIO_PMIC_EIC_SPRD)   += gpio
+@@ -122,6 +123,7 @@ obj-$(CONFIG_GPIO_PMIC_EIC_SPRD)   += gpio
  obj-$(CONFIG_GPIO_PXA)                        += gpio-pxa.o
  obj-$(CONFIG_GPIO_RASPBERRYPI_EXP)    += gpio-raspberrypi-exp.o
  obj-$(CONFIG_GPIO_RB4XX)              += gpio-rb4xx.o
index fa76e0a8229459485cace871eb3897a1bb610b9b..26ced7adfef80f4e9454b59ebf1b55dd164915d9 100644 (file)
@@ -53,7 +53,7 @@ Signed-off-by: Jonathan Bell <jonathan@raspberrypi.org>
        { HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_MULTI_TOUCH), HID_QUIRK_MULTI_INPUT },
        { HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_PIXART_USB_OPTICAL_MOUSE), HID_QUIRK_ALWAYS_POLL },
        { HID_USB_DEVICE(USB_VENDOR_ID_CHICONY, USB_DEVICE_ID_CHICONY_PIXART_USB_OPTICAL_MOUSE2), HID_QUIRK_ALWAYS_POLL },
-@@ -194,6 +195,7 @@ static const struct hid_device_id hid_qu
+@@ -195,6 +196,7 @@ static const struct hid_device_id hid_qu
        { HID_USB_DEVICE(USB_VENDOR_ID_WISEGROUP, USB_DEVICE_ID_QUAD_USB_JOYPAD), HID_QUIRK_NOGET | HID_QUIRK_MULTI_INPUT },
        { HID_USB_DEVICE(USB_VENDOR_ID_XIN_MO, USB_DEVICE_ID_XIN_MO_DUAL_ARCADE), HID_QUIRK_MULTI_INPUT },
        { HID_USB_DEVICE(USB_VENDOR_ID_LOGITECH, USB_DEVICE_ID_LOGITECH_GROUP_AUDIO), HID_QUIRK_NOGET },
index 9d2e2f87c65b37c61c083cf3c865fd412907eab6..2fdef53ea7326003b7c3f2e9a0d4180e0a86079a 100644 (file)
@@ -42,7 +42,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
        depends on MFD_JANZ_CMODIO
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -60,6 +60,7 @@ obj-$(CONFIG_GPIO_EP93XX)            += gpio-ep93x
+@@ -61,6 +61,7 @@ obj-$(CONFIG_GPIO_EP93XX)            += gpio-ep93x
  obj-$(CONFIG_GPIO_EXAR)                       += gpio-exar.o
  obj-$(CONFIG_GPIO_F7188X)             += gpio-f7188x.o
  obj-$(CONFIG_GPIO_FTGPIO010)          += gpio-ftgpio010.o
index cc713731650cbe989c2eab5c36ee318b90a5c007..ec9b1fea3d13cd961beacbe89dc8bef624d475ee 100644 (file)
@@ -27,7 +27,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
  #include <linux/phy/phy.h>
  #include <linux/platform_device.h>
  #include <linux/interrupt.h>
-@@ -427,7 +428,6 @@ static int brcm_usb_phy_probe(struct pla
+@@ -457,7 +458,6 @@ static int brcm_usb_phy_probe(struct pla
        struct device_node *dn = pdev->dev.of_node;
        int err;
        const char *mode;
@@ -35,7 +35,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
        void (*dvr_init)(struct brcm_usb_init_params *params);
        const struct match_chip_info *info;
        struct regmap *rmap;
-@@ -441,8 +441,9 @@ static int brcm_usb_phy_probe(struct pla
+@@ -471,8 +471,9 @@ static int brcm_usb_phy_probe(struct pla
        priv->ini.family_id = brcmstb_get_family_id();
        priv->ini.product_id = brcmstb_get_product_id();
  
index bdc932732c69ab9b94be17c14da3e770ac04e276..ffb064f95fd5af1cd7f297276ef92501d79f455d 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
 
 --- a/drivers/phy/broadcom/phy-brcm-usb.c
 +++ b/drivers/phy/broadcom/phy-brcm-usb.c
-@@ -35,7 +35,7 @@ struct value_to_name_map {
+@@ -36,7 +36,7 @@ struct value_to_name_map {
  };
  
  struct match_chip_info {
@@ -29,7 +29,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
        u8 required_regs[BRCM_REGS_MAX + 1];
        u8 optional_reg;
  };
-@@ -428,7 +428,6 @@ static int brcm_usb_phy_probe(struct pla
+@@ -458,7 +458,6 @@ static int brcm_usb_phy_probe(struct pla
        struct device_node *dn = pdev->dev.of_node;
        int err;
        const char *mode;
@@ -37,7 +37,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
        const struct match_chip_info *info;
        struct regmap *rmap;
        int x;
-@@ -444,8 +443,8 @@ static int brcm_usb_phy_probe(struct pla
+@@ -474,8 +473,8 @@ static int brcm_usb_phy_probe(struct pla
        info = of_device_get_match_data(&pdev->dev);
        if (!info)
                return -ENOENT;
index a2cea0f13890e85684ff1b75e90e93d271292adc..362738c8025519088627a0cc8e432588dbea1cd7 100644 (file)
@@ -35,7 +35,7 @@ Signed-off-by: Vinod Koul <vkoul@kernel.org>
          Enable this to support the Broadcom STB USB PHY.
 --- a/drivers/phy/broadcom/phy-brcm-usb.c
 +++ b/drivers/phy/broadcom/phy-brcm-usb.c
-@@ -287,6 +287,10 @@ static const struct match_chip_info chip
+@@ -317,6 +317,10 @@ static const struct match_chip_info chip
  
  static const struct of_device_id brcm_usb_dt_ids[] = {
        {
diff --git a/target/linux/bcm4908/patches-5.10/180-i2c-brcmstb-fix-support-for-DSL-and-CM-variants.patch b/target/linux/bcm4908/patches-5.10/180-i2c-brcmstb-fix-support-for-DSL-and-CM-variants.patch
deleted file mode 100644 (file)
index 4efe4fa..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From: =?UTF-8?q?Rafa=C5=82=20Mi=C5=82ecki?= <rafal@milecki.pl>
-Date: Tue, 15 Feb 2022 08:27:35 +0100
-Subject: [PATCH] i2c: brcmstb: fix support for DSL and CM variants
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-DSL and CM (Cable Modem) support 8 B max transfer size and have a custom
-DT binding for that reason. This driver was checking for a wrong
-"compatible" however which resulted in an incorrect setup.
-
-Fixes: e2e5a2c61837 ("i2c: brcmstb: Adding support for CM and DSL SoCs")
-Cc: Kamal Dasu <kdasu.kdev@gmail.com>
-Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
-Acked-by: Florian Fainelli <f.fainelli@gmail.com>
----
- drivers/i2c/busses/i2c-brcmstb.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/drivers/i2c/busses/i2c-brcmstb.c
-+++ b/drivers/i2c/busses/i2c-brcmstb.c
-@@ -674,7 +674,7 @@ static int brcmstb_i2c_probe(struct plat
-       /* set the data in/out register size for compatible SoCs */
-       if (of_device_is_compatible(dev->device->of_node,
--                                  "brcmstb,brcmper-i2c"))
-+                                  "brcm,brcmper-i2c"))
-               dev->data_regsz = sizeof(u8);
-       else
-               dev->data_regsz = sizeof(u32);
index 68edf37bf79c426386ce1f9379b0ae9ac958e0f6..d85735531bf2b443e46de6594711e1d19051c7a4 100644 (file)
@@ -20,7 +20,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
 
 --- a/include/net/netns/ipv6.h
 +++ b/include/net/netns/ipv6.h
-@@ -87,6 +87,7 @@ struct netns_ipv6 {
+@@ -88,6 +88,7 @@ struct netns_ipv6 {
        unsigned int            fib6_routes_require_src;
  #endif
        struct rt6_info         *ip6_prohibit_entry;
index 0f1df84b306c0acbf44702222d8db34c6d1041c7..ecd6e9e7a2507d35a74985ee856c11feecb7f7b8 100644 (file)
@@ -164,7 +164,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
  struct rtnl_link {
        rtnl_doit_func          doit;
-@@ -4682,7 +4682,9 @@ int ndo_dflt_bridge_getlink(struct sk_bu
+@@ -4684,7 +4684,9 @@ int ndo_dflt_bridge_getlink(struct sk_bu
            brport_nla_put_flag(skb, flags, mask,
                                IFLA_BRPORT_MCAST_FLOOD, BR_MCAST_FLOOD) ||
            brport_nla_put_flag(skb, flags, mask,
index 8d3b3cf9628e33ba4d64daa00a39c168ea6deb83..af44ff24aca18910106b4e1f8a003c435e95dc17 100644 (file)
@@ -68,13 +68,11 @@ v1 -> v2:
  3 files changed, 133 insertions(+)
  create mode 100644 drivers/gpio/gpio-cascade.c
 
-diff --git a/drivers/gpio/Kconfig b/drivers/gpio/Kconfig
-index 37a6f77c86fe..e69457144459 100644
 --- a/drivers/gpio/Kconfig
 +++ b/drivers/gpio/Kconfig
-@@ -1694,4 +1694,19 @@ config GPIO_VIRTIO
- endmenu
+@@ -1617,4 +1617,19 @@ config GPIO_MOCKUP
+         tools/testing/selftests/gpio/gpio-mockup.sh. Reference the usage in
+         it.
  
 +comment "Other GPIO expanders"
 +
@@ -92,11 +90,9 @@ index 37a6f77c86fe..e69457144459 100644
 +        will be called 'gpio-cascade'.
 +
  endif
-diff --git a/drivers/gpio/Makefile b/drivers/gpio/Makefile
-index 71ee9fc2ff83..e8945456e7ea 100644
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -45,6 +45,7 @@ obj-$(CONFIG_GPIO_BD9571MWV)         += gpio-bd9571mwv.o
+@@ -44,6 +44,7 @@ obj-$(CONFIG_GPIO_BD9571MWV)         += gpio-bd
  obj-$(CONFIG_GPIO_BRCMSTB)            += gpio-brcmstb.o
  obj-$(CONFIG_GPIO_BT8XX)              += gpio-bt8xx.o
  obj-$(CONFIG_GPIO_CADENCE)            += gpio-cadence.o
@@ -104,9 +100,6 @@ index 71ee9fc2ff83..e8945456e7ea 100644
  obj-$(CONFIG_GPIO_CLPS711X)           += gpio-clps711x.o
  obj-$(CONFIG_GPIO_SNPS_CREG)          += gpio-creg-snps.o
  obj-$(CONFIG_GPIO_CRYSTAL_COVE)               += gpio-crystalcove.o
-diff --git a/drivers/gpio/gpio-cascade.c b/drivers/gpio/gpio-cascade.c
-new file mode 100644
-index 000000000000..5cbda882d79a
 --- /dev/null
 +++ b/drivers/gpio/gpio-cascade.c
 @@ -0,0 +1,117 @@
@@ -227,6 +220,3 @@ index 000000000000..5cbda882d79a
 +MODULE_AUTHOR("Mauri Sandberg <maukka@ext.kapsi.fi>");
 +MODULE_DESCRIPTION("Generic GPIO cascade");
 +MODULE_LICENSE("GPL");
--- 
-2.25.1
-
index e43a97bfe8ac3dd73d7ba355945c937cb31d9af7..25cffb1444db784a60fa60764a27fdfc8e64bbca 100644 (file)
@@ -65,7 +65,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4547,6 +4560,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4548,6 +4561,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -75,7 +75,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = qc->hw_tag = tag;
-@@ -5325,6 +5341,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5326,6 +5342,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -85,7 +85,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5360,6 +5379,12 @@ static void ata_host_release(struct kref
+@@ -5361,6 +5380,12 @@ static void ata_host_release(struct kref
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -98,7 +98,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -5766,7 +5791,23 @@ int ata_host_register(struct ata_host *h
+@@ -5767,7 +5792,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
index 6106dfb8dc1212fc7e3d53777c852bfdd34f1061..37501bc64b335db74efed3631ecc732308189bb7 100644 (file)
@@ -16,7 +16,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
 
 --- a/drivers/mtd/nand/raw/qcom_nandc.c
 +++ b/drivers/mtd/nand/raw/qcom_nandc.c
-@@ -159,6 +159,11 @@
+@@ -158,6 +158,11 @@
  /* NAND_CTRL bits */
  #define       BAM_MODE_EN                     BIT(0)
  
@@ -28,7 +28,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
  /*
   * the NAND controller performs reads/writes with ECC in 516 byte chunks.
   * the driver calls the chunks 'step' or 'codeword' interchangeably
-@@ -430,6 +435,13 @@ struct qcom_nand_controller {
+@@ -429,6 +434,13 @@ struct qcom_nand_controller {
   * @cfg0, cfg1, cfg0_raw..:   NANDc register configurations needed for
   *                            ecc/non-ecc mode for the current nand flash
   *                            device
@@ -42,7 +42,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
   */
  struct qcom_nand_host {
        struct nand_chip chip;
-@@ -452,6 +464,9 @@ struct qcom_nand_host {
+@@ -451,6 +463,9 @@ struct qcom_nand_host {
        u32 ecc_bch_cfg;
        u32 clrflashstatus;
        u32 clrreadstatus;
@@ -52,7 +52,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
  };
  
  /*
-@@ -460,12 +475,14 @@ struct qcom_nand_host {
+@@ -459,12 +474,14 @@ struct qcom_nand_host {
   * @ecc_modes - ecc mode for NAND
   * @is_bam - whether NAND controller is using BAM
   * @is_qpic - whether NAND CTRL is part of qpic IP
@@ -67,7 +67,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
        u32 dev_cmd_reg_start;
  };
  
-@@ -1604,7 +1621,7 @@ qcom_nandc_read_cw_raw(struct mtd_info *
+@@ -1603,7 +1620,7 @@ qcom_nandc_read_cw_raw(struct mtd_info *
        data_size1 = mtd->writesize - host->cw_size * (ecc->steps - 1);
        oob_size1 = host->bbm_size;
  
@@ -76,7 +76,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
                data_size2 = ecc->size - data_size1 -
                             ((ecc->steps - 1) * 4);
                oob_size2 = (ecc->steps * 4) + host->ecc_bytes_hw +
-@@ -1685,7 +1702,7 @@ check_for_erased_page(struct qcom_nand_h
+@@ -1684,7 +1701,7 @@ check_for_erased_page(struct qcom_nand_h
        }
  
        for_each_set_bit(cw, &uncorrectable_cws, ecc->steps) {
@@ -85,7 +85,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
                        data_size = ecc->size - ((ecc->steps - 1) * 4);
                        oob_size = (ecc->steps * 4) + host->ecc_bytes_hw;
                } else {
-@@ -1844,7 +1861,7 @@ static int read_page_ecc(struct qcom_nan
+@@ -1843,7 +1860,7 @@ static int read_page_ecc(struct qcom_nan
        for (i = 0; i < ecc->steps; i++) {
                int data_size, oob_size;
  
@@ -94,7 +94,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
                        data_size = ecc->size - ((ecc->steps - 1) << 2);
                        oob_size = (ecc->steps << 2) + host->ecc_bytes_hw +
                                   host->spare_bytes;
-@@ -1941,6 +1958,30 @@ static int copy_last_cw(struct qcom_nand
+@@ -1940,6 +1957,30 @@ static int copy_last_cw(struct qcom_nand
        return ret;
  }
  
@@ -125,7 +125,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
  /* implements ecc->read_page() */
  static int qcom_nandc_read_page(struct nand_chip *chip, uint8_t *buf,
                                int oob_required, int page)
-@@ -1949,6 +1990,9 @@ static int qcom_nandc_read_page(struct n
+@@ -1948,6 +1989,9 @@ static int qcom_nandc_read_page(struct n
        struct qcom_nand_controller *nandc = get_qcom_nand_controller(chip);
        u8 *data_buf, *oob_buf = NULL;
  
@@ -135,7 +135,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
        nand_read_page_op(chip, page, 0, NULL, 0);
        data_buf = buf;
        oob_buf = oob_required ? chip->oob_poi : NULL;
-@@ -1968,6 +2012,9 @@ static int qcom_nandc_read_page_raw(stru
+@@ -1967,6 +2011,9 @@ static int qcom_nandc_read_page_raw(stru
        int cw, ret;
        u8 *data_buf = buf, *oob_buf = chip->oob_poi;
  
@@ -145,7 +145,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
        for (cw = 0; cw < ecc->steps; cw++) {
                ret = qcom_nandc_read_cw_raw(mtd, chip, data_buf, oob_buf,
                                             page, cw);
-@@ -1988,6 +2035,9 @@ static int qcom_nandc_read_oob(struct na
+@@ -1987,6 +2034,9 @@ static int qcom_nandc_read_oob(struct na
        struct qcom_nand_controller *nandc = get_qcom_nand_controller(chip);
        struct nand_ecc_ctrl *ecc = &chip->ecc;
  
@@ -155,7 +155,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
        clear_read_regs(nandc);
        clear_bam_transaction(nandc);
  
-@@ -2008,6 +2058,9 @@ static int qcom_nandc_write_page(struct
+@@ -2007,6 +2057,9 @@ static int qcom_nandc_write_page(struct
        u8 *data_buf, *oob_buf;
        int i, ret;
  
@@ -165,7 +165,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
        nand_prog_page_begin_op(chip, page, 0, NULL, 0);
  
        clear_read_regs(nandc);
-@@ -2023,7 +2076,7 @@ static int qcom_nandc_write_page(struct
+@@ -2022,7 +2075,7 @@ static int qcom_nandc_write_page(struct
        for (i = 0; i < ecc->steps; i++) {
                int data_size, oob_size;
  
@@ -174,7 +174,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
                        data_size = ecc->size - ((ecc->steps - 1) << 2);
                        oob_size = (ecc->steps << 2) + host->ecc_bytes_hw +
                                   host->spare_bytes;
-@@ -2080,6 +2133,9 @@ static int qcom_nandc_write_page_raw(str
+@@ -2079,6 +2132,9 @@ static int qcom_nandc_write_page_raw(str
        u8 *data_buf, *oob_buf;
        int i, ret;
  
@@ -184,7 +184,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
        nand_prog_page_begin_op(chip, page, 0, NULL, 0);
        clear_read_regs(nandc);
        clear_bam_transaction(nandc);
-@@ -2098,7 +2154,7 @@ static int qcom_nandc_write_page_raw(str
+@@ -2097,7 +2153,7 @@ static int qcom_nandc_write_page_raw(str
                data_size1 = mtd->writesize - host->cw_size * (ecc->steps - 1);
                oob_size1 = host->bbm_size;
  
@@ -193,7 +193,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
                        data_size2 = ecc->size - data_size1 -
                                     ((ecc->steps - 1) << 2);
                        oob_size2 = (ecc->steps << 2) + host->ecc_bytes_hw +
-@@ -2158,6 +2214,9 @@ static int qcom_nandc_write_oob(struct n
+@@ -2157,6 +2213,9 @@ static int qcom_nandc_write_oob(struct n
        int data_size, oob_size;
        int ret;
  
@@ -203,7 +203,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
        host->use_ecc = true;
        clear_bam_transaction(nandc);
  
-@@ -2806,6 +2865,7 @@ static int qcom_nand_host_init_and_regis
+@@ -2805,6 +2864,7 @@ static int qcom_nand_host_init_and_regis
        struct nand_chip *chip = &host->chip;
        struct mtd_info *mtd = nand_to_mtd(chip);
        struct device *dev = nandc->dev;
@@ -211,7 +211,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
        int ret;
  
        ret = of_property_read_u32(dn, "reg", &host->cs);
-@@ -2866,6 +2926,17 @@ static int qcom_nand_host_init_and_regis
+@@ -2865,6 +2925,17 @@ static int qcom_nand_host_init_and_regis
        if (ret)
                nand_cleanup(chip);
  
@@ -229,7 +229,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
        return ret;
  }
  
-@@ -3032,6 +3103,7 @@ static int qcom_nandc_remove(struct plat
+@@ -3030,6 +3101,7 @@ static int qcom_nandc_remove(struct plat
  static const struct qcom_nandc_props ipq806x_nandc_props = {
        .ecc_modes = (ECC_RS_4BIT | ECC_BCH_8BIT),
        .is_bam = false,
index 61c0c045a68ea9d389d145e97fb6fa2b5488e87b..84d418887c0913f05b45f7854de727a27245001b 100644 (file)
@@ -15,7 +15,7 @@
        /* initialize internal qc */
        qc = __ata_qc_from_tag(ap, ATA_TAG_INTERNAL);
  
-@@ -4554,6 +4562,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4555,6 +4563,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
@@ -25,7 +25,7 @@
        /* libsas case */
        if (ap->flags & ATA_FLAG_SAS_HOST) {
                tag = ata_sas_allocate_tag(ap);
-@@ -4599,6 +4610,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -4600,6 +4611,8 @@ void ata_qc_free(struct ata_queued_cmd *
                qc->tag = ATA_TAG_POISON;
                if (ap->flags & ATA_FLAG_SAS_HOST)
                        ata_sas_free_tag(tag, ap);
index c173336924d26e035fce17c6d5b7329c367a0bb7..52d40215f20d5b24a995eb2f1bf2a03abe3ef5d6 100644 (file)
@@ -62,7 +62,7 @@ Cc: linux-gpio@vger.kernel.org
        depends on PLAT_SPEAR
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -119,6 +119,7 @@ obj-$(CONFIG_GPIO_PISOSR)          += gpio-pisos
+@@ -120,6 +120,7 @@ obj-$(CONFIG_GPIO_PISOSR)          += gpio-pisos
  obj-$(CONFIG_GPIO_PL061)              += gpio-pl061.o
  obj-$(CONFIG_GPIO_PMIC_EIC_SPRD)      += gpio-pmic-eic-sprd.o
  obj-$(CONFIG_GPIO_PXA)                        += gpio-pxa.o
index fc138242828697442004b912215ecfd61179bdf8..62e4338cbb27c1012bfba841d206e75c49a700fa 100644 (file)
@@ -56,7 +56,7 @@ Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com>
        help
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -124,6 +124,7 @@ obj-$(CONFIG_GPIO_RC5T583)         += gpio-rc5t
+@@ -125,6 +125,7 @@ obj-$(CONFIG_GPIO_RC5T583)         += gpio-rc5t
  obj-$(CONFIG_GPIO_RCAR)                       += gpio-rcar.o
  obj-$(CONFIG_GPIO_RDA)                        += gpio-rda.o
  obj-$(CONFIG_GPIO_RDC321X)            += gpio-rdc321x.o
index cdecb2a112e14daf2f46b0dcec9b4b49be6ad13f..9175b55e8e1001f5986c566a7eb2e77116719c78 100644 (file)
@@ -15,7 +15,7 @@
        depends on MFD_SYSCON
 --- a/drivers/gpio/Makefile
 +++ b/drivers/gpio/Makefile
-@@ -126,6 +126,7 @@ obj-$(CONFIG_GPIO_RDA)                     += gpio-rda.o
+@@ -127,6 +127,7 @@ obj-$(CONFIG_GPIO_RDA)                     += gpio-rda.o
  obj-$(CONFIG_GPIO_RDC321X)            += gpio-rdc321x.o
  obj-$(CONFIG_GPIO_REALTEK_OTTO)               += gpio-realtek-otto.o
  obj-$(CONFIG_GPIO_REG)                        += gpio-reg.o