atheros: remove odd ATHEROS_AR2315 config symbol dependencies
authorJohn Crispin <john@openwrt.org>
Fri, 12 Sep 2014 06:52:42 +0000 (06:52 +0000)
committerJohn Crispin <john@openwrt.org>
Fri, 12 Sep 2014 06:52:42 +0000 (06:52 +0000)
Remove options which already selected by ATHEROS_AR231X on which
ATHEROS_AR2315 depends.

Signed-off-by: Sergey Ryazanov <ryazanov.s.a@gmail.com>
SVN-Revision: 42497

target/linux/atheros/patches-3.14/100-board.patch
target/linux/atheros/patches-3.14/105-ar2315_pci.patch

index 4840813669cb3d6ea82a43cc9ab1b2ed2bc13d64..7b1adbd711370964fd7ca2d483f76f38483fbe7f 100644 (file)
@@ -49,7 +49,7 @@
 +load-$(CONFIG_ATHEROS_AR231X)          += 0xffffffff80041000
 --- /dev/null
 +++ b/arch/mips/ar231x/Kconfig
 +load-$(CONFIG_ATHEROS_AR231X)          += 0xffffffff80041000
 --- /dev/null
 +++ b/arch/mips/ar231x/Kconfig
-@@ -0,0 +1,16 @@
+@@ -0,0 +1,9 @@
 +config ATHEROS_AR5312
 +      bool "Atheros 5312/2312+ support"
 +      depends on ATHEROS_AR231X
 +config ATHEROS_AR5312
 +      bool "Atheros 5312/2312+ support"
 +      depends on ATHEROS_AR231X
 +config ATHEROS_AR2315
 +      bool "Atheros 2315+ support"
 +      depends on ATHEROS_AR231X
 +config ATHEROS_AR2315
 +      bool "Atheros 2315+ support"
 +      depends on ATHEROS_AR231X
-+      select DMA_NONCOHERENT
-+      select CEVT_R4K
-+      select CSRC_R4K
-+      select IRQ_CPU
-+      select SYS_HAS_CPU_MIPS32_R1
-+      select SYS_SUPPORTS_32BIT_KERNEL
-+      select SYS_SUPPORTS_BIG_ENDIAN
 +      default y
 --- /dev/null
 +++ b/arch/mips/ar231x/Makefile
 +      default y
 --- /dev/null
 +++ b/arch/mips/ar231x/Makefile
index 53222a1af205f1c1b509461954e5b51e366c5048..14862c9e5e2b1ec93d5fc259208e5d21fa2037b1 100644 (file)
 +arch_initcall(ar2315_pci_init);
 --- a/arch/mips/ar231x/Kconfig
 +++ b/arch/mips/ar231x/Kconfig
 +arch_initcall(ar2315_pci_init);
 --- a/arch/mips/ar231x/Kconfig
 +++ b/arch/mips/ar231x/Kconfig
-@@ -14,3 +14,10 @@ config ATHEROS_AR2315
-       select SYS_SUPPORTS_32BIT_KERNEL
-       select SYS_SUPPORTS_BIG_ENDIAN
+@@ -7,3 +7,10 @@ config ATHEROS_AR2315
+       bool "Atheros 2315+ support"
+       depends on ATHEROS_AR231X
        default y
 +
 +config ATHEROS_AR2315_PCI
        default y
 +
 +config ATHEROS_AR2315_PCI