mvebu: move subtarget image Makefile switch to parent Makefile
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 18 Jan 2020 01:21:11 +0000 (02:21 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 21 Jan 2020 13:18:07 +0000 (14:18 +0100)
This moves the if conditions for choosing which image Makefiles
are used to the parent image/Makefile. It seems more convenient
to have "codeflow" in the parent while the subtarget-specific
files only contain the definitions.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Acked-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
target/linux/mvebu/image/Makefile
target/linux/mvebu/image/cortex-a53.mk
target/linux/mvebu/image/cortex-a72.mk
target/linux/mvebu/image/cortex-a9.mk

index ce1344a5470e8b74f4a7c6347b6c488e8d898764..6dd7bde7ae73c646812b64b1e2ab5a902f1ea179 100644 (file)
@@ -116,8 +116,16 @@ define Device/NAND-512K
   PAGESIZE := 4096
 endef
 
+ifeq ($(SUBTARGET),cortexa9)
 include cortex-a9.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa53)
 include cortex-a53.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa72)
 include cortex-a72.mk
+endif
 
 $(eval $(call BuildImage))
index f5313429affc02a6bc5e954258c65a5c7653aecb..e58a3c42b9c19394941775e794296c84b607b7fc 100644 (file)
@@ -1,5 +1,3 @@
-ifeq ($(SUBTARGET),cortexa53)
-
 define Device/globalscale_espressobin
   $(call Device/Default-arm64)
   DEVICE_VENDOR := Marvell
@@ -73,5 +71,3 @@ define Device/methode_udpu
   BOOT_SCRIPT := udpu
 endef
 TARGET_DEVICES += methode_udpu
-
-endif
index 5e619804e810039e94cb52783697e4ce0d2b5067..6abee2d8b90296fea0aa3ab1b394c10cd7e37967 100644 (file)
@@ -1,5 +1,3 @@
-ifeq ($(SUBTARGET),cortexa72)
-
 define Device/marvell_macchiatobin
   $(call Device/Default-arm64)
   DEVICE_VENDOR := SolidRun
@@ -29,5 +27,3 @@ define Device/marvell_armada7040-db
   IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
 endef
 TARGET_DEVICES += marvell_armada7040-db
-
-endif
index c2ada75c2d21c37e166d4bb7072d53c3075f38af..389082e4263b73416c824376e064894eba610a3a 100644 (file)
@@ -6,8 +6,6 @@
 # See /LICENSE for more information.
 #
 
-ifeq ($(SUBTARGET),cortexa9)
-
 define Device/linksys
   $(Device/NAND-128K)
   DEVICE_VENDOR := Linksys
@@ -218,5 +216,3 @@ define Device/cznic_turris-omnia
   SUPPORTED_DEVICES += armada-385-turris-omnia
 endef
 TARGET_DEVICES += cznic_turris-omnia
-
-endif