comgt: support ZTE MF286R modem
authorCezary Jackiewicz <cezary@eko.one.pl>
Sun, 27 Feb 2022 13:12:39 +0000 (14:12 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Apr 2022 19:31:02 +0000 (21:31 +0200)
The modem is based on Marvell PXA1826 and uses ACM+RNDIS interface to
establish connection with custom commands specific to ZTE modems.
Two variants of modems were discovered, some identifying themselves
as "ZTE", and others as plain "Marvell", the chipset manufacturer.
The modem itself runs a fork of OpenWrt inside, which root shell can be
accessed via ADB interface.

Signed-off-by: Cezary Jackiewicz <cezary@eko.one.pl>
Signed-off-by: Lech Perczak <lech.perczak@gmail.com>
(cherry picked from commit e02fb42c53bad5dd36726c6ef5a46bfe31d2e400)

package/network/utils/comgt/Makefile
package/network/utils/comgt/files/ncm.json

index db5ea5747357069acc131c1a2bf75a44f2e9adfd..24dae2521e392b37fd2c41d65c18e048f06c5a27 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=33
+PKG_RELEASE:=34
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
index bbdb30c5eeb4d092eecd081a6d815b259a05ac0f..b6ad71752910d1072de0252362e2040a97fd2db4 100644 (file)
                "connect": "AT+CGACT=1,${profile}",
                "finalize": "AT+CGDATA=\\\"M-MBIM\\\",${profile},1",
                "disconnect": "AT+CGACT=0,${profile}"
+       },
+       "\"zte": {
+               "initialize": [
+                       "AT+CFUN=1"
+               ],
+               "configure": [
+                       "AT+ZGDCONT=${profile},\\\"${pdptype}\\\",\\\"${apn}\\\",\\\"\\\",0,0",
+                       "AT+ZGPCOAUTH=${profile},\\\"${username}\\\",\\\"${password}\\\",0"
+               ],
+               "connect": "AT+ZGACT=1,${profile}",
+               "disconnect": "AT+ZGACT=0,${profile}"
+       },
+       "\"marvell\"": {
+               "initialize": [
+                       "AT+CFUN=1"
+               ],
+               "configure": [
+                       "AT+ZGDCONT=${profile},\\\"${pdptype}\\\",\\\"${apn}\\\",\\\"\\\",0,0",
+                       "AT+ZGPCOAUTH=${profile},\\\"${username}\\\",\\\"${password}\\\",0"
+               ],
+               "connect": "AT+ZGACT=1,${profile}",
+               "disconnect": "AT+ZGACT=0,${profile}"
        }
 }