ar71xx: set mips16 support, tune cflags for 34kc (works well on MIPS 24K as well...
authorFelix Fietkau <nbd@openwrt.org>
Thu, 9 May 2013 23:32:46 +0000 (23:32 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 9 May 2013 23:32:46 +0000 (23:32 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 36600

target/linux/ar71xx/Makefile

index 83b238e5842ecf939eb851865bfbd634b0bac3f8..600b21d430d808c90bddcbc53f0eaf5aaa600f34 100644 (file)
@@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
+FEATURES:=squashfs jffs2 targz mips16
+CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -fno-caller-saves -mno-branch-likely
 SUBTARGETS:=generic nand
 
 LINUX_VERSION:=3.8.12