fix hostapd (add missed changes from [3564])
authorNicolas Thill <nico@openwrt.org>
Sat, 1 Apr 2006 20:30:35 +0000 (20:30 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 1 Apr 2006 20:30:35 +0000 (20:30 +0000)
SVN-Revision: 3575

openwrt/package/Makefile
openwrt/package/depend.mk

index 09df4fe2b9ba134642ef3a1592fda2ba185b93fa..cae4609338201f97e7ece2f5e2ed4b761b467631 100644 (file)
@@ -69,7 +69,7 @@ package-$(BR2_COMPILE_GSM) += gsm
 package-$(BR2_PACKAGE_HASERL) += haserl
 package-$(BR2_PACKAGE_HEYU) += heyu
 package-$(BR2_PACKAGE_HOSTAP_UTILS) += hostap-utils
-package-$(BR2_PACKAGE_HOSTAPD) += hostapd
+package-$(BR2_COMPILE_HOSTAPD) += hostapd
 package-$(BR2_COMPILE_HOWL) += howl
 package-$(BR2_PACKAGE_HTPDATE) += htpdate
 package-$(BR2_PACKAGE_HTTPING) += httping
index f973391c85a2e95e3fa2b722faf62e72c7d35a4b..6ed55179bd4bad48e00428acd446baf5f4bdee88 100644 (file)
@@ -29,7 +29,6 @@ iptables-snmp-compile: net-snmp-compile
 iptraf-compile: ncurses-compile
 ipsec-tools-compile: openssl-compile
 jamvm-compile: libffi-sable-compile zlib-compile sablevm-classpath-compile
-hostapd-compile: openssl-compile wireless-tools-compile
 httping-compile: openssl-compile
 kismet-compile: uclibc++-compile libpcap-compile ncurses-compile
 l2tpns-compile: libcli-compile
@@ -138,6 +137,11 @@ ifneq ($(BR2_PACKAGE_FREERADIUS_MOD_SQL_PGSQL),)
 freeradius-compile: postgresql-compile
 endif
 
+hostapd-compile: wireless-tools-compile
+ifneq ($(BR2_PACKAGE_HOSTAPD),)
+hostapd-compile: openssl-compile
+endif
+
 ifneq ($(BR2_PACKAGE_MINI_HTTPD_MATRIXSSL),)
 mini_httpd-compile: matrixssl-compile
 endif