ar71xx: add support for ALFA Network AP121F
authorPiotr Dymacz <pepe2k@gmail.com>
Fri, 31 Mar 2017 11:37:31 +0000 (13:37 +0200)
committerPiotr Dymacz <pepe2k@gmail.com>
Sat, 22 Jul 2017 21:13:55 +0000 (23:13 +0200)
ALFA Network AP121F is a pocket-size router dedicated for VPN/TOR users.
Device is based on Atheros AR9331 WiSoC and is running a custom version
(updated from OpenWrt CC to LEDE 17.01 release) of NetAidKit firmware.

Specification:

- 400/400/200 MHz (CPU/DDR/AHB)
- 64 MB of RAM (DDR1)
- 16 MB of FLASH (SPI NOR)
- 1x 10/100 Mbps Ethernet
- 1T1R 2.4 GHz
- 1x microSD (optional, on separate PCB)
- 3x LED, 1x button, 1x switch
- UART header on PCB

Flash instruction (under U-Boot web recovery mode):

1. Configure PC with static IP 192.168.1.2/24.
2. Connect PC with RJ45 port, press the reset button, power up device,
   wait for first blink of all LEDs (indicates network setup), then keep
   button for 3 following blinks and release it.
3. Open 192.168.1.1 address in your browser and upload sysupgrade image.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
13 files changed:
target/linux/ar71xx/base-files/etc/board.d/01_leds
target/linux/ar71xx/base-files/etc/board.d/02_network
target/linux/ar71xx/base-files/etc/diag.sh
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-4.4
target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
target/linux/ar71xx/files/arch/mips/ath79/Makefile
target/linux/ar71xx/files/arch/mips/ath79/mach-ap121f.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
target/linux/ar71xx/image/generic.mk
target/linux/ar71xx/mikrotik/config-default
target/linux/ar71xx/nand/config-default

index 8eaa892b4aeb2972197f33b6bd29265c10b91dd5..84b1a7dfd966027c1b5e8780a32222bb2fa4835f 100755 (executable)
@@ -48,6 +48,10 @@ antrouter-r1)
        ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
        ucidef_set_led_default "btc" "BTC" "$board:green:btc" "0"
        ;;
        ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
        ucidef_set_led_default "btc" "BTC" "$board:green:btc" "0"
        ;;
+ap121f)
+       ucidef_set_led_netdev "lan" "LAN" "$board:green:lan" "eth0"
+       ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
+       ;;
 ap531b0|\
 sc1750|\
 sc450)
 ap531b0|\
 sc1750|\
 sc450)
index b2126c0c94818035c5798d55bb09c69a8949d101..5889b2bf803d1fbf8f64b7689cb33c5c403ffdbc 100755 (executable)
@@ -63,6 +63,7 @@ ar71xx_setup_interfaces()
        antminer-s1|\
        antminer-s3|\
        antrouter-r1|\
        antminer-s1|\
        antminer-s3|\
        antrouter-r1|\
+       ap121f|\
        aw-nr580|\
        bullet-m|\
        c-55|\
        aw-nr580|\
        bullet-m|\
        c-55|\
index 75f0826859fc363c69c50fc1b1b0c0399440b260..7753a7156dee2252d9eb7d3c7d08a4e25edfdd14 100644 (file)
@@ -30,6 +30,9 @@ get_status_led() {
        xd3200)
                status_led="$board:green:system"
                ;;
        xd3200)
                status_led="$board:green:system"
                ;;
+       ap121f)
+               status_led="$board:green:vpn"
+               ;;
        ap132|\
        ap531b0|\
        cpe505n|\
        ap132|\
        ap531b0|\
        cpe505n|\
index 5c29a3f0d085abbb334b4908315f729929b16eaf..7fd5fb452281dfde79f5c28907fb32f402aa5626 100755 (executable)
@@ -416,6 +416,9 @@ ar71xx_board_detect() {
        *"AP121-MINI")
                name="ap121-mini"
                ;;
        *"AP121-MINI")
                name="ap121-mini"
                ;;
+       *"AP121F")
+               name="ap121f"
+               ;;
        *"AP132 reference board")
                name="ap132"
                ;;
        *"AP132 reference board")
                name="ap132"
                ;;
index 949cb6aed58d0a4992f6b270e7b4db2d4fa95388..05b5634aa51dfeae0f53ba274fd64dde611fd5a7 100755 (executable)
@@ -203,6 +203,7 @@ platform_check_image() {
        airgatewaypro|\
        airgateway|\
        airrouter|\
        airgatewaypro|\
        airgateway|\
        airrouter|\
+       ap121f|\
        ap132|\
        ap531b0|\
        ap90q|\
        ap132|\
        ap531b0|\
        ap90q|\
index e8d907fcd3600a06d0fb3b8f429f07dc408f0d85..70793af3a357f17d3b6918b07237df5fbb510cbf 100644 (file)
@@ -42,6 +42,7 @@ CONFIG_ATH79_MACH_ANTMINER_S1=y
 CONFIG_ATH79_MACH_ANTMINER_S3=y
 CONFIG_ATH79_MACH_ANTROUTER_R1=y
 CONFIG_ATH79_MACH_AP121=y
 CONFIG_ATH79_MACH_ANTMINER_S3=y
 CONFIG_ATH79_MACH_ANTROUTER_R1=y
 CONFIG_ATH79_MACH_AP121=y
+CONFIG_ATH79_MACH_AP121F=y
 CONFIG_ATH79_MACH_AP132=y
 CONFIG_ATH79_MACH_AP136=y
 CONFIG_ATH79_MACH_AP143=y
 CONFIG_ATH79_MACH_AP132=y
 CONFIG_ATH79_MACH_AP136=y
 CONFIG_ATH79_MACH_AP143=y
index 055dddf33d5f61fcf5f53e3689855bb79ae482f3..ff9c3037a1424af8224f96b88a8024098ba05ee0 100644 (file)
@@ -16,6 +16,16 @@ config ATH79_MACH_ALFA_AP120C
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
 
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
 
+config ATH79_MACH_AP121F
+       bool "ALFA Network AP121F support"
+       select SOC_AR933X
+       select ATH79_DEV_ETH
+       select ATH79_DEV_GPIO_BUTTONS
+       select ATH79_DEV_LEDS_GPIO
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_USB
+       select ATH79_DEV_WMAC
+
 config ATH79_MACH_ALFA_AP96
        bool "ALFA Network AP96 board support"
        select SOC_AR71XX
 config ATH79_MACH_ALFA_AP96
        bool "ALFA Network AP96 board support"
        select SOC_AR71XX
index 3f589f7e2e74a1223f4ceb23c6aa4a25f2fccb0a..469b6a794c669d1db0daa49f8c829e8d3fe81c24 100644 (file)
@@ -48,6 +48,7 @@ obj-$(CONFIG_ATH79_MACH_ANTMINER_S1)          += mach-antminer-s1.o
 obj-$(CONFIG_ATH79_MACH_ANTMINER_S3)           += mach-antminer-s3.o
 obj-$(CONFIG_ATH79_MACH_ANTROUTER_R1)          += mach-antrouter-r1.o
 obj-$(CONFIG_ATH79_MACH_AP121)                 += mach-ap121.o
 obj-$(CONFIG_ATH79_MACH_ANTMINER_S3)           += mach-antminer-s3.o
 obj-$(CONFIG_ATH79_MACH_ANTROUTER_R1)          += mach-antrouter-r1.o
 obj-$(CONFIG_ATH79_MACH_AP121)                 += mach-ap121.o
+obj-$(CONFIG_ATH79_MACH_AP121F)                        += mach-ap121f.o
 obj-$(CONFIG_ATH79_MACH_AP132)                 += mach-ap132.o
 obj-$(CONFIG_ATH79_MACH_AP136)                 += mach-ap136.o
 obj-$(CONFIG_ATH79_MACH_AP143)                 += mach-ap143.o
 obj-$(CONFIG_ATH79_MACH_AP132)                 += mach-ap132.o
 obj-$(CONFIG_ATH79_MACH_AP136)                 += mach-ap136.o
 obj-$(CONFIG_ATH79_MACH_AP143)                 += mach-ap143.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-ap121f.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-ap121f.c
new file mode 100644 (file)
index 0000000..955b7fa
--- /dev/null
@@ -0,0 +1,103 @@
+/*
+ * ALFA Network AP121F board support
+ *
+ * Copyright (C) 2017 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define AP121F_GPIO_LED_LAN    17
+#define AP121F_GPIO_LED_VPN    27
+#define AP121F_GPIO_LED_WLAN   0
+
+#define AP121F_GPIO_MICROSD_EN 26
+
+#define AP121F_GPIO_BTN_RESET  12
+#define AP121F_GPIO_BTN_SWITCH 21
+
+#define AP121F_KEYS_POLL_INTERVAL      20
+#define AP121F_KEYS_DEBOUNCE_INTERVAL  (3 * AP121F_KEYS_POLL_INTERVAL)
+
+#define AP121F_WMAC_CALDATA_OFFSET     0x1000
+
+static struct gpio_led ap121f_leds_gpio[] __initdata = {
+       {
+               .name           = "ap121f:green:lan",
+               .gpio           = AP121F_GPIO_LED_LAN,
+               .active_low     = 1,
+       }, {
+               .name           = "ap121f:green:vpn",
+               .gpio           = AP121F_GPIO_LED_VPN,
+               .active_low     = 1,
+       }, {
+               .name           = "ap121f:green:wlan",
+               .gpio           = AP121F_GPIO_LED_WLAN,
+               .active_low     = 0,
+       },
+};
+
+static struct gpio_keys_button ap121f_gpio_keys[] __initdata = {
+       {
+               .desc                   = "reset",
+               .type                   = EV_KEY,
+               .code                   = KEY_RESTART,
+               .debounce_interval      = AP121F_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = AP121F_GPIO_BTN_RESET,
+               .active_low             = 1,
+       }, {
+               .desc                   = "switch",
+               .type                   = EV_KEY,
+               .code                   = BTN_0,
+               .debounce_interval      = AP121F_KEYS_DEBOUNCE_INTERVAL,
+               .gpio                   = AP121F_GPIO_BTN_SWITCH,
+               .active_low             = 0,
+       },
+};
+
+static void __init ap121f_setup(void)
+{
+       u8 *art = (u8 *) KSEG1ADDR(0x1f040000);
+
+       ath79_register_m25p80(NULL);
+
+       ath79_setup_ar933x_phy4_switch(false, false);
+
+       /* LAN */
+       ath79_register_mdio(0, 0x0);
+       ath79_init_mac(ath79_eth0_data.mac_addr, art, 0);
+       ath79_register_eth(0);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(ap121f_leds_gpio),
+                                ap121f_leds_gpio);
+
+       ath79_register_gpio_keys_polled(-1, AP121F_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(ap121f_gpio_keys),
+                                       ap121f_gpio_keys);
+
+       gpio_request_one(AP121F_GPIO_MICROSD_EN,
+                        GPIOF_OUT_INIT_HIGH | GPIOF_EXPORT_DIR_FIXED,
+                        "microSD enable");
+
+       ath79_register_wmac(art + AP121F_WMAC_CALDATA_OFFSET, NULL);
+
+       ath79_register_usb();
+}
+
+MIPS_MACHINE(ATH79_MACH_AP121F, "AP121F", "ALFA Network AP121F", ap121f_setup);
index 0b70256338a4e80acc4e6800cb2499d93490b787..5bc50a42ffd718433e60f178e8f451bfcbb2ffd0 100644 (file)
@@ -30,6 +30,7 @@ enum ath79_mach_type {
        ATH79_MACH_ANTROUTER_R1,                /* Antrouter R1 */
        ATH79_MACH_AP121,                       /* Atheros AP121 reference board */
        ATH79_MACH_AP121_MINI,                  /* Atheros AP121-MINI reference board */
        ATH79_MACH_ANTROUTER_R1,                /* Antrouter R1 */
        ATH79_MACH_AP121,                       /* Atheros AP121 reference board */
        ATH79_MACH_AP121_MINI,                  /* Atheros AP121-MINI reference board */
+       ATH79_MACH_AP121F,                      /* ALFA Network AP121F */
        ATH79_MACH_AP132,                       /* Atheros AP132 reference board */
        ATH79_MACH_AP135_020,                   /* Atheros AP135-020 reference board */
        ATH79_MACH_AP136_010,                   /* Atheros AP136-010 reference board */
        ATH79_MACH_AP132,                       /* Atheros AP132 reference board */
        ATH79_MACH_AP135_020,                   /* Atheros AP135-020 reference board */
        ATH79_MACH_AP136_010,                   /* Atheros AP136-010 reference board */
index 3f1486ed63bb511c7f521ca74de65fc0a5b7fbea..01c5bdc6772604da35f02143c06db87113b732a1 100644 (file)
@@ -75,6 +75,19 @@ define Build/wrgg-pad-rootfs
 endef
 
 
 endef
 
 
+define Device/ap121f
+  DEVICE_TITLE := ALFA Network AP121F
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage -swconfig
+  BOARDNAME := AP121F
+  IMAGE_SIZE := 16064k
+  CONSOLE := ttyATH0,115200
+  MTDPARTS := spi0.0:192k(u-boot)ro,64k(u-boot-env),64k(art)ro,-(firmware)
+  SUPPORTED_DEVICES := ap121f
+  IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \
+       append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += ap121f
+
 define Device/ap531b0
   DEVICE_TITLE := Rockeetech AP531B0
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2
 define Device/ap531b0
   DEVICE_TITLE := Rockeetech AP531B0
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2
index 6c81bc2de51758a792f6dea179e088d56e709149..34c2fc1f0fd3c6a75deb70801352a5c3b710e260 100644 (file)
@@ -9,6 +9,7 @@
 # CONFIG_ATH79_MACH_ANTMINER_S3 is not set
 # CONFIG_ATH79_MACH_ANTROUTER_R1 is not set
 # CONFIG_ATH79_MACH_AP121 is not set
 # CONFIG_ATH79_MACH_ANTMINER_S3 is not set
 # CONFIG_ATH79_MACH_ANTROUTER_R1 is not set
 # CONFIG_ATH79_MACH_AP121 is not set
+# CONFIG_ATH79_MACH_AP121F is not set
 # CONFIG_ATH79_MACH_AP132 is not set
 # CONFIG_ATH79_MACH_AP136 is not set
 # CONFIG_ATH79_MACH_AP143 is not set
 # CONFIG_ATH79_MACH_AP132 is not set
 # CONFIG_ATH79_MACH_AP136 is not set
 # CONFIG_ATH79_MACH_AP143 is not set
index 6eff5d0b28fd7967e3251c4881c10d591dd1d6b6..57318b38e8bf051063482264ee4a00ad19a57d05 100644 (file)
@@ -8,6 +8,7 @@
 # CONFIG_ATH79_MACH_ANTMINER_S3 is not set
 # CONFIG_ATH79_MACH_ANTROUTER_R1 is not set
 # CONFIG_ATH79_MACH_AP121 is not set
 # CONFIG_ATH79_MACH_ANTMINER_S3 is not set
 # CONFIG_ATH79_MACH_ANTROUTER_R1 is not set
 # CONFIG_ATH79_MACH_AP121 is not set
+# CONFIG_ATH79_MACH_AP121F is not set
 # CONFIG_ATH79_MACH_AP132 is not set
 # CONFIG_ATH79_MACH_AP136 is not set
 # CONFIG_ATH79_MACH_AP143 is not set
 # CONFIG_ATH79_MACH_AP132 is not set
 # CONFIG_ATH79_MACH_AP136 is not set
 # CONFIG_ATH79_MACH_AP143 is not set