add aiccu, bwm, ntpclient and radvd (from Sebastian Noel)
authorFelix Fietkau <nbd@openwrt.org>
Mon, 4 Apr 2005 22:12:17 +0000 (22:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 4 Apr 2005 22:12:17 +0000 (22:12 +0000)
SVN-Revision: 562

19 files changed:
openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/aiccu/Config.in [new file with mode: 0644]
openwrt/package/aiccu/Makefile [new file with mode: 0644]
openwrt/package/aiccu/aiccu.control [new file with mode: 0644]
openwrt/package/aiccu/files/S51aiccu [new file with mode: 0755]
openwrt/package/bwm/Config.in [new file with mode: 0644]
openwrt/package/bwm/Makefile [new file with mode: 0644]
openwrt/package/bwm/bwm.control [new file with mode: 0644]
openwrt/package/ntpclient/Config.in [new file with mode: 0644]
openwrt/package/ntpclient/Makefile [new file with mode: 0644]
openwrt/package/ntpclient/files/S41ntpclient [new file with mode: 0755]
openwrt/package/ntpclient/ntpclient.control [new file with mode: 0644]
openwrt/package/radvd/Config.in [new file with mode: 0644]
openwrt/package/radvd/Makefile [new file with mode: 0644]
openwrt/package/radvd/files/S51radvd [new file with mode: 0755]
openwrt/package/radvd/files/radvd.conf.example [new file with mode: 0644]
openwrt/package/radvd/patches/no-libfl.patch [new file with mode: 0644]
openwrt/package/radvd/radvd.control [new file with mode: 0644]

index bf84536b07a2c2c97860ab367d60afa696e4bafe..e7d9f28e99cc6dd9ce3b8ee5156b4fd29a8003d7 100644 (file)
@@ -40,6 +40,10 @@ source "package/nocatsplash/Config.in"
 source "package/fping/Config.in"
 source "package/arpwatch/Config.in"
 source "package/wireless-tools/Config.in"
+source "package/aiccu/Config.in"
+source "package/bwm/Config.in"
+source "package/ntpclient/Config.in"
+source "package/radvd/Config.in"
 
 comment "Libraries"
 source "package/zlib/Config.in"
index bb378848ff9381d3fff8e7271ba9060ecfd4e978..4d3c85c266e85f223b4302f2b48923675c1b2ae5 100644 (file)
@@ -2,10 +2,12 @@
 include $(TOPDIR)/rules.mk
 
 package-y:=openwrt
+package-$(BR2_PACKAGE_AICCU) += aiccu
 package-$(BR2_PACKAGE_ARPTABLES) += arptables
 package-$(BR2_PACKAGE_ARPWATCH) += arpwatch
 package-$(BR2_PACKAGE_BRIDGE) += bridge
 package-$(BR2_PACKAGE_BUSYBOX) += busybox
+package-$(BR2_PACKAGE_BWM) += bwm
 package-$(BR2_PACKAGE_CHILLISPOT) += chillispot
 package-$(BR2_PACKAGE_CIFSMOUNT) += cifsmount
 package-$(BR2_PACKAGE_CUPS) += cups
@@ -27,6 +29,7 @@ package-$(BR2_PACKAGE_MICROPERL) += microperl
 package-$(BR2_PACKAGE_NCURSES) += ncurses
 package-$(BR2_PACKAGE_NFSD) += nfs-server
 package-$(BR2_PACKAGE_NOCATSPLASH) += nocatsplash
+package-$(BR2_PACKAGE_NTPCLIENT) += ntpclient
 package-$(BR2_PACKAGE_OPENSSL) += openssl
 package-$(BR2_PACKAGE_OPENNTPD) += openntpd
 package-$(BR2_PACKAGE_OPENVPN) += openvpn
@@ -37,6 +40,7 @@ package-$(BR2_PACKAGE_PPP) += ppp
 package-$(BR2_PACKAGE_PPTP) += pptp
 package-$(BR2_PACKAGE_PPTPD) += pptpd
 package-$(BR2_PACKAGE_QUAGGA) += quagga
+package-$(BR2_PACKAGE_RADVD) += radvd
 package-$(BR2_PACKAGE_SER) += ser
 package-$(BR2_PACKAGE_SETSERIAL) += setserial
 package-$(BR2_PACKAGE_STRACE) += strace
diff --git a/openwrt/package/aiccu/Config.in b/openwrt/package/aiccu/Config.in
new file mode 100644 (file)
index 0000000..541aadc
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_AICCU
+       select BR2_PACKAGE_KMOD_IPV6
+       tristate "aiccu"
+       default m
+       help
+        SixXS Automatic IPv6 Connectivity Client Utility
+
+        For more information about SixXS check http://www.sixxs.net
diff --git a/openwrt/package/aiccu/Makefile b/openwrt/package/aiccu/Makefile
new file mode 100644 (file)
index 0000000..0b662d1
--- /dev/null
@@ -0,0 +1,46 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=aiccu
+PKG_VERSION:=2005.01.31
+PKG_RELEASE:=1
+PKG_MD5SUM:=7c3da5feab3d59fb5a99a45203e0ca56
+
+PKG_SOURCE_URL:=http://www.sixxs.net/archive/sixxs/aiccu/unix
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_CAT:=zcat
+PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE):
+       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+
+$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(PKG_BUILD_DIR)/.unpacked
+
+$(PKG_BUILD_DIR)/unix-console/$(PKG_NAME): $(PKG_BUILD_DIR)/.unpacked
+       $(SED) "s,strip,$(STRIP)," $(PKG_BUILD_DIR)/unix-console/Makefile
+       $(MAKE) CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS) -D_GNU_SOURCE" DEBUG=0 -C $(PKG_BUILD_DIR)
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME)
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       mkdir -p $(PKG_IPK_DIR)/usr/sbin $(PKG_IPK_DIR)/etc/init.d
+       install -m 755 $(PKG_BUILD_DIR)/unix-console/$(PKG_NAME) $(PKG_IPK_DIR)/usr/sbin/
+       install -m 755 ./files/S51aiccu $(PKG_IPK_DIR)/etc/init.d/
+       install -m 644 $(PKG_BUILD_DIR)/doc/aiccu.conf $(PKG_IPK_DIR)/etc/aiccu.conf
+       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
+       mkdir -p $(PACKAGE_DIR)
+       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
+       $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.unpacked
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+
+clean:
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
diff --git a/openwrt/package/aiccu/aiccu.control b/openwrt/package/aiccu/aiccu.control
new file mode 100644 (file)
index 0000000..158679e
--- /dev/null
@@ -0,0 +1,7 @@
+Package: aiccu
+Priority: optional
+Section: net
+Maintainer: Sebastien NOEL <me@twolife.org>
+Source: buildroot internal
+Depends: kmod-ipv6, ip
+Description: SixXS Automatic IPv6 Connectivity Client Utility
diff --git a/openwrt/package/aiccu/files/S51aiccu b/openwrt/package/aiccu/files/S51aiccu
new file mode 100755 (executable)
index 0000000..dabafcf
--- /dev/null
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+case "$1" in
+    start)
+       aiccu start     
+       ;;
+
+    stop)
+       aiccu stop
+       aiccu stop
+       ;;
+
+    restart)
+       $0 stop
+       $0 start
+       ;;
+    *)
+       echo "Usage: $0 {start|stop|restart}"
+       exit 1
+       ;;
+esac
diff --git a/openwrt/package/bwm/Config.in b/openwrt/package/bwm/Config.in
new file mode 100644 (file)
index 0000000..3a04ffd
--- /dev/null
@@ -0,0 +1,5 @@
+config BR2_PACKAGE_BWM
+       tristate "bwm"
+       default m
+       help
+         A very tiny bandwidth monitor.
diff --git a/openwrt/package/bwm/Makefile b/openwrt/package/bwm/Makefile
new file mode 100644 (file)
index 0000000..cf9c51e
--- /dev/null
@@ -0,0 +1,43 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bwm
+PKG_VERSION:=1.1.0
+PKG_RELEASE:=1
+PKG_MD5SUM:=51021a036acb92d2bda0c0c0483f9552
+
+PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/b/bwm
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
+PKG_CAT:=zcat
+PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE):
+       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+
+$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(PKG_BUILD_DIR)/.unpacked
+
+$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.unpacked
+       $(TARGET_CC) $(TARGET_CFLAGS) $(PKG_BUILD_DIR)/bwm.c -o $(PKG_BUILD_DIR)/bwm
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       mkdir -p $(PKG_IPK_DIR)/usr/bin
+       install -m 755 $(PKG_BUILD_DIR)/$(PKG_NAME) $(PKG_IPK_DIR)/usr/bin/
+       $(STRIP) $(PKG_IPK_DIR)/usr/bin/*
+       mkdir -p $(PACKAGE_DIR)
+       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
+       $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.unpacked
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+
+clean:
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
diff --git a/openwrt/package/bwm/bwm.control b/openwrt/package/bwm/bwm.control
new file mode 100644 (file)
index 0000000..41fe4ee
--- /dev/null
@@ -0,0 +1,6 @@
+Package: bwm
+Priority: optional
+Section: net
+Maintainer: Sebastien NOEL <me@twolife.org>
+Source: http://ftp.debian.org/debian/pool/main/b/bwm/
+Description: A very tiny bandwidth monitor
diff --git a/openwrt/package/ntpclient/Config.in b/openwrt/package/ntpclient/Config.in
new file mode 100644 (file)
index 0000000..faeab4b
--- /dev/null
@@ -0,0 +1,5 @@
+config BR2_PACKAGE_NTPCLIENT
+       tristate "ntpclient"
+       default m
+       help
+         NTP client for setting system time from NTP servers.
diff --git a/openwrt/package/ntpclient/Makefile b/openwrt/package/ntpclient/Makefile
new file mode 100644 (file)
index 0000000..23abdaa
--- /dev/null
@@ -0,0 +1,44 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ntpclient
+PKG_VERSION:=2003_194
+PKG_RELEASE:=1
+PKG_MD5SUM:=94e84d5c6023c5e1f3890b28d0a08c92
+
+PKG_SOURCE_URL:=http://doolittle.faludi.com/ntpclient
+PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+PKG_CAT:=zcat
+PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE):
+       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+
+$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       touch $(PKG_BUILD_DIR)/.unpacked
+
+$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.unpacked
+       $(MAKE) CC=$(TARGET_CC) CFLAGS="$(TARGET_CFLAGS)" -C $(PKG_BUILD_DIR)
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       mkdir -p $(PKG_IPK_DIR)/usr/sbin $(PKG_IPK_DIR)/etc/init.d
+       install -m 755 $(PKG_BUILD_DIR)/ntpclient $(PKG_IPK_DIR)/usr/sbin/
+       install -m 755 ./files/S41ntpclient $(PKG_IPK_DIR)/etc/init.d/
+       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
+       mkdir -p $(PACKAGE_DIR)
+       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
+       $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.unpacked
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+
+clean:
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
diff --git a/openwrt/package/ntpclient/files/S41ntpclient b/openwrt/package/ntpclient/files/S41ntpclient
new file mode 100755 (executable)
index 0000000..16a75ca
--- /dev/null
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/sbin/ntpclient -c 1 -s -h pool.ntp.org
diff --git a/openwrt/package/ntpclient/ntpclient.control b/openwrt/package/ntpclient/ntpclient.control
new file mode 100644 (file)
index 0000000..c32e304
--- /dev/null
@@ -0,0 +1,6 @@
+Package: ntpclient
+Priority: optional
+Section: net
+Maintainer: Sebastien NOEL <me@twolife.org>
+Source: http://doolittle.faludi.com/ntpclient/
+Description: NTP client for setting system time from NTP servers.
diff --git a/openwrt/package/radvd/Config.in b/openwrt/package/radvd/Config.in
new file mode 100644 (file)
index 0000000..4857b4d
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_RADVD
+       select BR2_PACKAGE_KMOD_IPV6
+       select BR2_PACKAGE_LIBFL
+       tristate "radvd"
+       default m
+       help
+         Routing Advertisement Daemon for IPv6
diff --git a/openwrt/package/radvd/Makefile b/openwrt/package/radvd/Makefile
new file mode 100644 (file)
index 0000000..6b1fadb
--- /dev/null
@@ -0,0 +1,62 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=radvd
+PKG_VERSION:=0.7.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=56ce3f8cbf5966a0d531c21813320423
+
+PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_CAT:=zcat
+PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+$(DL_DIR)/$(PKG_SOURCE):
+       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+
+$(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE)
+       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       $(PATCH) $(PKG_BUILD_DIR) ./patches
+       touch $(PKG_BUILD_DIR)/.patched
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.patched
+       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --prefix=/usr \
+               --with-logfile=/tmp/radvd.log \
+               --with-pidfile=/tmp/run/radvd.pid \
+               --with-configfile=/etc/radvd.conf \
+       );
+       touch $(PKG_BUILD_DIR)/.configured
+
+$(PKG_BUILD_DIR)/$(PKG_NAME): $(PKG_BUILD_DIR)/.configured
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) LDFLAGS=-L$(PKG_BUILD_DIR) -C $(PKG_BUILD_DIR) radvd_LDADD=""
+
+$(PKG_IPK): $(PKG_BUILD_DIR)/$(PKG_NAME)
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       mkdir -p $(PKG_IPK_DIR)/usr/sbin $(PKG_IPK_DIR)/etc/init.d
+       install -m 755 $(PKG_BUILD_DIR)/radvd $(PKG_IPK_DIR)/usr/sbin/
+       install -m 755 $(PKG_BUILD_DIR)/radvdump $(PKG_IPK_DIR)/usr/sbin/
+       install -m 755 ./files/S51radvd $(PKG_IPK_DIR)/etc/init.d/
+       install -m 644 ./files/radvd.conf.example $(PKG_IPK_DIR)/etc/
+       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
+       mkdir -p $(PACKAGE_DIR)
+       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+
+$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
+       $(IPKG) install $(PKG_IPK)
+
+source: $(DL_DIR)/$(PKG_SOURCE)
+prepare: $(PKG_BUILD_DIR)/.patched
+compile: $(PKG_IPK)
+install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+
+clean:
+       rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
diff --git a/openwrt/package/radvd/files/S51radvd b/openwrt/package/radvd/files/S51radvd
new file mode 100755 (executable)
index 0000000..88565db
--- /dev/null
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+case "$1" in
+    start)
+       echo 1 > /proc/sys/net/ipv6/conf/all/forwarding
+       /usr/sbin/radvd
+       ;;
+
+    stop)
+       killall radvd
+       echo 0 > /proc/sys/net/ipv6/conf/all/forwarding
+       ;;
+
+    restart)
+       $0 stop
+       $0 start
+       ;;
+    *)
+       echo "Usage: $0 {start|stop|restart}"
+       exit 1
+       ;;
+esac
diff --git a/openwrt/package/radvd/files/radvd.conf.example b/openwrt/package/radvd/files/radvd.conf.example
new file mode 100644 (file)
index 0000000..06d8357
--- /dev/null
@@ -0,0 +1,22 @@
+# For more examples, see the radvd documentation.
+
+interface br0
+{
+       AdvSendAdvert off;
+
+#
+# Disable Mobile IPv6 support
+#
+       AdvHomeAgentFlag off;
+
+#
+# example of a standard prefix
+#
+       prefix fec0:0:0:1::/64
+       {
+               AdvOnLink on;
+               AdvAutonomous on;
+               AdvRouterAddr off;
+       };
+
+};
diff --git a/openwrt/package/radvd/patches/no-libfl.patch b/openwrt/package/radvd/patches/no-libfl.patch
new file mode 100644 (file)
index 0000000..e17a127
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN radvd-0.7.3.old/scanner.l radvd-0.7.3/scanner.l
+--- radvd-0.7.3.old/scanner.l  2004-10-26 07:30:34.000000000 +0200
++++ radvd-0.7.3/scanner.l      2005-04-05 00:01:42.000000000 +0200
+@@ -21,6 +21,8 @@
+ extern char *conf_file;
++int yywrap(void) { return 1; }
++
+ int num_lines = 1;
+ %}
diff --git a/openwrt/package/radvd/radvd.control b/openwrt/package/radvd/radvd.control
new file mode 100644 (file)
index 0000000..52760ad
--- /dev/null
@@ -0,0 +1,7 @@
+Package: radvd
+Priority: optional
+Section: net
+Maintainer: Sebastien NOEL <me@twolife.org>
+Source: http://v6web.litech.org/radvd/
+Depends: kmod-ipv6
+Description: Routing Advertisement Daemon for IPv6