include: image.mk: ensure that $(KDIR)/tmp exists in the IB case as well
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 1 Jun 2015 18:00:35 +0000 (18:00 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 1 Jun 2015 18:00:35 +0000 (18:00 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 45870

include/image.mk

index 36c6c63320ffc8c9d52161452b808ef445c947b3..020418d54d42945bd69b7c398b799a81f82c56a0 100644 (file)
@@ -464,6 +464,9 @@ define BuildImage
     image_prepare: compile
                mkdir -p $(KDIR)/tmp
                $(call Image/Prepare)
+  else
+    image_prepare:
+               mkdir -p $(KDIR)/tmp
   endif
 
   mkfs_prepare: image_prepare