modules: make dwc2 only depend on gadget support for brcm2708
authorJohn Crispin <john@openwrt.org>
Wed, 11 Mar 2015 17:58:53 +0000 (17:58 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 11 Mar 2015 17:58:53 +0000 (17:58 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 44683

package/kernel/linux/modules/usb.mk

index 71661dc..51e443a 100644 (file)
@@ -440,7 +440,7 @@ $(eval $(call KernelPackage,usb2-pci))
 
 define KernelPackage/usb-dwc2
   TITLE:=DWC2 USB controller driver
-  DEPENDS:=@!LINUX_3_8 @!LINUX_3_10 +kmod-usb-gadget
+  DEPENDS:=@!LINUX_3_8 @!LINUX_3_10 +TARGET_brcm2708:kmod-usb-gadget
   KCONFIG:= \
        CONFIG_USB_DWC2 \
        CONFIG_USB_DWC2_PCI \