strace: fix build on aarch64
authorStijn Tintel <stijn@linux-ipv6.be>
Thu, 28 Jun 2018 10:00:10 +0000 (13:00 +0300)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 10:28:12 +0000 (11:28 +0100)
As of version 4.21, strace enforces mpers by default. The current
implementation of aarch64 compat in strace assumes it's identical to
ARMv7 EABI and therefore tries to enable m32 personality support. As
there is no -m32 support on aarch64, this causes the build to fail.

Restore previous strace behavior to fix build on aarch64.

Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Tested-by: Karl Palsson <karlp@tweak.net.au>
(backported from 067e2f5f1d0102ffb96d3248e42a29e7352cc29c)

package/devel/strace/Makefile

index 6209dc5a638f879625c63971f772abee83c0f44d..15faa5e406185906217930c487226bb6895a73b1 100644 (file)
@@ -30,6 +30,10 @@ include $(INCLUDE_DIR)/package.mk
 
 HOST_CFLAGS += -I$(LINUX_DIR)/user_headers/include
 
+ifeq ($(ARCH),aarch64)
+  CONFIGURE_ARGS += --enable-mpers=check
+endif
+
 CONFIGURE_VARS+= \
        LDFLAGS_FOR_BUILD="$(HOST_LDFLAGS)" \
        CPPFLAGS_FOR_BUILD="$(HOST_CPPFLAGS)" \