procd: Always tell cmake whether to include seccomp support or not
authorMichal Sojka <sojkam1@fel.cvut.cz>
Fri, 3 Nov 2017 21:31:42 +0000 (22:31 +0100)
committerJohn Crispin <john@phrozen.org>
Fri, 3 Nov 2017 21:31:42 +0000 (22:31 +0100)
Without this change, when a user disables seccomp support in .config,
procd does not get recompiled unless the package is cleaned manually.
It is because when -D option is missing from cmake command line, cmake
uses cached value from the previous run where seccomp was enabled.

Signed-off-by: Michal Sojka <sojkam1@fel.cvut.cz>
package/system/procd/Makefile

index 67dcf31d0d727b16d2f16564d02a9512f9c24755..83785abd6f29f50c0ec9bfa6b640499e5efee6e9 100644 (file)
@@ -87,9 +87,8 @@ ifdef CONFIG_PACKAGE_procd-ujail
   CMAKE_OPTIONS += -DJAIL_SUPPORT=1
 endif
 
-ifdef CONFIG_PACKAGE_procd-seccomp
-  CMAKE_OPTIONS += -DSECCOMP_SUPPORT=1 -DUTRACE_SUPPORT=1
-endif
+SECCOMP=$(if $(CONFIG_PACKAGE_procd-seccomp),1,0)
+CMAKE_OPTIONS += -DSECCOMP_SUPPORT=$(SECCOMP) -DUTRACE_SUPPORT=$(SECCOMP)
 
 define Package/procd/install
        $(INSTALL_DIR) $(1)/sbin $(1)/etc $(1)/lib/functions