kernel: package the HW random core module
authorFlorian Fainelli <florian@openwrt.org>
Wed, 10 Jul 2013 19:42:48 +0000 (19:42 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 10 Jul 2013 19:42:48 +0000 (19:42 +0000)
And update the crypto-hw-hifn-795x to use it.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 37231

package/kernel/linux/modules/crypto.mk
package/kernel/linux/modules/other.mk

index be76f53251207d2a86a93ea83cb013e0d868d013..065ddbfecb3cbc82ee63e9a518143d190e81cb7a 100644 (file)
@@ -164,8 +164,8 @@ $(eval $(call KernelPackage,crypto-hw-geode))
 
 define KernelPackage/crypto-hw-hifn-795x
   TITLE:=HIFN 795x crypto accelerator
+  DEPENDS:=+kmod-random-core
   KCONFIG:= \
-       CONFIG_HW_RANDOM=y \
        CONFIG_CRYPTO_DEV_HIFN_795X \
        CONFIG_CRYPTO_DEV_HIFN_795X_RNG=y
   FILES:=$(LINUX_DIR)/drivers/crypto/hifn_795x.ko
index 387090aec3aa5685518c552c01734b8c8a8595db..94bf5dd6cf858b2a25cb5b71befee406dfb597ff 100644 (file)
@@ -684,3 +684,17 @@ define KernelPacakge/ptp-gianfar/description
 endef
 
 $(eval $(call KernelPackage,ptp-gianfar))
+
+define KernelPackage/random-core
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Hardware Random Number Generator Core support
+  KCONFIG:=CONFIG_HW_RANDOM
+  FILES:=$(LINUX_DIR)/drivers/char/hw_random/rng-core.ko
+  AUTOLOAD:=$(call AutoLoad,10,rng-core)
+endef
+
+define KernelPackage/random-core/description
+   Kernel module for the HW random number generator core infrastructure
+endef
+
+$(eval $(call KernelPackage,random-core))