nftables: install libnftables to staging dir
authorDaniel Danzberger <daniel@dd-wrt.com>
Mon, 4 Oct 2021 07:47:32 +0000 (09:47 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 20 Nov 2021 20:08:25 +0000 (21:08 +0100)
Makes libnftables library and headers available for other packages.

Signed-off-by: Daniel Danzberger <daniel@dd-wrt.com>
package/network/utils/nftables/Makefile

index 8ead30a127279485c9438a4ff4c530e2cb2ed243..89bb10e0daf4e1d297335e8a547e65063991708d 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nftables
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://netfilter.org/projects/$(PKG_NAME)/files
@@ -61,6 +61,12 @@ endif
 TARGET_CFLAGS += -flto
 TARGET_LDFLAGS += -flto
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/nftables $(1)/usr/include/
+endef
+
 define Package/nftables/install/Default
        $(INSTALL_DIR) $(1)/usr/sbin
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/nft $(1)/usr/sbin/