toolchain/binutils: add 2.26.1
authorSyrone Wong <wong.syrone@gmail.com>
Wed, 13 Jul 2016 13:57:02 +0000 (21:57 +0800)
committerFelix Fietkau <nbd@nbd.name>
Fri, 15 Jul 2016 12:17:20 +0000 (14:17 +0200)
Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
Signed-off-by: Felix Fietkau <nbd@nbd.name> [fixes/cleanup]
toolchain/binutils/Config.in
toolchain/binutils/Config.version
toolchain/binutils/Makefile
toolchain/binutils/patches/2.26.1/300-001_ld_makefile_patch.patch [new file with mode: 0644]
toolchain/binutils/patches/2.26.1/300-012_check_ldrunpath_length.patch [new file with mode: 0644]
toolchain/binutils/patches/2.26.1/400-mips_no_dynamic_linking_sym.patch [new file with mode: 0644]
toolchain/binutils/patches/2.26.1/500-Change-default-emulation-for-mips64-linux.patch [new file with mode: 0644]

index 2960c947d2b2e2dd02c0f0f5115cd92b44714c66..f43cea599988e65e8bf4635e5144e0b31365578c 100644 (file)
@@ -17,6 +17,11 @@ choice
                bool "Binutils 2.25.1"
                select BINUTILS_VERSION_2_25_1
 
+       config BINUTILS_USE_VERSION_2_26_1
+               depends on !arc
+               bool "Binutils 2.26.1"
+               select BINUTILS_VERSION_2_26_1
+
        config BINUTILS_USE_VERSION_2_26_ARC
                depends on arc
                bool "ARC binutils 2.26"
index fc7a1f37c08d44d93145b91e1286102837d038e0..6812d03b72e0abdda26074e69647b6415c7ad7f5 100644 (file)
@@ -5,6 +5,9 @@ config BINUTILS_VERSION_2_25_1
        default y if (!TOOLCHAINOPTS && !arc)
        bool
 
+config BINUTILS_VERSION_2_26_1
+       bool
+
 config BINUTILS_VERSION_2_26_ARC
        default y if (!TOOLCHAINOPTS && arc)
        bool
@@ -13,5 +16,6 @@ config BINUTILS_VERSION
        string
        default "2.24-linaro"          if BINUTILS_VERSION_2_24_LINARO
        default "2.25.1"               if BINUTILS_VERSION_2_25_1
+       default "2.26.1"               if BINUTILS_VERSION_2_26_1
        default "arc-2016.03"          if BINUTILS_VERSION_2_26_ARC
 
index 03fc76abddb3bb0e862e29d7de7013d0b8830e16..a30a1671695ead4fef3402d400def4e8d1954b92 100644 (file)
@@ -17,6 +17,10 @@ ifeq ($(PKG_VERSION),2.25.1)
   PKG_MD5SUM:=ac493a78de4fee895961d025b7905be4
 endif
 
+ifeq ($(PKG_VERSION),2.26.1)
+  PKG_MD5SUM:=d2b24e5b5301b7ff0207414c34c3e0fb
+endif
+
 ifeq ($(findstring linaro, $(CONFIG_BINUTILS_VERSION)),linaro)
   PKG_SOURCE_URL:=https://releases.linaro.org/14.09/components/toolchain/binutils-linaro/
   PKG_REV:=2.24.0-2014.09
diff --git a/toolchain/binutils/patches/2.26.1/300-001_ld_makefile_patch.patch b/toolchain/binutils/patches/2.26.1/300-001_ld_makefile_patch.patch
new file mode 100644 (file)
index 0000000..c51fc00
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/ld/Makefile.am
++++ b/ld/Makefile.am
+@@ -54,7 +54,7 @@ endif
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ EMUL = @EMUL@
+ EMULATION_OFILES = @EMULATION_OFILES@
+--- a/ld/Makefile.in
++++ b/ld/Makefile.in
+@@ -388,7 +388,7 @@ AM_CFLAGS = $(WARN_CFLAGS)
+ # We put the scripts in the directory $(scriptdir)/ldscripts.
+ # We can't put the scripts in $(datadir) because the SEARCH_DIR
+ # directives need to be different for native and cross linkers.
+-scriptdir = $(tooldir)/lib
++scriptdir = $(libdir)
+ BASEDIR = $(srcdir)/..
+ BFDDIR = $(BASEDIR)/bfd
+ INCDIR = $(BASEDIR)/include
diff --git a/toolchain/binutils/patches/2.26.1/300-012_check_ldrunpath_length.patch b/toolchain/binutils/patches/2.26.1/300-012_check_ldrunpath_length.patch
new file mode 100644 (file)
index 0000000..2e24b38
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/ld/emultempl/elf32.em
++++ b/ld/emultempl/elf32.em
+@@ -1198,6 +1198,8 @@ fragment <<EOF
+             && command_line.rpath == NULL)
+           {
+             lib_path = (const char *) getenv ("LD_RUN_PATH");
++            if ((lib_path) && (strlen (lib_path) == 0))
++              lib_path = NULL;
+             if (gld${EMULATION_NAME}_search_needed (lib_path, &n,
+                                                     force))
+               break;
+@@ -1461,6 +1463,8 @@ gld${EMULATION_NAME}_before_allocation (
+   rpath = command_line.rpath;
+   if (rpath == NULL)
+     rpath = (const char *) getenv ("LD_RUN_PATH");
++  if ((rpath) && (strlen (rpath) == 0))
++      rpath = NULL;
+   for (abfd = link_info.input_bfds; abfd; abfd = abfd->link.next)
+     if (bfd_get_flavour (abfd) == bfd_target_elf_flavour)
diff --git a/toolchain/binutils/patches/2.26.1/400-mips_no_dynamic_linking_sym.patch b/toolchain/binutils/patches/2.26.1/400-mips_no_dynamic_linking_sym.patch
new file mode 100644 (file)
index 0000000..a63203d
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/bfd/elfxx-mips.c
++++ b/bfd/elfxx-mips.c
+@@ -7689,6 +7689,7 @@ _bfd_mips_elf_create_dynamic_sections (b
+       name = SGI_COMPAT (abfd) ? "_DYNAMIC_LINK" : "_DYNAMIC_LINKING";
+       bh = NULL;
++      if (0) {
+       if (!(_bfd_generic_link_add_one_symbol
+           (info, abfd, name, BSF_GLOBAL, bfd_abs_section_ptr, 0,
+            NULL, FALSE, get_elf_backend_data (abfd)->collect, &bh)))
+@@ -7701,6 +7702,7 @@ _bfd_mips_elf_create_dynamic_sections (b
+       if (! bfd_elf_link_record_dynamic_symbol (info, h))
+       return FALSE;
++      }
+       if (! mips_elf_hash_table (info)->use_rld_obj_head)
+       {
diff --git a/toolchain/binutils/patches/2.26.1/500-Change-default-emulation-for-mips64-linux.patch b/toolchain/binutils/patches/2.26.1/500-Change-default-emulation-for-mips64-linux.patch
new file mode 100644 (file)
index 0000000..3343a85
--- /dev/null
@@ -0,0 +1,37 @@
+--- a/bfd/config.bfd
++++ b/bfd/config.bfd
+@@ -1062,12 +1062,12 @@ case "${targ}" in
+     targ_selvecs="mips_elf32_le_vec mips_elf64_be_vec mips_elf64_le_vec mips_ecoff_be_vec mips_ecoff_le_vec"
+     ;;
+   mips64*el-*-linux*)
+-    targ_defvec=mips_elf32_ntrad_le_vec
+-    targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_le_vec mips_elf64_trad_be_vec"
++    targ_defvec=mips_elf64_trad_le_vec
++    targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_be_vec"
+     ;;
+   mips64*-*-linux*)
+-    targ_defvec=mips_elf32_ntrad_be_vec
+-    targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_be_vec mips_elf64_trad_le_vec"
++    targ_defvec=mips_elf64_trad_be_vec
++    targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_le_vec"
+     ;;
+   mips*el-*-linux*)
+     targ_defvec=mips_elf32_trad_le_vec
+--- a/ld/configure.tgt
++++ b/ld/configure.tgt
+@@ -476,11 +476,11 @@ mips*el-*-vxworks*)      targ_emul=elf32elmip
+ mips*-*-vxworks*)     targ_emul=elf32ebmipvxworks
+                       targ_extra_emuls="elf32elmipvxworks" ;;
+ mips*-*-windiss)      targ_emul=elf32mipswindiss ;;
+-mips64*el-*-linux-*)  targ_emul=elf32ltsmipn32
+-                      targ_extra_emuls="elf32btsmipn32 elf32ltsmip elf32btsmip elf64ltsmip elf64btsmip"
++mips64*el-*-linux-*)  targ_emul=elf64ltsmip
++                      targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32ltsmip elf32btsmip elf64btsmip"
+                       targ_extra_libpath=$targ_extra_emuls ;;
+-mips64*-*-linux-*)    targ_emul=elf32btsmipn32
+-                      targ_extra_emuls="elf32ltsmipn32 elf32btsmip elf32ltsmip elf64btsmip elf64ltsmip"
++mips64*-*-linux-*)    targ_emul=elf64btsmip
++                      targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32btsmip elf32ltsmip elf64ltsmip"
+                       targ_extra_libpath=$targ_extra_emuls ;;
+ mips*el-*-linux-*)    targ_emul=elf32ltsmip
+                       targ_extra_emuls="elf32btsmip elf32ltsmipn32 elf64ltsmip elf32btsmipn32 elf64btsmip"