ds-lite: drop default encaplimit value
authorHans Dedecker <dedeckeh@gmail.com>
Mon, 17 Sep 2018 09:24:39 +0000 (11:24 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Wed, 19 Sep 2018 07:42:28 +0000 (09:42 +0200)
Setting encaplimit to a numerical value results into the value being
included as tunnel encapsulation limit in the destination option header
for tunneled packets.
Several users have reported interop issues as not all ISPs support the
destination option header containing the tunnel encapsulation limit
resulting into broken ds-lite connectivity.
Therefore drop the default encaplimit value for ds-lite tunnels so
no destination option header is included by default.

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/ipv6/ds-lite/Makefile
package/network/ipv6/ds-lite/files/dslite.sh

index 4393d35877fb11c27dad1abf6b2c04ea491301eb..198b6ebcc7cd13ba39bf118ee87bb3a10f361913 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ds-lite
 PKG_VERSION:=7
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index 7bd3f2e70d5a33c774797688196f32de078a4eed..017963926db62b84b7e23b8e905fb1fb0a6f097b 100644 (file)
@@ -69,7 +69,7 @@ proto_dslite_setup() {
        json_add_string remote "$peeraddr"
        [ -n "$tunlink" ] && json_add_string link "$tunlink"
        json_add_object "data"
-         json_add_string encaplimit "${encaplimit:-4}"
+         [ -n "$encaplimit" ] && json_add_string encaplimit "$encaplimit"
        json_close_object
        proto_close_tunnel