port olsrd update in [2837] from whiterussian to trunk
authorNicolas Thill <nico@openwrt.org>
Thu, 5 Jan 2006 19:30:19 +0000 (19:30 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 5 Jan 2006 19:30:19 +0000 (19:30 +0000)
SVN-Revision: 2839

openwrt/package/olsrd/Config.in
openwrt/package/olsrd/Makefile
openwrt/package/olsrd/ipkg/olsrd-mod-tas.control [new file with mode: 0644]
openwrt/package/olsrd/patches/olsrd-0.4.10-opt-flags.diff [new file with mode: 0644]
openwrt/package/olsrd/patches/olsrd-0.4.9-no-makedepend.patch [deleted file]
openwrt/package/olsrd/patches/olsrd-0.4.9-opt-flags.diff [deleted file]

index 79818aea0756858cc4177b45f6b8acbc6213d007..0d6ffa4a845d53d757c8d428e1d1e67570789032 100644 (file)
@@ -45,4 +45,10 @@ config BR2_PACKAGE_OLSRD_MOD_SECURE
        default m if CONFIG_DEVEL
        depends BR2_PACKAGE_OLSRD
 
+config BR2_PACKAGE_OLSRD_MOD_TAS
+       prompt   "olsrd-mod-tas................... Tiny Application Server (TAS) plugin for olsrd"
+       tristate
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_OLSRD
+
 endmenu
index 219813663ba90765a29987011138de90820cb03c..15be9672862e8fb3dbaff34505b38bc38f94772b 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=olsrd
-PKG_VERSION:=0.4.9
+PKG_VERSION:=0.4.10
 PKG_RELEASE:=1
-PKG_MD5SUM:=593c0861fa10d2a8d0e7d8617479c5cf
+PKG_MD5SUM:=9807d4451e65cb4ec385155eef7bf3cf
 
 PKG_SOURCE_URL:=http://www.olsr.org/releases/0.4
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -33,6 +33,7 @@ $(eval $(call PKG_template,OLSRD_MOD_HTTPINFO,olsrd-mod-httpinfo,$(PKG_VERSION)-
 $(eval $(call PKG_template,OLSRD_MOD_NAMESERVICE,olsrd-mod-nameservice,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OLSRD_MOD_POWER,olsrd-mod-power,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,OLSRD_MOD_SECURE,olsrd-mod-secure,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,OLSRD_MOD_TAS,olsrd-mod-tas,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(eval $(call PKG_mod_template,OLSRD_MOD_DOT_DRAW,dot_draw))
 $(eval $(call PKG_mod_template,OLSRD_MOD_DYN_GW,dyn_gw))
@@ -40,6 +41,7 @@ $(eval $(call PKG_mod_template,OLSRD_MOD_HTTPINFO,httpinfo))
 $(eval $(call PKG_mod_template,OLSRD_MOD_NAMESERVICE,nameservice))
 $(eval $(call PKG_mod_template,OLSRD_MOD_POWER,power))
 $(eval $(call PKG_mod_template,OLSRD_MOD_SECURE,secure))
+$(eval $(call PKG_mod_template,OLSRD_MOD_TAS,tas))
 
 $(PKG_BUILD_DIR)/.configured:
        touch $@
diff --git a/openwrt/package/olsrd/ipkg/olsrd-mod-tas.control b/openwrt/package/olsrd/ipkg/olsrd-mod-tas.control
new file mode 100644 (file)
index 0000000..91ad4c6
--- /dev/null
@@ -0,0 +1,5 @@
+Package: olsrd-mod-tas
+Priority: optional
+Section: net
+Description: a Tiny Application Server (TAS) plugin for olsrd
+Depends: olsrd
diff --git a/openwrt/package/olsrd/patches/olsrd-0.4.10-opt-flags.diff b/openwrt/package/olsrd/patches/olsrd-0.4.10-opt-flags.diff
new file mode 100644 (file)
index 0000000..02d1cc8
--- /dev/null
@@ -0,0 +1,12 @@
+diff -ruN olsrd-0.4.10-old/Makefile.inc olsrd-0.4.10-new/Makefile.inc
+--- olsrd-0.4.10-old/Makefile.inc      2006-01-01 16:58:20.000000000 +0100
++++ olsrd-0.4.10-new/Makefile.inc      2006-01-05 17:57:23.000000000 +0100
+@@ -21,7 +21,7 @@
+ ifndef CFLAGS
+ CFLAGS +=     -Wall -Wmissing-prototypes -Wstrict-prototypes \
+               -Wmissing-declarations -Wsign-compare
+-CFLAGS +=     -O2 -g
++CFLAGS +=     $(OFLAGS)
+ endif
+ ifdef OLSRD_PLUGIN
diff --git a/openwrt/package/olsrd/patches/olsrd-0.4.9-no-makedepend.patch b/openwrt/package/olsrd/patches/olsrd-0.4.9-no-makedepend.patch
deleted file mode 100644 (file)
index 1e0e4de..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-diff -ruN olsrd-0.4.9-old/Makefile olsrd-0.4.9-new/Makefile
---- olsrd-0.4.9-old/Makefile   2005-05-20 17:37:26.000000000 +0200
-+++ olsrd-0.4.9-new/Makefile   2005-05-20 17:42:20.000000000 +0200
-@@ -75,7 +75,7 @@
- OFLAGS ?=     -O2 -g
- CFLAGS ?=     $(CCWARNINGS) $(OFLAGS) #-DDEBUG #-pg #-march=i686
- LIBS =                -lm -ldl #-pg
--MAKEDEPEND =  makedepend -f $(DEPFILE) $(DEFINES) -Y $(INCLUDES) $(SRCS) >/dev/null 2>&1
-+MAKEDEPEND =  $(CC) -M $(DEFINES) $(INCLUDES) $(SRCS) >> $(DEPFILE)
- all:   cfgparser olsrd
- install: install_olsrd
-diff -ruN olsrd-0.4.9-old/lib/dot_draw/Makefile olsrd-0.4.9-new/lib/dot_draw/Makefile
---- olsrd-0.4.9-old/lib/dot_draw/Makefile      2005-04-01 23:53:01.000000000 +0200
-+++ olsrd-0.4.9-new/lib/dot_draw/Makefile      2005-05-20 17:42:52.000000000 +0200
-@@ -64,8 +64,7 @@
- EXTRA_OBJS =  # nothing
--MAKEDEPEND =  makedepend -f $(DEPFILE) $(CFLAGS_ADD) -Y $(INCLUDES) \
--              $(SRCS) >/dev/null 2>&1
-+MAKEDEPEND =  $(CC) -M $(CFLAGS_ADD) $(INCLUDES) $(SRCS) >> $(DEPFILE) 
- all:          all2
- install:      install2
-diff -ruN olsrd-0.4.9-old/lib/nameservice/Makefile olsrd-0.4.9-new/lib/nameservice/Makefile
---- olsrd-0.4.9-old/lib/nameservice/Makefile   2005-03-01 22:41:34.000000000 +0100
-+++ olsrd-0.4.9-new/lib/nameservice/Makefile   2005-05-20 17:42:57.000000000 +0200
-@@ -98,8 +98,7 @@
- EXTRA_OBJS =  # nothing
--MAKEDEPEND =  makedepend -f $(DEPFILE) $(CFLAGS_ADD) -Y $(INCLUDES) \
--              $(SRCS) >/dev/null 2>&1
-+MAKEDEPEND =  $(CC) -M $(CFLAGS_ADD) $(INCLUDES) $(SRCS) >> $(DEPFILE)
- all:          all2
- install:      install2
-diff -ruN olsrd-0.4.9-old/src/cfgparser/Makefile olsrd-0.4.9-new/src/cfgparser/Makefile
---- olsrd-0.4.9-old/src/cfgparser/Makefile     2005-03-21 03:17:36.000000000 +0100
-+++ olsrd-0.4.9-new/src/cfgparser/Makefile     2005-05-20 17:43:50.000000000 +0200
-@@ -56,7 +56,7 @@
- ifeq ($(OS), linux)
- PIPETONULL =  >/dev/null 2>&1
--DEPFLAGS +=   -Dlinux -Y
-+DEPFLAGS +=   -Dlinux
- endif
- ifeq ($(OS), fbsd)
-@@ -129,7 +129,7 @@
- endif
- endif
--MAKEDEPEND =  makedepend -f $(DEPFILE) $(DEPFLAGS) $(INCLUDES) $(SRCS) $(PIPETONULL)
-+MAKEDEPEND =  $(CC) -M $(DEPFLAGS) $(INCLUDES) $(SRCS) >> $(DEPFILE)
- OBJS =                olsrd_conf.o oparse.o oscan.o cfgfile_gen.o $(PORT_OBJS)
- LIBS +=               $(PORT_LIBS)
diff --git a/openwrt/package/olsrd/patches/olsrd-0.4.9-opt-flags.diff b/openwrt/package/olsrd/patches/olsrd-0.4.9-opt-flags.diff
deleted file mode 100644 (file)
index c601ae0..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ruN olsrd-0.4.9-orig/Makefile olsrd-0.4.9-1/Makefile
---- olsrd-0.4.9-orig/Makefile  2005-03-31 20:39:24.000000000 +0200
-+++ olsrd-0.4.9-1/Makefile     2005-04-05 02:14:48.000000000 +0200
-@@ -72,7 +72,8 @@
- SRCS +=       $(wildcard src/linux/*.c) $(wildcard src/unix/*.c)
- HDRS +=               $(wildcard src/linux/*.h) $(wildcard src/unix/*.h)
- DEFINES =     -Dlinux
--CFLAGS ?=     $(CCWARNINGS) -O2 -g #-DDEBUG #-pg #-march=i686
-+OFLAGS ?=     -O2 -g
-+CFLAGS ?=     $(CCWARNINGS) $(OFLAGS) #-DDEBUG #-pg #-march=i686
- LIBS =                -lm -ldl #-pg
- MAKEDEPEND =  makedepend -f $(DEPFILE) $(DEFINES) -Y $(INCLUDES) $(SRCS) >/dev/null 2>&1