uboot-mvebu: add Methode eDPU support
authorRobert Marko <robert.marko@sartura.hr>
Wed, 21 Sep 2022 16:39:22 +0000 (18:39 +0200)
committerRobert Marko <robert.marko@sartura.hr>
Mon, 17 Oct 2022 13:42:50 +0000 (15:42 +0200)
Add support for building for Methode eDPU board, no patches are needed
as board has been upstreamed and is part of the 2022.10-rc releases.

Signed-off-by: Robert Marko <robert.marko@sartura.hr>
package/boot/uboot-mvebu/Makefile

index 274cc641d97fc9a6ce9095293e505cee17665a15..5075dce2ab47632924c978321070e35012beea29 100644 (file)
@@ -55,12 +55,18 @@ define U-Boot/uDPU
   BUILD_SUBTARGET:=cortexa53
 endef
 
+define U-Boot/eDPU
+  NAME:=Methode eDPU
+  BUILD_SUBTARGET:=cortexa53
+endef
+
 UBOOT_TARGETS:= \
        clearfog \
        helios4 \
        omnia \
        espressobin \
-       uDPU
+       uDPU \
+       eDPU
 
 define Package/u-boot/install
        $(if $(findstring cortexa53,$(BUILD_SUBTARGET)),,$(Package/u-boot/install/default))