ath79: Add support for TP-Link CPE210 v2
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 25 Mar 2019 17:46:26 +0000 (18:46 +0100)
committerPetr Štetiar <ynezz@true.cz>
Tue, 2 Apr 2019 00:10:59 +0000 (02:10 +0200)
This PR adds support for a popular low-cost 2.4GHz N based AP

Specifications:
 - SoC: Qualcomm Atheros QCA9533 (650MHz)
 - RAM: 64MB
 - Storage: 8 MB SPI NOR
 - Wireless: 2.4GHz N based built into SoC 2x2
 - Ethernet: 1x 100/10 Mbps, integrated into SoC, 24V POE IN

Installation:
Flash factory image through stock firmware WEB UI
or through TFTP
To get to TFTP recovery just hold reset button while powering on
for around 4-5 seconds and release.
Rename factory image to recovery.bin
Stock TFTP server IP:192.168.0.100
Stock device TFTP adress:192.168.0.254

This is based on the support patch for the identical CPE210 v3
by Mario Schroen <m.schroen@web.de>.

Tested-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
[renamed dtsi filename]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/qca9533_tplink_cpe210-v2.dts [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk

index 47fac182814b76c8bc10e561a6975e9fc0478f8d..af26425da2a3e2d385e333b60a005fb6b8d3f371 100755 (executable)
@@ -123,6 +123,7 @@ tplink,archer-c6-v2)
        ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x3C"
        ucidef_set_led_switch "wan" "WAN" "tp-link:green:wan" "switch0" "0x02"
        ;;
+tplink,cpe210-v2|\
 tplink,cpe210-v3)
        ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
        ucidef_set_rssimon "wlan0" "200000" "1"
index 1041af561e5b2ca72ed63dad7044e74a2fdce410..fbf15e4ed8dfb12c13c3589bfa194a43a18d9fcf 100755 (executable)
@@ -19,6 +19,7 @@ ath79_setup_interfaces()
        pcs,cap324|\
        pisen,wmm003n|\
        pqi,air-pen|\
+       tplink,cpe210-v2|\
        tplink,cpe210-v3|\
        tplink,re350k-v1|\
        tplink,re450-v2|\
diff --git a/target/linux/ath79/dts/qca9533_tplink_cpe210-v2.dts b/target/linux/ath79/dts/qca9533_tplink_cpe210-v2.dts
new file mode 100644 (file)
index 0000000..e8273ba
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9533_tplink_cpe210.dtsi"
+
+/ {
+       compatible = "tplink,cpe210-v2", "qca,qca9533";
+       model = "TP-LINK CPE210 v2";
+};
index 92d811f10b87c94d9c7265e5dcfaceb59a1d18f4..e3a0abeb5f21e7137947500c4a4ec07fccaf59ea 100644 (file)
@@ -109,6 +109,19 @@ define Device/tplink_archer-c7-v5
 endef
 TARGET_DEVICES += tplink_archer-c7-v5
 
+define Device/tplink_cpe210-v2
+  $(Device/tplink-safeloader)
+  ATH_SOC := qca9533
+  IMAGE_SIZE := 7680k
+  DEVICE_TITLE := TP-Link CPE210 v2
+  TPLINK_BOARD_ID := CPE210V2
+  DEVICE_PACKAGES := rssileds
+  LOADER_TYPE := elf
+  KERNEL := kernel-bin | append-dtb | lzma | tplink-v1-header -O
+  SUPPORTED_DEVICES += cpe210-v2
+endef
+TARGET_DEVICES += tplink_cpe210-v2
+
 define Device/tplink_cpe210-v3
   $(Device/tplink-safeloader)
   ATH_SOC := qca9533