gettext-full: update to version 0.19.6
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 22 Nov 2015 14:17:11 +0000 (14:17 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 22 Nov 2015 14:17:11 +0000 (14:17 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 47584

package/libs/gettext-full/Makefile
package/libs/gettext-full/patches/001-autotools.patch
package/libs/gettext-full/patches/001-no_examples_and_tests.patch
package/libs/gettext-full/patches/003-gettext-error_print_progname.patch
package/libs/gettext-full/patches/100-error_progname.patch
package/libs/gettext-full/patches/110-error_progname_def.patch
package/libs/gettext-full/patches/120-uclibc-nolocale.patch

index 1f8c2c82c1502879c9bed8f404610b43c8232b14..e07a158c28a19a2d1b0eaa595afff319afebc5af 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gettext-full
-PKG_VERSION:=0.19.4
+PKG_VERSION:=0.19.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=gettext-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gettext
-PKG_MD5SUM:=997c9070354eff5517115feaea6038f0
+PKG_MD5SUM:=69d79254ee3b41df23f41c2f4fd720d9
 PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/gettext-$(PKG_VERSION)
 
index ecbb0302dd6922b14f8bba60b2d2104fd8a115b2..2f23c8e3133d4312fb8af75dde62846d53248c17 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gettext-runtime/man/Makefile.am
 +++ b/gettext-runtime/man/Makefile.am
-@@ -171,8 +171,7 @@ textdomain.3.html: textdomain.3.in
+@@ -172,8 +172,7 @@ textdomain.3.html: textdomain.3.in
  bindtextdomain.3.html: bindtextdomain.3.in
  bind_textdomain_codeset.3.html: bind_textdomain_codeset.3.in
  
@@ -12,7 +12,7 @@
          $(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
 --- a/gettext-tools/man/Makefile.am
 +++ b/gettext-tools/man/Makefile.am
-@@ -153,8 +153,7 @@ recode-sr-latin.1.html: recode-sr-latin.
+@@ -154,8 +154,7 @@ recode-sr-latin.1.html: recode-sr-latin.
  gettextize.1.html: gettextize.1
  autopoint.1.html: autopoint.1
  
index 373b4a12f01beac1aa1991e7d9bed4c8f2ea6ea6..97353b18ed5b125d1b443f66952bd6503f3ad430 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gettext-runtime/Makefile.am
 +++ b/gettext-runtime/Makefile.am
-@@ -28,7 +28,7 @@ SUBDIR_libasprintf = libasprintf
+@@ -29,7 +29,7 @@ SUBDIR_libasprintf = libasprintf
  else
  SUBDIR_libasprintf =
  endif
index 72fdc55f53194a5c684627f3117538112c9088b6..6698e300af8f5410f168685678d01a73c1312e2b 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gettext-tools/libgettextpo/error.h
 +++ b/gettext-tools/libgettextpo/error.h
-@@ -58,7 +58,7 @@ extern void error_at_line (int __status,
+@@ -68,7 +68,7 @@ extern void error_at_line (int __status,
  /* If NULL, error will flush stdout, then print on stderr the program
     name, a colon and a space.  Otherwise, error will call this
     function without parameters instead.  */
index 74f51692210764f54bbcb676b80bdac8694942a5..38371aeacbd3045fc0ac4c9e443ae6fdddeac16c 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gettext-runtime/intl/intl-compat.c
 +++ b/gettext-runtime/intl/intl-compat.c
-@@ -129,3 +129,7 @@ bind_textdomain_codeset (const char *dom
+@@ -130,3 +130,7 @@ bind_textdomain_codeset (const char *dom
  {
    return libintl_bind_textdomain_codeset (domainname, codeset);
  }
index bf01d4b6a3272398db8edf9397444816ab80fb7d..e47c7de77f603fe435d12b960d1880389f0f926e 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gettext-tools/libgettextpo/error.h
 +++ b/gettext-tools/libgettextpo/error.h
-@@ -58,7 +58,7 @@ extern void error_at_line (int __status,
+@@ -68,7 +68,7 @@ extern void error_at_line (int __status,
  /* If NULL, error will flush stdout, then print on stderr the program
     name, a colon and a space.  Otherwise, error will call this
     function without parameters instead.  */
index 51d523fcb98f6a404e4a71e52621e67b020c6e7e..4c6a73e310ff9d6992c50dfa8c4327620cec0738 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gettext-runtime/intl/localename.c
 +++ b/gettext-runtime/intl/localename.c
-@@ -2779,7 +2779,7 @@ gl_locale_name_posix (int category, cons
+@@ -2788,7 +2788,7 @@ gl_locale_name_posix (int category, cons
  {
    /* Use the POSIX methods of looking to 'LC_ALL', 'LC_xxx', and 'LANG'.
       On some systems this can be done by the 'setlocale' function itself.  */