kmod-tcp-hybla: new module for hybla congestion control algorithm
authorYousong Zhou <yszhou4tech@gmail.com>
Wed, 23 Dec 2020 06:36:45 +0000 (14:36 +0800)
committerYousong Zhou <yszhou4tech@gmail.com>
Sat, 26 Dec 2020 02:08:08 +0000 (10:08 +0800)
Just the module and no default sysctl conf file is provided

Link: https://forum.openwrt.org/t/20-xx-tcp-hybla/83076
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
package/kernel/linux/modules/netsupport.mk

index d287e4627064de4138ab39040c29b11fe5499ab2..4e78ac54784df2f0d63d1108e80ea036586a7e0d 100644 (file)
@@ -947,6 +947,24 @@ endef
 $(eval $(call KernelPackage,tcp-bbr))
 
 
+define KernelPackage/tcp-hybla
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=TCP-Hybla congestion control algorithm
+  KCONFIG:=CONFIG_TCP_CONG_HYBLA
+  FILES:=$(LINUX_DIR)/net/ipv4/tcp_hybla.ko
+  AUTOLOAD:=$(call AutoProbe,tcp_hybla)
+endef
+
+define KernelPackage/tcp-hybla/description
+  TCP-Hybla is a sender-side only change that eliminates penalization of
+  long-RTT, large-bandwidth connections, like when satellite legs are
+  involved, especially when sharing a common bottleneck with normal
+  terrestrial connections.
+endef
+
+$(eval $(call KernelPackage,tcp-hybla))
+
+
 define KernelPackage/ax25
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=AX25 support