kernel: bump kernel 4.4 to 4.4.132 for 17.01
authorEtienne Haarsma <bladeoner112@gmail.com>
Mon, 21 May 2018 08:36:58 +0000 (10:36 +0200)
committerJohn Crispin <john@phrozen.org>
Tue, 22 May 2018 04:56:44 +0000 (06:56 +0200)
* Refreshed patches

Compile-tested: ar71xx
Run-tested: ar71xx

Signed-off-by: Etienne Haarsma <bladeoner112@gmail.com>
include/kernel-version.mk
target/linux/apm821xx/patches-4.4/040-backport_leds-convert-IDE-trigger-to-common-disk-trigger.patch
target/linux/generic/patches-4.4/099-0007-qmi_wwan-add-support-for-Quectel-EC21-and-EC25.patch
target/linux/generic/patches-4.4/834-ledtrig-libata.patch
target/linux/ixp4xx/patches-4.4/600-skb_avoid_dmabounce.patch
target/linux/oxnas/patches-4.4/999-libata-hacks.patch

index f10bbcabbc49d627d483f6d0bace8ac360dd1b9a..2e92bbf5fd8c03def9284de682ecfe4e13c48313 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .131
+LINUX_VERSION-4.4 = .132
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.131 = 65127add35c45acda866d10860e80bfdcc19b6c21e30e5dc9b92020a44d7c709
+LINUX_KERNEL_HASH-4.4.132 = c415b01c810ad88284f9ffaebe0526efce8b1643d930dac6d8ef6a55cf6e0634
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 6441866806e491ab4d8df6877f2734d68790a013..c753342d5b90deb652c3a299f8c4fe9b0976681d 100644 (file)
@@ -47,7 +47,7 @@ Signed-off-by: Jacek Anaszewski <j.anaszewski@samsung.com>
  #include <linux/pm_runtime.h>
  #include <linux/platform_device.h>
  
-@@ -4936,6 +4937,9 @@ void ata_qc_complete(struct ata_queued_c
+@@ -4939,6 +4940,9 @@ void ata_qc_complete(struct ata_queued_c
  {
        struct ata_port *ap = qc->ap;
  
index 62ff1cd5824fd737c1ad52b1421f6ae0cecaa119..3dad08008b72e37598e27d4de612285e954072ce 100644 (file)
@@ -82,7 +82,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  /* Gobi 1000 QMI/wwan interface number is 3 according to qcserial */
  #define QMI_GOBI1K_DEVICE(vend, prod) \
        QMI_FIXED_INTF(vend, prod, 3)
-@@ -908,6 +932,8 @@ static const struct usb_device_id produc
+@@ -909,6 +933,8 @@ static const struct usb_device_id produc
        {QMI_FIXED_INTF(0x03f0, 0x4e1d, 8)},    /* HP lt4111 LTE/EV-DO/HSPA+ Gobi 4G Module */
        {QMI_FIXED_INTF(0x22de, 0x9061, 3)},    /* WeTelecom WPD-600N */
        {QMI_FIXED_INTF(0x1e0e, 0x9001, 5)},    /* SIMCom 7230E */
index ca19ad63797e3fb5b245c96a6f56e16a9a1dfdfb..fd804cae9a61e5c2b86962c17f4bb3e03cab6d49 100644 (file)
@@ -69,7 +69,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  /**
   *    ata_build_rw_tf - Build ATA taskfile for given read/write request
   *    @tf: Target ATA taskfile
-@@ -4802,6 +4815,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4805,6 +4818,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
                if (tag < 0)
                        return NULL;
        }
@@ -79,7 +79,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
  
        qc = __ata_qc_from_tag(ap, tag);
        qc->tag = tag;
-@@ -5698,6 +5714,9 @@ struct ata_port *ata_port_alloc(struct a
+@@ -5701,6 +5717,9 @@ struct ata_port *ata_port_alloc(struct a
        ap->stats.unhandled_irq = 1;
        ap->stats.idle_irq = 1;
  #endif
@@ -89,7 +89,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
        ata_sff_port_init(ap);
  
        return ap;
-@@ -5719,6 +5738,12 @@ static void ata_host_release(struct devi
+@@ -5722,6 +5741,12 @@ static void ata_host_release(struct devi
  
                kfree(ap->pmp_link);
                kfree(ap->slave_link);
@@ -102,7 +102,7 @@ Signed-off-by: Daniel Golle <daniel@makrotopia.org>
                kfree(ap);
                host->ports[i] = NULL;
        }
-@@ -6165,7 +6190,23 @@ int ata_host_register(struct ata_host *h
+@@ -6168,7 +6193,23 @@ int ata_host_register(struct ata_host *h
                host->ports[i]->print_id = atomic_inc_return(&ata_print_id);
                host->ports[i]->local_port_no = i + 1;
        }
index e080e600f9df531e67b4596237e27b92ce408f01..60b5d1a8cb4b4e41989594d6bb4777bbb9d2843b 100644 (file)
@@ -10,7 +10,7 @@
  
        /* Get the HEAD */
        skb = kmem_cache_alloc_node(cache, gfp_mask & ~__GFP_DMA, node);
-@@ -1146,6 +1149,10 @@ int pskb_expand_head(struct sk_buff *skb
+@@ -1147,6 +1150,10 @@ int pskb_expand_head(struct sk_buff *skb
        if (skb_shared(skb))
                BUG();
  
index faf33b704fed8c71c3979bd8f7d790ced8e2471e..fe01fde6caffbbf1af9918f8c502c2cd92db171e 100644 (file)
@@ -15,7 +15,7 @@
        /* initialize internal qc */
  
        /* XXX: Tag 0 is used for drivers with legacy EH as some
-@@ -4809,6 +4817,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
+@@ -4812,6 +4820,9 @@ struct ata_queued_cmd *ata_qc_new_init(s
        if (unlikely(ap->pflags & ATA_PFLAG_FROZEN))
                return NULL;
  
@@ -25,7 +25,7 @@
        /* libsas case */
        if (ap->flags & ATA_FLAG_SAS_HOST) {
                tag = ata_sas_allocate_tag(ap);
-@@ -4854,6 +4865,8 @@ void ata_qc_free(struct ata_queued_cmd *
+@@ -4857,6 +4868,8 @@ void ata_qc_free(struct ata_queued_cmd *
                qc->tag = ATA_TAG_POISON;
                if (ap->flags & ATA_FLAG_SAS_HOST)
                        ata_sas_free_tag(tag, ap);