toolchain/gcc: remove uclibc hack
authorRosen Penev <rosenp@gmail.com>
Wed, 25 Mar 2020 01:29:51 +0000 (18:29 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 13 Apr 2020 20:40:19 +0000 (22:40 +0200)
This was introduced with 014d3b98b96872d020ffccf0358ba60967b3f1c0 , which
is almost 10 years old. uClibc-ng does not suffer from this problem.

Note that this hack prevents libstdc++ from using C++11 math functions.

Tested by removing all of the mpd patches designed to fix this and
compiling.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
toolchain/gcc/common.mk

index 5f237e4520fbb33e5618325ad9d1800b78ac4fb9..090aa2447d89984d2c4133c78c5bac72b162ffd7 100644 (file)
@@ -74,9 +74,6 @@ TAR_OPTIONS += \
        --exclude=libjava
 
 export libgcc_cv_fixed_point=no
-ifdef CONFIG_USE_UCLIBC
-  export glibcxx_cv_c99_math_tr1=no
-endif
 ifdef CONFIG_INSTALL_GCCGO
   export libgo_cv_c_split_stack_supported=no
 endif