ramips: add support for ZBT WG2626
authorJohn Crispin <john@openwrt.org>
Mon, 2 Nov 2015 10:18:19 +0000 (10:18 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 2 Nov 2015 10:18:19 +0000 (10:18 +0000)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 47351

target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/ZBT-WG2626.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/mt7621/profiles/zbt.mk [new file with mode: 0644]

index 21e36417784987f70a459471e8e087492eb005ca..382174298a57ef4d3b959a429bb833c5d7c10f8d 100755 (executable)
@@ -83,7 +83,8 @@ ramips_setup_interfaces()
        wsr-1166|\
        wsr-600|\
        wt1520|\
        wsr-1166|\
        wsr-600|\
        wt1520|\
-       y1)
+       y1|\
+       zbt-wg2626)
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ucidef_add_switch "switch0" "1" "1"
                ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 6t"
                ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
                ucidef_add_switch "switch0" "1" "1"
                ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 6t"
index 537675960f6703fd508b647def94b23c39bd20a6..e0dd92ab97ca0ca385ded138670aa551092635b9 100644 (file)
@@ -62,7 +62,8 @@ get_status_led() {
        rut5xx|\
        v11st-fe|\
        vocore|\
        rut5xx|\
        v11st-fe|\
        vocore|\
-       wmr-300)
+       wmr-300|\
+       zbt-wg2626)
                status_led="$board:green:status"
                ;;
        atp-52b|\
                status_led="$board:green:status"
                ;;
        atp-52b|\
index 2ed09c9b33cc5474448ee18e24ebd6ba7c04e580..62a79c505c267a6874c34cbcce28efd5fd6141ec 100755 (executable)
@@ -454,6 +454,9 @@ ramips_board_detect() {
        *"ZBT-WA05")
                name="zbt-wa05"
                ;;
        *"ZBT-WA05")
                name="zbt-wa05"
                ;;
+       *"ZBT-WG2626")
+               name="zbt-wg2626"
+               ;;
        *"ZBT-WR8305RT")
                name="zbt-wr8305rt"
                ;;
        *"ZBT-WR8305RT")
                name="zbt-wr8305rt"
                ;;
index 33ec8cc85458e0d3a4525a707cad2c1760be2548..3d4b73afb626ac0f31424b24a274b67c158e33ae 100755 (executable)
@@ -132,6 +132,7 @@ platform_check_image() {
        y1|\
        y1s|\
        zbt-wa05|\
        y1|\
        y1s|\
        zbt-wa05|\
+       zbt-wg2626|\
        zbt-wr8305rt|\
        zte-q7)
                [ "$magic" != "27051956" ] && {
        zbt-wr8305rt|\
        zte-q7)
                [ "$magic" != "27051956" ] && {
diff --git a/target/linux/ramips/dts/ZBT-WG2626.dts b/target/linux/ramips/dts/ZBT-WG2626.dts
new file mode 100644 (file)
index 0000000..6170454
--- /dev/null
@@ -0,0 +1,127 @@
+/dts-v1/;
+
+/include/ "mt7621.dtsi"
+
+/ {
+       compatible = "mediatek,mt7621-eval-board", "mediatek,mt7621-soc";
+       model = "ZBT-WG2626";
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x1c000000>, <0x20000000 0x4000000>;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,57600";
+       };
+
+       sdhci@10130000 {
+               status = "okay";
+       };
+
+       palmbus@1E000000 {
+               spi@b00 {
+                       status = "okay";
+
+                       m25p80@0 {
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+                               compatible = "w25q128";
+                               reg = <0 0>;
+                               linux,modalias = "m25p80";
+                               spi-max-frequency = <10000000>;
+
+                               partition@0 {
+                                       label = "u-boot";
+                                       reg = <0x0 0x30000>;
+                                       read-only;
+                               };
+
+                               partition@30000 {
+                                       label = "u-boot-env";
+                                       reg = <0x30000 0x10000>;
+                                       read-only;
+                               };
+
+                               factory: partition@40000 {
+                                       label = "factory";
+                                       reg = <0x40000 0x10000>;
+                                       read-only;
+                               };
+
+                               partition@50000 {
+                                       label = "firmware";
+                                       reg = <0x50000 0xfb0000>;
+                               };
+
+                       };
+               };
+
+               i2c@900 {
+                       compatible = "ralink,i2c-mt7621";
+                       reg = <0x900 0x100>;
+                       #address-cells = <1>;
+                       #size-cells = <0>;
+                       pinctrl-names = "default";
+                       pinctrl-0 = <&i2c_pins>;
+                       status = "okay";
+               };
+       };
+
+       pcie@1e140000 {
+               status = "okay";
+
+               pcie0 {
+                       mt76@0,0 {
+                               reg = <0x0000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x8000>;
+                               mediatek,2ghz = <0>;
+                       };
+               };
+
+               pcie1 {
+                       mt76@1,0 {
+                               reg = <0x0000 0 0 0 0>;
+                               device_type = "pci";
+                               mediatek,mtd-eeprom = <&factory 0x0000>;
+                               mediatek,5ghz = <0>;
+                       };
+               };
+       };
+
+       ethernet@1e100000 {
+               mtd-mac-address = <&factory 0xe000>;
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 18 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               status {
+                       label = "zbt-wg2626:green:status";
+                       gpios = <&gpio0 24 1>;
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "wdt", "rgmii2", "wdt rst", "jtag", "mdio";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+};
index f1a0ec406e3b34d8ba0a22866750db825a5f043d..5e19c3f97d22a683e4cd7d20dca2bbf39c7b29ef 100644 (file)
@@ -952,7 +952,7 @@ endif
 #
 
 ifeq ($(SUBTARGET),mt7621)
 #
 
 ifeq ($(SUBTARGET),mt7621)
-  TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3
+  TARGET_DEVICES += mt7621 wsr-600 wsr-1166 dir-860l-b1 firewrt pbr-m1 re6500 sap-g3200u3 zbt-wg2626
 endif
 
 define Device/mt7621
 endif
 
 define Device/mt7621
@@ -1002,6 +1002,11 @@ define Device/sap-g3200u3
   DTS := SAP-G3200U3
 endef
 
   DTS := SAP-G3200U3
 endef
 
+define Device/zbt-wg2626
+  DTS := ZBT-WG2626
+  IMAGE_SIZE := $(ralink_default_fw_size_16M)
+endef
+
 #
 # MT7628 Profiles
 #
 #
 # MT7628 Profiles
 #
diff --git a/target/linux/ramips/mt7621/profiles/zbt.mk b/target/linux/ramips/mt7621/profiles/zbt.mk
new file mode 100644 (file)
index 0000000..0134bb5
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ZBT-WG2626
+       NAME:=ZBT-WG2626 Device
+       FEATURES+=rtc
+       PACKAGES:=\
+               kmod-usb-core kmod-usb3 kmod-sdhci-mt7620 \
+               kmod-ledtrig-usbdev kmod-ata-core kmod-ata-ahci \
+               kmod-usb3-mt7621
+endef
+
+define Profile/ZBT-WG2626/Description
+       Package set for ZBT-WG2626 device
+endef
+$(eval $(call Profile,ZBT-WG2626))