ramips: add Poray IP2202 support
authorJohn Crispin <john@openwrt.org>
Thu, 1 Aug 2013 14:31:15 +0000 (14:31 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 1 Aug 2013 14:31:15 +0000 (14:31 +0000)
Signed-off-by: Felix Kaechele <heffer@fedoraproject.org>
SVN-Revision: 37640

target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/etc/uci-defaults/02_network
target/linux/ramips/base-files/lib/preinit/06_set_iface_mac
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/IP2202.dts [new file with mode: 0644]
target/linux/ramips/image/Makefile
target/linux/ramips/rt305x/profiles/poray.mk

index 689fee71049c8ba017b9e9add6b6101d72bc5c69..6ecb13352cdae5764c50dbb13e25723a75869991 100755 (executable)
@@ -45,6 +45,9 @@ get_status_led() {
        fonera20n)
                status_led="fonera20n:green:power"
                ;;
+       ip2202)
+               status_led="ip2202:green:run"
+               ;;
        rt-n13u)
                status_led="rt-n13u:power"
                ;;
index 2df7b0842bf14a33eb5954aa0882088e0560999a..ef13e364a51bccad6ea3f0c149299f520ce6ff4b 100755 (executable)
@@ -173,6 +173,7 @@ ramips_setup_macs()
        broadway | \
        dir-620-d1 | \
        f5d8235-v1 | \
+       ip2202 | \
        mpr-a1 | \
        mpr-a2 | \
        mzk-w300nh2 | \
index 6712154dc4bf0b44282ea3079e057e76bc67dfcb..a0d9b6123bff5a4fdff9e90ede2b4963caa7cb0e 100644 (file)
@@ -60,6 +60,7 @@ preinit_set_mac_address() {
        carambola |\
        dir-615-h1 |\
        fonera20n |\
+       ip2202 |\
        rt-n13u |\
        hw550-3g |\
        nbg-419n |\
index 6960c6d4015df580fb7860117ae4b2a8168f8f74..858a8092e7ad52a0fc6c1d3670767c4197de5bfc 100755 (executable)
@@ -148,6 +148,9 @@ ramips_board_detect() {
        *"Planex MZK-W300NH2"*)
                name="mzk-w300nh2"
                ;;
+       *"Poray IP2202")
+               name="ip2202"
+               ;;
        *"Poray M3")
                name="m3"
                ;;
index df3b32479dd1867a635438498ce7724decdb9232..e85beada3935a2d532996a2458d2c35513204983 100755 (executable)
@@ -44,6 +44,7 @@ platform_check_image() {
        freestation5 | \
        hw550-3g | \
        hg255d | \
+       ip2202 | \
        m3 | \
        m4 | \
        mofi3500-3gn | \
diff --git a/target/linux/ramips/dts/IP2202.dts b/target/linux/ramips/dts/IP2202.dts
new file mode 100644 (file)
index 0000000..ea9f170
--- /dev/null
@@ -0,0 +1,97 @@
+/dts-v1/;
+
+/include/ "rt3050.dtsi"
+
+/ {
+       compatible = "IP2202", "ralink,rt3052-soc";
+       model = "Poray IP2202";
+
+       palmbus@10000000 {
+               sysc@0 {
+                       ralink,pinmux = "i2c", "spi", "uartlite", "jtag", "sdram", "rgmii";
+                       ralink,gpiomux = "mdio";
+                       ralink,uartmux = "gpio";
+                       ralink,wdtmux = <1>;
+               };
+
+               gpio0: gpio@600 {
+                       status = "okay";
+               };
+
+       };
+
+       cfi@1f000000 {
+               compatible = "cfi-flash";
+               reg = <0x1f000000 0x800000>;
+
+               bank-width = <2>;
+               device-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x30000>;
+                       read-only;
+               };
+
+               partition@30000 {
+                       label = "u-boot-env";
+                       reg = <0x30000 0x10000>;
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       label = "factory";
+                       reg = <0x40000 0x10000>;
+                       read-only;
+               };
+
+               partition@50000 {
+                       label = "firmware";
+                       reg = <0x50000 0x7b0000>;
+               };
+       };
+
+       ethernet@10100000 {
+               status = "okay";
+       };
+
+       esw@10110000 {
+               status = "okay";
+               ralink,portmap = <0x2f>;
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+               run {
+                       label = "ip2202:green:run";
+                       gpios = <&gpio0 9 1>;
+               };
+               net {
+                       label = "ip2202:amber:net";
+                       gpios = <&gpio0 13 1>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 10 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       wmac@10180000 {
+               status = "okay";
+               ralink,led-polarity = <0>;
+       };
+
+       otg@101c0000 {
+               status = "okay";
+       };
+};
index 4bfcced46f9b13e57199ab917818c264a9714bbb..88954f13aabccdb832b699967e0c7bc0ef5d2107 100644 (file)
@@ -374,6 +374,8 @@ Image/Build/Profile/RT-N13U=$(call BuildFirmware/Default8M/$(1),$(1),rt-n13u,RT-
 
 Image/Build/Profile/FREESTATION5=$(call BuildFirmware/Default8M/$(1),$(1),freestation5,FREESTATION5)
 
+Image/Build/Profile/IP2202=$(call BuildFirmware/Default8M/$(1),$(1),ip2202,IP2202)
+
 Image/Build/Profile/M3=$(call BuildFirmware/Poray4M/$(1),$(1),m3,M3)
 
 Image/Build/Profile/M4=$(call BuildFirmware/PorayDualSize/$(1),$(1),m4,M4)
@@ -516,6 +518,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/FREESTATION5,$(1))
 #      $(call Image/Build/Profile/HG255D,$(1))
        $(call Image/Build/Profile/HW550-3G,$(1))
+       $(call Image/Build/Profile/IP2202,$(1))
        $(call Image/Build/Profile/M3,$(1))
        $(call Image/Build/Profile/M4,$(1))
        $(call Image/Build/Profile/MOFI3500-3GN,$(1))
index 8c1ed6194f85dece645e173b31b7d798d4f2c2e9..ed017b7d8432810a2d5099daa9304680a58988cd 100644 (file)
@@ -5,6 +5,18 @@
 # See /LICENSE for more information.
 #
 
+define Profile/IP2202
+       NAME:=Poray IP2202
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-usb-rt305x-dwc_otg \
+       kmod-ledtrig-netdev kmod-ledtrig-timer restorefactory
+endef
+
+define Profile/IP2202/Description
+       Package set for Poray IP2202 board
+endef
+
+$(eval $(call Profile,IP2202))
+
 define Profile/M3
        NAME:=Poray M3
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-netdev kmod-ledtrig-timer