e2fsprogs: fix glibc compile issue (FS#1749,FS#1796)
authorHans Dedecker <dedeckeh@gmail.com>
Mon, 8 Oct 2018 14:57:01 +0000 (16:57 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Mon, 8 Oct 2018 15:24:23 +0000 (17:24 +0200)
Fixes the following build error:

.../toolchain-i386_pentium4_gcc-7.3.0_glibc/lib/gcc/i486-openwrt-linux-gnu/7.3.0/../../../../i486-openwrt-linux-gnu/bin/ld: ../lib/libcom_err.so: undefined reference to `sem_post’
.../toolchain-i386_pentium4_gcc-7.3.0_glibc/lib/gcc/i486-openwrt-linux-gnu/7.3.0/../../../../i486-openwrt-linux-gnu/bin/ld: ../lib/libcom_err.so: undefined reference to `sem_wait'
.../toolchain-i386_pentium4_gcc-7.3.0_glibc/lib/gcc/i486-openwrt-linux-gnu/7.3.0/../../../../i486-openwrt-linux-gnu/bin/ld: ../lib/libcom_err.so: undefined reference to `sem_init’
.../toolchain-i386_pentium4_gcc-7.3.0_glibc/lib/gcc/i486-openwrt-linux-gnu/7.3.0/../../../../i486-openwrt-linux-gnu/bin/ld: ../lib/libcom_err.so: undefined reference to `sem_destroy’

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/utils/e2fsprogs/Makefile

index 13a408718d34ed3d1ecd861afb9a2fa372d12df2..48f812a30ccc5cd90f35134ee6e831db246ee03a 100644 (file)
@@ -132,6 +132,8 @@ $(call Package/e2fsprogs)
 endef
 
 TARGET_CFLAGS += $(FPIC) -ffunction-sections -fdata-sections -flto
+
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
 TARGET_LDFLAGS += -flto
 
 CONFIGURE_ARGS += \