update to 2.6.26.3 and 2.6.25.16
authorGabor Juhos <juhosg@openwrt.org>
Fri, 22 Aug 2008 15:37:19 +0000 (15:37 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 22 Aug 2008 15:37:19 +0000 (15:37 +0000)
SVN-Revision: 12371

38 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/adm5120/patches-2.6.26/202-pci_disable_common_quirks.patch
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/ar71xx/patches-2.6.26/140-redboot_partition_scan.patch
target/linux/at91/Makefile
target/linux/at91/patches-2.6.25/017-usb_serial_endpoint_size.patch
target/linux/atheros/Makefile
target/linux/atheros/patches-2.6.26/120-watchdog.patch
target/linux/atheros/patches-2.6.26/135-ar2313_2.6.26.patch
target/linux/atheros/patches-2.6.26/140-redboot_partition_scan.patch
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/etrax/Makefile
target/linux/generic-2.6/config-2.6.26
target/linux/generic-2.6/patches-2.6.25/208-rtl8110sb_fix.patch
target/linux/generic-2.6/patches-2.6.25/801-usb_serial_endpoint_size.patch
target/linux/generic-2.6/patches-2.6.26/071-redboot_boardconfig.patch
target/linux/generic-2.6/patches-2.6.26/208-rtl8110sb_fix.patch
target/linux/generic-2.6/patches-2.6.26/801-usb_serial_endpoint_size.patch
target/linux/generic-2.6/patches-2.6.26/910-cryptodev_backport.patch
target/linux/ifxmips/Makefile
target/linux/iop32x/Makefile
target/linux/ixp4xx/Makefile
target/linux/ixp4xx/patches-2.6.26/116-sidewinder_fis_location.patch
target/linux/ixp4xx/patches-2.6.26/162-wg302v1_mem_fixup.patch
target/linux/ixp4xx/patches-2.6.26/192-cambria_gpio_device.patch
target/linux/magicbox/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ps3/Makefile
target/linux/uml/Makefile
target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
target/linux/x86/Makefile

index 52eef9dfbc02dcfd6e1467eceda1d5f5b9ce35fa..e43423425c3243c7acdac7a526f14229b3ced49a 100644 (file)
@@ -25,11 +25,11 @@ endif
 ifeq ($(LINUX_VERSION),2.6.24.7)
   LINUX_KERNEL_MD5SUM:=40a73780d51525d28d36dec852c680c4
 endif
-ifeq ($(LINUX_VERSION),2.6.25.15)
-  LINUX_KERNEL_MD5SUM:=13ed94f02fc2a11615e3332e1cdf50e7
+ifeq ($(LINUX_VERSION),2.6.25.16)
+  LINUX_KERNEL_MD5SUM:=fdb0e08f0e5a2b4fe6dc711ca35f430e
 endif
-ifeq ($(LINUX_VERSION),2.6.26.2)
-  LINUX_KERNEL_MD5SUM:=82472622bd26bed0054790ec3e60ee00
+ifeq ($(LINUX_VERSION),2.6.26.3)
+  LINUX_KERNEL_MD5SUM:=90fe36b18dbac6e2f79374e2df60ac67
 endif
 
 # disable the md5sum check for unknown kernel versions
index f87f9eaf8073a1814f1f97f905e16c0f76892747..2947308f8e9a889602300e5996a8c596f646a017 100644 (file)
@@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-#LINUX_VERSION:=2.6.25.15
-LINUX_VERSION:=2.6.26.2
+#LINUX_VERSION:=2.6.25.16
+LINUX_VERSION:=2.6.26.3
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index 7f31c9bf94426698a9bf7d3069f4c1009aaa03bb..40728a970758bc3d8520c3d69f9cf5eb86eebe34 100644 (file)
@@ -39,7 +39,7 @@
  /* Enable 1k I/O space granularity on the Intel P64H2 */
  static void __devinit quirk_p64h2_1k_io(struct pci_dev *dev)
  {
-@@ -1929,3 +1932,4 @@
+@@ -1934,3 +1937,4 @@
                        quirk_msi_intx_disable_bug);
  
  #endif /* CONFIG_PCI_MSI */
index f6da81212395dd56c7a3cc1023d339204290f20e..8d48a2addb4cbe05f8717bccb68bc8d0ff8bbb80 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 66b1efc24ddb4275c08adba125c77d25e4d1c084..1572c84319fd0a1f8a2d1099b89a2dd77eb0b95a 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar71xx
 BOARDNAME:=Atheros AR71xx
 FEATURES:=squashfs tgz broken
 
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
 
 include $(INCLUDE_DIR)/target.mk
 
index baf8026a39fdce08e85057bb8ff5ed52421c7d1b..3e89407d0de4e6e3bcc643a687e245c0a0dd00e2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/redboot.c
 +++ b/drivers/mtd/redboot.c
-@@ -59,31 +59,32 @@
+@@ -62,31 +62,32 @@
        static char nullstring[] = "unallocated";
  #endif
  
@@ -40,7 +40,7 @@
        printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
               master->name, offset);
  
-@@ -155,6 +156,11 @@
+@@ -158,6 +159,11 @@
        }
        if (i == numslots) {
                /* Didn't find it */
index 90d10088d569922eb886a47e954b7eecc89d17de..4385a1763a708bd1f519c3c6d4ce1a9745d78b95 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=at91
 BOARDNAME:=Atmel AT91
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 412490ffa1ebf103e2a7ec643d197f3e39ef8273..d698763c68de044a0215ea83632e6c31dcf2e56d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/usb/serial/usb-serial.c
 +++ b/drivers/usb/serial/usb-serial.c
-@@ -905,7 +905,7 @@
+@@ -904,7 +904,7 @@
                        dev_err(&interface->dev, "No free urbs available\n");
                        goto probe_error;
                }
index 1544f82164de654ab85880ef07ecad31cf38aaa7..e4e2a423ced96b8851ecfea93af526e965ffd465 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros 231x/5312
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 64ac6871ce8da41bc530a87a11f1fc2fbbcc24da..d99b8c7813115487de7b0a84dcc681a3fe771d9d 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.26.2/drivers/watchdog/Kconfig
-===================================================================
---- linux-2.6.26.2.orig/drivers/watchdog/Kconfig       2008-08-14 16:54:30.000000000 +0200
-+++ linux-2.6.26.2/drivers/watchdog/Kconfig    2008-08-14 16:55:40.000000000 +0200
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
 @@ -683,6 +683,12 @@
        help
          Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
@@ -15,10 +13,8 @@ Index: linux-2.6.26.2/drivers/watchdog/Kconfig
  # PARISC Architecture
  
  # POWERPC Architecture
-Index: linux-2.6.26.2/drivers/watchdog/Makefile
-===================================================================
---- linux-2.6.26.2.orig/drivers/watchdog/Makefile      2008-08-14 16:55:44.000000000 +0200
-+++ linux-2.6.26.2/drivers/watchdog/Makefile   2008-08-14 16:58:16.000000000 +0200
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
 @@ -97,6 +97,7 @@
  obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
  obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
index e3a30d88729823696a2a399a614aeac34da380c3..97d3f1c3878b49d91e9ca174fe155d94750d7a44 100644 (file)
@@ -1,5 +1,5 @@
---- a/drivers/net/ar2313/ar2313.c      (revisione 11911)
-+++ a/drivers/net/ar2313/ar2313.c      (copia locale)
+--- a/drivers/net/ar2313/ar2313.c
++++ b/drivers/net/ar2313/ar2313.c
 @@ -291,7 +291,7 @@
        sp->mii_bus.write = mdiobus_write;
        sp->mii_bus.reset = mdiobus_reset;
index baf8026a39fdce08e85057bb8ff5ed52421c7d1b..3e89407d0de4e6e3bcc643a687e245c0a0dd00e2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/redboot.c
 +++ b/drivers/mtd/redboot.c
-@@ -59,31 +59,32 @@
+@@ -62,31 +62,32 @@
        static char nullstring[] = "unallocated";
  #endif
  
@@ -40,7 +40,7 @@
        printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
               master->name, offset);
  
-@@ -155,6 +156,11 @@
+@@ -158,6 +159,11 @@
        }
        if (i == numslots) {
                /* Didn't find it */
index 25f94fca0d468e3ebfbbf88e72a85fa9db0a3f50..7cc7a93300233f49655c581dff8d4434ca0781db 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=au1000
 BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=jffs2 usb pci
 
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += yamonenv
index de38c6581a61449cb7dace896b5acd0cc70ee077..49c7c4615465a83a6b9d0850d487ae594da3e133 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 3ec9bbb83f64c0b82f2d7d4945a04d682c22bfe6..36205aed617a8f0b7e4fbd0fe2e5e42a1080c56e 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-switch kmod-diag
index 79d21f62469d7f598cd0cac94e2e2a08091d4a69..cc2da9b7a5cb7c06026c9f52a4065a4284a7544b 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
 FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
 
 include $(INCLUDE_DIR)/target.mk
 
index a08d6b8925f9a46c9659a4d8bdd7999e894301f3..8404cc86c982614cc4029b2936962866902f6bd8 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=cris
 BOARD:=etrax
 BOARDNAME:=Foxboard (ETRAX 100LX)
 FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
 
 include $(INCLUDE_DIR)/target.mk
 
index a5f3921822bcf972f0b10951ac938f69dd733722..dbf2b23b984eff1f051098eba26030b20eea65b7 100644 (file)
@@ -428,6 +428,7 @@ CONFIG_HZ_100=y
 # CONFIG_HZ_256 is not set
 # CONFIG_HZ_300 is not set
 # CONFIG_HZ_48 is not set
+# CONFIG_I2C_ALGOBIT is not set
 # CONFIG_I2C_ALGOPCA is not set
 # CONFIG_I2C_ALGOPCF is not set
 # CONFIG_I2C_ALI1535 is not set
@@ -442,6 +443,7 @@ CONFIG_HZ_100=y
 # CONFIG_I2C_DEBUG_CORE is not set
 # CONFIG_I2C_ELEKTOR is not set
 # CONFIG_I2C_GPIO is not set
+# CONFIG_I2C_HELPER_AUTO is not set
 # CONFIG_I2C_I801 is not set
 # CONFIG_I2C_I810 is not set
 # CONFIG_I2C_IBM_IIC is not set
index 2339bd2625f8b96d7c44bb9355b165478bbf49a1..e812f9b51e6e2116585a4b5ff533ae960e5b524f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/r8169.c
 +++ b/drivers/net/r8169.c
-@@ -1537,7 +1537,7 @@
+@@ -1539,7 +1539,7 @@
                .hw_start       = rtl_hw_start_8169,
                .region         = 1,
                .align          = 0,
@@ -9,7 +9,7 @@
                                  RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
                .napi_event     = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
                .msi            = 0
-@@ -1546,7 +1546,7 @@
+@@ -1548,7 +1548,7 @@
                .hw_start       = rtl_hw_start_8168,
                .region         = 2,
                .align          = 8,
@@ -18,7 +18,7 @@
                                  TxErr | TxOK | RxOK | RxErr,
                .napi_event     = TxErr | TxOK | RxOK | RxOverflow,
                .msi            = RTL_FEATURE_MSI
-@@ -1555,7 +1555,7 @@
+@@ -1557,7 +1557,7 @@
                .hw_start       = rtl_hw_start_8101,
                .region         = 2,
                .align          = 8,
@@ -27,7 +27,7 @@
                                  RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
                .napi_event     = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
                .msi            = RTL_FEATURE_MSI
-@@ -2903,10 +2903,12 @@
+@@ -2905,10 +2905,12 @@
                        break;
                }
  
index 79ee43e16abff4e1b99122c3619e64dc4a7e02f7..e91ff5eafa6d9b1db54654979fdfe079af35fffd 100644 (file)
@@ -8,7 +8,7 @@
  static int debug;
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];    /* initially all NULL */
  static DEFINE_MUTEX(table_lock);
-@@ -904,7 +905,7 @@
+@@ -903,7 +904,7 @@
                        dev_err(&interface->dev, "No free urbs available\n");
                        goto probe_error;
                }
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc (buffer_size, GFP_KERNEL);
-@@ -1316,3 +1317,5 @@
+@@ -1315,3 +1316,5 @@
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index 48c7d52cb7a109441736247e9cc9a2a09185947a..07f569a731b35cf18158fdc7221688980faa32b3 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.26.2/drivers/mtd/redboot.c
-===================================================================
---- linux-2.6.26.2.orig/drivers/mtd/redboot.c  2008-08-19 19:32:17.000000000 +0200
-+++ linux-2.6.26.2/drivers/mtd/redboot.c       2008-08-19 19:47:34.000000000 +0200
+--- a/drivers/mtd/redboot.c
++++ b/drivers/mtd/redboot.c
 @@ -13,6 +13,8 @@
  #include <linux/mtd/mtd.h>
  #include <linux/mtd/partitions.h>
@@ -19,7 +17,7 @@ Index: linux-2.6.26.2/drivers/mtd/redboot.c
        int nrparts = 0;
        struct fis_image_desc *buf;
        struct mtd_partition *parts;
-@@ -217,14 +220,14 @@
+@@ -211,14 +214,14 @@
                }
        }
  #endif
@@ -36,7 +34,7 @@ Index: linux-2.6.26.2/drivers/mtd/redboot.c
  #ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
        if (nulllen > 0) {
                strcpy(nullname, nullstring);
-@@ -243,6 +246,8 @@
+@@ -237,6 +240,8 @@
        }
  #endif
        for ( ; i<nrparts; i++) {
@@ -45,7 +43,7 @@ Index: linux-2.6.26.2/drivers/mtd/redboot.c
                parts[i].size = fl->img->size;
                parts[i].offset = fl->img->flash_base;
                parts[i].name = names;
-@@ -276,6 +281,14 @@
+@@ -270,6 +275,14 @@
                fl = fl->next;
                kfree(tmp_fl);
        }
index 2339bd2625f8b96d7c44bb9355b165478bbf49a1..e812f9b51e6e2116585a4b5ff533ae960e5b524f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/net/r8169.c
 +++ b/drivers/net/r8169.c
-@@ -1537,7 +1537,7 @@
+@@ -1539,7 +1539,7 @@
                .hw_start       = rtl_hw_start_8169,
                .region         = 1,
                .align          = 0,
@@ -9,7 +9,7 @@
                                  RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
                .napi_event     = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
                .msi            = 0
-@@ -1546,7 +1546,7 @@
+@@ -1548,7 +1548,7 @@
                .hw_start       = rtl_hw_start_8168,
                .region         = 2,
                .align          = 8,
@@ -18,7 +18,7 @@
                                  TxErr | TxOK | RxOK | RxErr,
                .napi_event     = TxErr | TxOK | RxOK | RxOverflow,
                .msi            = RTL_FEATURE_MSI
-@@ -1555,7 +1555,7 @@
+@@ -1557,7 +1557,7 @@
                .hw_start       = rtl_hw_start_8101,
                .region         = 2,
                .align          = 8,
@@ -27,7 +27,7 @@
                                  RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
                .napi_event     = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
                .msi            = RTL_FEATURE_MSI
-@@ -2903,10 +2903,12 @@
+@@ -2905,10 +2905,12 @@
                        break;
                }
  
index f1bd446bd59f903e2808c0f2b18cba3a48bc6a40..e7bc6c52f4a11456d6b76b09f380e6a2ee517895 100644 (file)
@@ -8,7 +8,7 @@
  static int debug;
  static struct usb_serial *serial_table[SERIAL_TTY_MINORS];    /* initially all NULL */
  static DEFINE_MUTEX(table_lock);
-@@ -815,7 +816,7 @@
+@@ -814,7 +815,7 @@
                        dev_err(&interface->dev, "No free urbs available\n");
                        goto probe_error;
                }
@@ -17,7 +17,7 @@
                port->bulk_in_size = buffer_size;
                port->bulk_in_endpointAddress = endpoint->bEndpointAddress;
                port->bulk_in_buffer = kmalloc (buffer_size, GFP_KERNEL);
-@@ -1229,3 +1230,5 @@
+@@ -1228,3 +1229,5 @@
  
  module_param(debug, bool, S_IRUGO | S_IWUSR);
  MODULE_PARM_DESC(debug, "Debug enabled or not");
index 682d2a13fd2805a4728fbdb228c9c32c0f260d30..a2d64367c47a34cc359c3336b3706e0eca081ce1 100644 (file)
 +
 --- a/drivers/crypto/padlock-aes.c
 +++ b/drivers/crypto/padlock-aes.c
-@@ -385,12 +385,12 @@
+@@ -411,12 +411,12 @@
        int ret;
  
        if (!cpu_has_xcrypt) {
  
 --- a/drivers/crypto/padlock-sha.c
 +++ b/drivers/crypto/padlock-sha.c
-@@ -254,12 +254,12 @@
+@@ -263,12 +263,12 @@
        int rc = -ENODEV;
  
        if (!cpu_has_phe) {
index 060782bbd33844cf2866dd58311cf7b5cd61dc2f..79f578dd196e1788cb7ed8a0d2715c864b2af668 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES:=uboot-ifxmips
index 12dc5990c2e343e38c9ea293f32dcce6cde000cb..e46e0c80c8bb2fc0fdd3a3fa9cc90d20ae156ea9 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=iop32x
 BOARDNAME:=Intel IOP32x
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 897a2fac2ad263e33c005253e63cfbd8f6cec2a2..51155663b8c00c2dc474fae9ed800c694c4be7e7 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 718ef3ce5ee3306abb6b257256aad94a5e1e3d86..da685ef74e083d7a49a08f5598619565900298c5 100644 (file)
@@ -1,15 +1,15 @@
 --- a/drivers/mtd/redboot.c
 +++ b/drivers/mtd/redboot.c
-@@ -13,6 +13,8 @@
- #include <linux/mtd/mtd.h>
- #include <linux/mtd/partitions.h>
+@@ -15,6 +15,8 @@
+ #define BOARD_CONFIG_PART             "boardconfig"
  
 +#include <asm/mach-types.h>
 +
  struct fis_image_desc {
      unsigned char name[16];      // Null terminated name
      uint32_t    flash_base;    // Address within FLASH of image
-@@ -30,7 +32,8 @@
+@@ -32,7 +34,8 @@
        struct fis_list *next;
  };
  
@@ -19,7 +19,7 @@
  module_param(directory, int, 0);
  
  static inline int redboot_checksum(struct fis_image_desc *img)
-@@ -58,6 +61,8 @@
+@@ -61,6 +64,8 @@
  #ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
        static char nullstring[] = "unallocated";
  #endif
index 4eb1b7595fcb6ab080fe823d4505dcda94bf0ebf..f2d8fde550a88836a2d39a75d6c616889b98f064 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/mach-ixp4xx/wg302v1-setup.c
 +++ b/arch/arm/mach-ixp4xx/wg302v1-setup.c
-@@ -99,6 +99,36 @@
+@@ -115,6 +115,36 @@
        &wg302v1_eth[0],
  };
  
@@ -37,7 +37,7 @@
  static void __init wg302v1_init(void)
  {
        ixp4xx_sys_init();
-@@ -117,6 +147,7 @@
+@@ -133,6 +163,7 @@
        /* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
        .phys_io        = IXP4XX_PERIPHERAL_BASE_PHYS,
        .io_pg_offst    = ((IXP4XX_PERIPHERAL_BASE_VIRT) >> 18) & 0xfffc,
index c79a03fa4c9c8bc53b6204ceba9baf86b90aef75..0fe2eb0526cd53c26309ca7a63772d4b86a4170c 100644 (file)
@@ -44,4 +44,4 @@
 +      platform_device_register(&cambria_gpio);
        platform_device_register(&cambria_optional_uart);
  
-       cambria_npec_data.phy = 2;
+       platform_device_register(&cambria_npec_device);
index fcdd285a3f4ffd20715bffd441de6340b091959c..f170208d2b3efd255f3205c5c6bd574e5b237993 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=squashfs pci
 
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
 LINUX_KARCH:=ppc
 
 include $(INCLUDE_DIR)/target.mk
index c9474379f829749c108299339b9d80639926939c..7fc961cd962373fe8f643470cb3bf314f93ce3ff 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=orion
 BOARDNAME:=Marvell Orion
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 5194f30f802bdba3d84448991edf0584abd07b19..38c16c1e346b282f1bb6153d5d0c31b97a417be6 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc40x
 BOARDNAME:=AMCC/IBM PPC40x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index fa8ec11ea42d89c6d83825dd61be84f03224a0ca..1c13f4ce9a6c84cb8a8344f81350b33a9400dd70 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index a9e69a806b250806061597218763d7a9dc5aa289..3e559eb4216fbe854b571863134eb44ef2fd0342 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=powerpc
 BOARD:=ps3
 BOARDNAME:=Sony PS3 Game Console
 
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
 
 KERNEL_CC:=
 
index 3dd9a986ab4d86ef6a5d2c887433884f82a7ce7d..e09751314b547e4a29d249673b618d3e73b2611e 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext2
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.26.2
+LINUX_VERSION:=2.6.26.3
 
 include $(INCLUDE_DIR)/target.mk
 
index 17c08cd6c56273592d62237dc1aa8627e1ea9d61..200c684577a48e72935626c4dbc8299ff6141109 100644 (file)
@@ -1,7 +1,5 @@
-Index: linux-2.6.26/arch/um/Makefile-i386
-===================================================================
---- linux-2.6.26.orig/arch/um/Makefile-i386    2008-07-28 13:43:40.412036547 +0200
-+++ linux-2.6.26/arch/um/Makefile-i386 2008-07-28 13:44:00.234033125 +0200
+--- a/arch/um/Makefile-i386
++++ b/arch/um/Makefile-i386
 @@ -35,7 +35,7 @@
  # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
  # a lot more stack due to the lack of sharing of stacklots.  Also, gcc
index 2d29198984bf853441735cf1d0fb5229a92717c7..3288de347a08acbf62582f18261567cebe568025 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2 vdi
 SUBTARGETS=generic
 
-LINUX_VERSION:=2.6.25.15
+LINUX_VERSION:=2.6.25.16
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci