kernel: bump 4.14 to 4.14.123
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 3 Jun 2019 11:41:17 +0000 (13:41 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 3 Jun 2019 15:01:20 +0000 (17:01 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx, imx6
Runtime-tested on: cns3xxx, imx6

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/cns3xxx/patches-4.14/075-spi_support.patch
target/linux/generic/hack-4.14/911-kobject_add_broadcast_uevent.patch

index 23c3976b3b1d719165abdaedf91612449610b6da..0f1dfcec2708252fa61c76a58419d122fa6c418e 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-4.9 = .180
-LINUX_VERSION-4.14 = .122
+LINUX_VERSION-4.14 = .123
 
 LINUX_KERNEL_HASH-4.9.180 = d25a490d62a3e96a587333e163862585eac4086fc8d4893b4ec1711e7d387c5f
-LINUX_KERNEL_HASH-4.14.122 = c8a3f40ef877e18b3d2890e0954f2d81b6d012a7321836ca4e5b036ef93f68f5
+LINUX_KERNEL_HASH-4.14.123 = 25f58cb56bde388ac9bcee984f5f2d0ca094b0a8af6b92ad1f5b2fd0e6725b85
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index e38dbdb75e10b21711ea5d8a53499616ac5bc44f..401ec876e92474c37c921771db4f9f84dd274d65 100644 (file)
@@ -39,7 +39,7 @@
  /**
 --- a/drivers/spi/spi.c
 +++ b/drivers/spi/spi.c
-@@ -1027,6 +1027,9 @@ static int spi_transfer_one_message(stru
+@@ -1029,6 +1029,9 @@ static int spi_transfer_one_message(stru
        list_for_each_entry(xfer, &msg->transfers, transfer_list) {
                trace_spi_transfer_start(msg, xfer);
  
index 19400af189653bedf47455a432019dc62db050a9..bf46428854194c0c34915ad956b1bb526ba20978 100644 (file)
@@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #endif /* _KOBJECT_H_ */
 --- a/lib/kobject_uevent.c
 +++ b/lib/kobject_uevent.c
-@@ -599,6 +599,43 @@ int add_uevent_var(struct kobj_uevent_en
+@@ -602,6 +602,43 @@ int add_uevent_var(struct kobj_uevent_en
  EXPORT_SYMBOL_GPL(add_uevent_var);
  
  #if defined(CONFIG_NET)