ipq806x: qca99xx: fix wifi calibration
authorPavel Kubelun <be.dissent@gmail.com>
Thu, 8 Jun 2017 06:06:27 +0000 (09:06 +0300)
committerFelix Fietkau <nbd@nbd.name>
Sat, 17 Jun 2017 09:51:41 +0000 (11:51 +0200)
As of now OTP is being correctly parsed and the driver requires to parse pre-caldata to follow corresponding routine.

Rename cal file into pre-calfile so the board initialized correctly with API 2 board data (board-2.bin).

Also remove the now unneeded for qca9984 board.bin symlink to 5GHz calfile.

Signed-off-by: Pavel Kubelun <be.dissent@gmail.com>
package/firmware/ath10k-firmware/Makefile
target/linux/ipq806x/base-files/etc/hotplug.d/firmware/11-ath10k-caldata

index 17ff2ca8e7b21944f23d3adac2c4b65b8aff8e98..d33f650db3b8ad5acf3b29fb80a0ed704fcd55ac 100644 (file)
@@ -319,9 +319,6 @@ endef
 
 define Package/ath10k-firmware-qca9984/install
        $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA9984/hw1.0
-       ln -s \
-               ../../cal-pci-0000:01:00.0.bin \
-               $(1)/lib/firmware/ath10k/QCA9984/hw1.0/board.bin
        $(INSTALL_DATA) \
                $(PKG_BUILD_DIR)/QCA9984/hw1.0/board-2.bin \
                $(1)/lib/firmware/ath10k/QCA9984/hw1.0/board-2.bin
@@ -332,9 +329,6 @@ endef
 
 define Package/ath10k-firmware-qca9984-ct/install
        $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA9984/hw1.0
-       ln -s \
-               ../../cal-pci-0000:01:00.0.bin \
-               $(1)/lib/firmware/ath10k/QCA9984/hw1.0/board.bin
        $(INSTALL_DATA) \
                $(PKG_BUILD_DIR)/QCA9984/hw1.0/board-2.bin \
                $(1)/lib/firmware/ath10k/QCA9984/hw1.0/board-2.bin
index 652621247f47988413f8df17c0476e441658e93e..40e1330bf0b46f5562a114d790c9dd609b1d6cdc 100644 (file)
@@ -61,7 +61,7 @@ case "$FIRMWARE" in
        esac
        ;;
 
-"ath10k/cal-pci-0000:01:00.0.bin")
+"ath10k/pre-cal-pci-0000:01:00.0.bin")
        case $board in
        c2600)
                ath10kcal_extract "radio" 4096 12064
@@ -84,7 +84,7 @@ case "$FIRMWARE" in
                ;;
        esac
        ;;
-"ath10k/cal-pci-0001:01:00.0.bin")
+"ath10k/pre-cal-pci-0001:01:00.0.bin")
        case $board in
        c2600)
                ath10kcal_extract "radio" 20480 12064