px5g-wolfssl: cleanup Makefile and SPDX license
authorPaul Spooren <mail@aparcar.org>
Mon, 31 Aug 2020 20:55:04 +0000 (10:55 -1000)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 31 Aug 2020 21:29:37 +0000 (22:29 +0100)
Minor cosmetic cleanups of the Makefile and add a SPDX compatible
license headers.

Signed-off-by: Paul Spooren <mail@aparcar.org>
package/utils/px5g-wolfssl/Makefile
package/utils/px5g-wolfssl/px5g-wolfssl.c

index a9f6a097ed10f658120c25838f5c685737156a3f..be36f9f33d55e2b42056994524ec006c9ff90df3 100644 (file)
@@ -1,9 +1,6 @@
-#
 # Copyright (C) 2020 Paul Spooren <mail@aparcar.org>
 #
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# SPDX-License-Identifier: GPL-2.0-or-later
 
 include $(TOPDIR)/rules.mk
 
@@ -21,7 +18,7 @@ define Package/px5g-wolfssl
   SECTION:=utils
   CATEGORY:=Utilities
   SUBMENU:=Encryption
-  TITLE:=X.509 certificate generator (using wolfssl)
+  TITLE:=X.509 certificate generator (using WolfSSL)
   DEPENDS:=+libwolfssl
   PROVIDES:=px5g
   VARIANT:=wolfssl
@@ -33,17 +30,14 @@ define Package/px5g-wolfssl/description
  and PEM format for use with stunnel, uhttpd and others.
 endef
 
-define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-endef
-
 TARGET_LDFLAGS += -lwolfssl
 
 
 TARGET_CFLAGS += -Wl,--gc-sections
 
 define Build/Compile
-       $(TARGET_CC) $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/px5g px5g-wolfssl.c $(TARGET_LDFLAGS)
+       $(TARGET_CC) $(TARGET_CPPFLAGS) $(TARGET_CFLAGS) \
+               -o $(PKG_BUILD_DIR)/px5g px5g-wolfssl.c $(TARGET_LDFLAGS)
 endef
 
 define Package/px5g-wolfssl/install
index 54ae9bb3ec06cc9d2396a309fde4321173c8e4ca..b937d220ca5e8ea4018d80bcf678b2edd7c3bd93 100644 (file)
@@ -1,3 +1,7 @@
+// Copyright 2020 Paul Spooren <mail@aparcar.org>
+//
+// SPDX-License-Identifier: GPL-2.0-or-later
+
 #define _GNU_SOURCE
 #include <stdbool.h>
 #include <stdint.h>