kernel: add a package for block2mtd
authorFelix Fietkau <nbd@openwrt.org>
Tue, 16 Feb 2010 18:28:55 +0000 (18:28 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 16 Feb 2010 18:28:55 +0000 (18:28 +0000)
SVN-Revision: 19665

package/kernel/modules/other.mk

index 47fee9f53c0a21dda7114389cbffcb0fb268f7c6..ada8365a7f07d99fcc3b252b7d37530b1ff7e6d0 100644 (file)
@@ -7,6 +7,14 @@
 
 OTHER_MENU:=Other modules
 
+define KernelPackage/block2mtd
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Block device MTD emulation
+  KCONFIG:=CONFIG_MTD_BLOCK2MTD
+  FILES:=$(LINUX_DIR)/drivers/mtd/devices/block2mtd.$(LINUX_KMOD_SUFFIX)
+endef
+$(eval $(call KernelPackage,block2mtd))
+
 define KernelPackage/crc-itu-t
   SUBMENU:=$(OTHER_MENU)
   TITLE:=CRC ITU-T V.41 support