ramips: Add Xiaomi Mi Router 4A 100M International
authorNita Vesa <werecatf@outlook.com>
Fri, 29 Apr 2022 10:57:24 +0000 (13:57 +0300)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 3 Jul 2022 20:14:05 +0000 (22:14 +0200)
The international version of Mi Router 4A 100M is physically
identical to the non-international one, but appears to be
using a different partitioning scheme with the "overlay"
partition being 2MiB in size instead of 1MiB. This means
the following "firmware" partition starts at a different
address and the DTS needs to be adjusted for the firmware
to work.

Signed-off-by: Nita Vesa <werecatf@outlook.com>
target/linux/ramips/dts/mt7628an_xiaomi_mi-router-4a-100m-intl.dts [new file with mode: 0644]
target/linux/ramips/image/mt76x8.mk
target/linux/ramips/mt76x8/base-files/etc/board.d/02_network

diff --git a/target/linux/ramips/dts/mt7628an_xiaomi_mi-router-4a-100m-intl.dts b/target/linux/ramips/dts/mt7628an_xiaomi_mi-router-4a-100m-intl.dts
new file mode 100644 (file)
index 0000000..cdf259c
--- /dev/null
@@ -0,0 +1,56 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7628an_xiaomi_mi-router-4.dtsi"
+
+/ {
+       compatible = "xiaomi,mi-router-4a-100m-intl", "mediatek,mt7628an-soc";
+       model = "Xiaomi Mi Router 4A (100M International Edition)";
+};
+
+&partitions {
+       partition@60000 {
+               label = "overlay";
+               reg = <0x60000 0x200000>;
+               read-only;
+       };
+
+       partition@260000 {
+               label = "firmware";
+               reg = <0x260000 0xda0000>;
+               compatible = "denx,uimage";
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&pcie0 {
+       wifi@0,0 {
+               compatible = "mediatek,mt76";
+               reg = <0x0000 0 0 0 0>;
+               mediatek,mtd-eeprom = <&factory 0x8000>;
+               ieee80211-freq-limit = <5000000 6000000>;
+       };
+};
+
+&ethernet {
+       nvmem-cells = <&macaddr_factory_4>;
+       nvmem-cell-names = "mac-address";
+       mac-address-increment = <(-1)>;
+};
+
+&esw {
+       mediatek,portmap = <0x3e>;
+       mediatek,portdisable = <0x2a>;
+};
+
+&factory {
+       compatible = "nvmem-cells";
+       #address-cells = <1>;
+       #size-cells = <1>;
+
+       macaddr_factory_4: macaddr@4 {
+               reg = <0x4 0x6>;
+       };
+};
index 5c10159568eda0d741ab6903a26458898caf0e4c..21126c32d9b1518e1916935b9fe2f8eed3a35faf 100644 (file)
@@ -917,6 +917,16 @@ define Device/xiaomi_mi-router-4a-100m
 endef
 TARGET_DEVICES += xiaomi_mi-router-4a-100m
 
+define Device/xiaomi_mi-router-4a-100m-intl
+  IMAGE_SIZE := 14976k
+  DEVICE_VENDOR := Xiaomi
+  DEVICE_MODEL := Mi Router 4A
+  DEVICE_VARIANT := 100M International Edition
+  DEVICE_PACKAGES := kmod-mt76x2
+  SUPPORTED_DEVICES += xiaomi,mir4a-100m-intl
+endef
+TARGET_DEVICES += xiaomi_mi-router-4a-100m-intl
+
 define Device/xiaomi_mi-router-4c
   IMAGE_SIZE := 14976k
   DEVICE_VENDOR := Xiaomi
index 0d2c40446a885f250b6b9883245e0a876bc7480e..1c3d43d8210cd91c822a655f2f5a76a7ac8ff220 100644 (file)
@@ -152,7 +152,8 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0:wan" "3:lan" "4:lan" "6@eth0"
                ;;
-       xiaomi,mi-router-4a-100m)
+       xiaomi,mi-router-4a-100m|\
+       xiaomi,mi-router-4a-100m-intl)
                ucidef_add_switch "switch0" \
                        "4:lan:1" "2:lan:2" "0:wan" "6@eth0"
                ;;
@@ -280,6 +281,7 @@ ramips_setup_macs()
                wan_mac=$(mtd_get_mac_binary factory 0x28)
                ;;
        xiaomi,mi-router-4a-100m|\
+       xiaomi,mi-router-4a-100m-intl|\
        xiaomi,mi-router-4c)
                wan_mac=$(mtd_get_mac_binary factory 0x4)
                ;;