brcm2708: boot-part feature integration
authorChristian Lamparter <chunkeey@gmail.com>
Thu, 27 Dec 2018 20:56:28 +0000 (21:56 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Thu, 24 Jan 2019 14:53:02 +0000 (15:53 +0100)
This patch adds the boot-part feature which enables the brcm2708
target move from the custom boot partition size config option to
the generic CONFIG_TARGET_KERNEL_PARTSIZE.

Note:
For people using custom images: Just like with
CONFIG_TARGET_ROOTFS_PARTSIZE changing the value
can cause sysupgrade to repartition the device!
Make sure to have a backup in this case.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
config/Config-images.in
target/linux/brcm2708/Makefile
target/linux/brcm2708/image/Config.in [deleted file]
target/linux/brcm2708/image/Makefile

index 245aed098b36b462583a1669b742d138725bcf2f..a0c7b7a94db9298e642a132cf0020851dc7d418e 100644 (file)
@@ -270,6 +270,7 @@ menu "Target Images"
                int "Kernel partition size (in MB)"
                depends on GRUB_IMAGES || USES_BOOT_PART
                default 8 if TARGET_apm821xx_sata
                int "Kernel partition size (in MB)"
                depends on GRUB_IMAGES || USES_BOOT_PART
                default 8 if TARGET_apm821xx_sata
+               default 20 if TARGET_brcm2708
                default 16
 
        config TARGET_ROOTFS_PARTSIZE
                default 16
 
        config TARGET_ROOTFS_PARTSIZE
index f4dd86767ca0e7cd28e04f50198e08d75a3860ed..11908f5c2f3cc5b29d1c30540f5a45635103789b 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=brcm2708
 BOARDNAME:=Broadcom BCM27xx
 ARCH:=arm
 BOARD:=brcm2708
 BOARDNAME:=Broadcom BCM27xx
-FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs rootfs-part
+FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs rootfs-part boot-part
 MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 SUBTARGETS:=bcm2708 bcm2709 bcm2710
 
 MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 SUBTARGETS:=bcm2708 bcm2709 bcm2710
 
diff --git a/target/linux/brcm2708/image/Config.in b/target/linux/brcm2708/image/Config.in
deleted file mode 100644 (file)
index f7abd9d..0000000
+++ /dev/null
@@ -1,5 +0,0 @@
-config BRCM2708_SD_BOOT_PARTSIZE
-       int "Boot (SD Card) filesystem partition size (in MB)"
-       depends on TARGET_brcm2708
-       default 20
-
index f2d8cec3265b88f9bb8c452ccc5c486b05b45059..cd00d7f3943709f57a69b90b97a11a068938de4b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 FAT32_BLOCK_SIZE=1024
 include $(INCLUDE_DIR)/image.mk
 
 FAT32_BLOCK_SIZE=1024
-FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+FAT32_BLOCKS=$(shell echo $$(($(CONFIG_TARGET_KERNEL_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
 define Build/Compile
        $(CP) $(LINUX_DIR)/COPYING $(KDIR)/COPYING.linux
 
 define Build/Compile
        $(CP) $(LINUX_DIR)/COPYING $(KDIR)/COPYING.linux
@@ -44,7 +44,7 @@ endef
 
 define Build/sdcard-img
        ./gen_rpi_sdcard_img.sh $@ $@.boot $(IMAGE_ROOTFS) \
 
 define Build/sdcard-img
        ./gen_rpi_sdcard_img.sh $@ $@.boot $(IMAGE_ROOTFS) \
-               $(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+               $(CONFIG_TARGET_KERNEL_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
 endef
 
 ### Devices ###
 endef
 
 ### Devices ###