tools: patch: make patch build depend on automake
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 14 Oct 2018 13:25:37 +0000 (15:25 +0200)
committerJo-Philipp Wich <jo@mein.io>
Tue, 18 Dec 2018 16:22:06 +0000 (17:22 +0100)
The Makefile.am changed and now patch wants to use automake to
regenerate the Makefile.in. Make sure automake was build before we build
patch.

This fixes build problem seen by the build bots.
Fixes: 4797dddfde6 ("patch: apply upstream cve fixes")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
(backported from 07e8c217cb79a19c59fcb34ea6de39aa91a625b6)

tools/Makefile

index d2b5daf18c233c8e94657fd61922c75770a3b35b..6766d7df6e52c9211903cad41e70f8ab937fb3cb 100644 (file)
@@ -66,6 +66,7 @@ $(curdir)/bc/compile := $(curdir)/bison/compile
 $(curdir)/findutils/compile := $(curdir)/bison/compile
 $(curdir)/gengetopt/compile := $(curdir)/libtool/compile
 $(curdir)/patchelf/compile := $(curdir)/libtool/compile
+$(curdir)/patch/compile := $(curdir)/automake/compile
 $(curdir)/dosfstools/compile := $(curdir)/autoconf/compile $(curdir)/automake/compile
 $(curdir)/libressl/compile := $(curdir)/pkg-config/compile
 $(curdir)/mkimage/compile += $(curdir)/libressl/compile