build: autotools: fix cache path
authorHuangbin Zhan <zhanhb88@gmail.com>
Sat, 30 Oct 2021 07:28:28 +0000 (15:28 +0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 4 Apr 2022 22:20:24 +0000 (00:20 +0200)
the cache directory should be autom4te.cache in all $(PKG_AUTOMAKE_PATHS)
rather than $(PKG_BUILD_DIR)/autom4te.cache only

Signed-off-by: Huangbin Zhan <zhanhb88@gmail.com>
(cherry picked from commit 044ca149f36a08f56fe827a20aa113837c58cb40)

include/autotools.mk

index 0f0d608b26534d3f0c7e8e36f9cbae4a87127733..e9a7a8224809f8d61d462ef09df72040ac879a0b 100644 (file)
@@ -35,7 +35,7 @@ define autoreconf
                $(patsubst %,rm -f %;,$(2)) \
                $(foreach p,$(3), \
                        if [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
-                               [ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
+                               [ -d $(p)/autom4te.cache ] && rm -rf $(p)/autom4te.cache; \
                                [ -e $(p)/config.rpath ] || \
                                                ln -s $(SCRIPT_DIR)/config.rpath $(p)/config.rpath; \
                                touch NEWS AUTHORS COPYING ABOUT-NLS ChangeLog; \