update ipsec-tools to 0.6.6, add a patch to build on 2.6.19, use Configure template
authorNicolas Thill <nico@openwrt.org>
Fri, 15 Dec 2006 16:15:35 +0000 (16:15 +0000)
committerNicolas Thill <nico@openwrt.org>
Fri, 15 Dec 2006 16:15:35 +0000 (16:15 +0000)
SVN-Revision: 5800

package/ipsec-tools/Makefile
package/ipsec-tools/patches/03-linux_2.6.19_rtnetlink_changes.diff [new file with mode: 0644]

index 586390a281dc06469ca5a2e546f8a4df36c08a12..feccbbb5eb8fabcfd04e72d298156d9a984eab71 100644 (file)
@@ -9,12 +9,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipsec-tools
-PKG_VERSION:=0.6.4
+PKG_VERSION:=0.6.6
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@SF/ipsec-tools
-PKG_MD5SUM:=d0242a943c82c0cbf28005966ff35e21
+PKG_MD5SUM:=e908f3cf367e31c7902df5ab16fbe5c3
 PKG_CAT:=bzcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@@ -32,55 +32,32 @@ define Package/ipsec-tools
 endef
 
 define Build/Configure
-       (cd $(PKG_BUILD_DIR); rm -f config.cache; \
-               touch configure.ac; \
-               touch aclocal.m4; \
-               touch Makefile.in; \
-               touch config.h.in; \
-               touch configure; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
-               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --with-gnu-ld \
-                       --with-kernel-headers="$(LINUX_DIR)/include" \
-                       --without-readline \
-                       --with-openssl="$(STAGING_DIR)/usr" \
-                       --without-libradius \
-                       --without-libpam \
-                       --enable-dpd \
-                       --enable-natt \
+       (cd $(PKG_BUILD_DIR); touch \
+               configure.ac \
+               aclocal.m4 \
+               Makefile.in \
+               config.h.in \
+               configure \
+       );
+       $(call Build/Configure/Default, \
+               --enable-shared \
+               --enable-static \
+               --with-kernel-headers="$(LINUX_DIR)/include" \
+               --without-readline \
+               --with-openssl="$(STAGING_DIR)/usr" \
+               --without-libradius \
+               --without-libpam \
+               --enable-dpd \
+               --enable-natt \
        );
 endef
 
+# override CFLAGS holding "-Werror" that break builds on compile warnings
 define Build/Compile
-       $(call Build/Compile/Default, \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
-               all install \
-       )
+               CFLAGS="$(TARGET_CFLAGS)" \
+               all install
 endef
 
 define Package/ipsec-tools/install
diff --git a/package/ipsec-tools/patches/03-linux_2.6.19_rtnetlink_changes.diff b/package/ipsec-tools/patches/03-linux_2.6.19_rtnetlink_changes.diff
new file mode 100644 (file)
index 0000000..5552906
--- /dev/null
@@ -0,0 +1,21 @@
+diff -ruN ipsec-tools-0.6.6-old/src/racoon/grabmyaddr.c ipsec-tools-0.6.6-new/src/racoon/grabmyaddr.c
+--- ipsec-tools-0.6.6-old/src/racoon/grabmyaddr.c      2005-07-16 06:41:01.000000000 +0200
++++ ipsec-tools-0.6.6-new/src/racoon/grabmyaddr.c      2006-12-15 15:50:13.000000000 +0100
+@@ -77,10 +77,17 @@
+ #ifdef __linux__
+ #include <linux/types.h>
+ #include <linux/rtnetlink.h>
++#include <linux/version.h>
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,19)
++# include <linux/if_addr.h>
++#endif
+ #ifndef HAVE_GETIFADDRS
+ #define HAVE_GETIFADDRS
+ #define NEED_LINUX_GETIFADDRS
+ #endif
++#ifndef IFA_RTA
++# define IFA_RTA(r)  ((struct rtattr*)(((char*)(r)) + NLMSG_ALIGN(sizeof(struct ifaddrmsg))))
++#endif
+ #endif
+ #ifndef HAVE_GETIFADDRS