ath79: add support for TP-Link Archer A7
authorKarl-Felix Glatzer <karl.glatzer@gmx.de>
Wed, 12 Dec 2018 16:56:15 +0000 (17:56 +0100)
committerJohn Crispin <john@phrozen.org>
Mon, 17 Dec 2018 07:09:13 +0000 (08:09 +0100)
This patch adds support for TP-Link Archer A7

Specification:
- SOC: QCA9563
- Flash: 16 MiB (SPI)
- RAM: 128 MiB (DDR2)
- Ethernet: 4x 1Gbps LAN + 1x 1Gbps WAN
- Wireless:
  - 2.4GHz (bgn) SoC internal
  - 5GHz (ac) QCA988x
- USB: 1x USB 2.0 port
- Button: 1x power, 1x reset, 1x wps
- LED: 10x LEDs
- UART: holes in PCB
  - Vcc, GND, RX, TX from ethernet port side
  - 115200n8

Flash instructions:

Upload openwrt-ath79-generic-tplink_archer-a7-v5-squashfs-factory.bin
via the Webinterface.

Flash instruction using tftp recovery:

1. Connect the computer to one of the LAN ports of the Archer A7
2. Set the computer IP to 192.168.0.66
3. Start a tftp server with the OpenWrt factory image in the tftp
   root directory renamed to ArcherC7v5_tp_recovery.bin
2. Connect power cable to Archer A7, press and hold the reset button
   and turn the router on
3. Keep the reset button pressed for ~5 seconds
4. Wait ~150 seconds to complete flashing

Changes since first revision:

  - Flash instructions using stock image webinterface
  - Changed "Version 5" in model string to "v5"
  - Split DTS file in qca9563_tplink_archer-x7-v5.dtsi
    and qca9563_tplink_archer-a7-v5.dts
  - Firmware image is now build with dynamic partitioning
  - Default to ath10k-ct

Changes since second revision:
  - Changed uboot@0 to uboot@20000 in DTS file
  - Fixed ordering issue in board led script
  - Specify firmware partition format in DTS file
  - Rebased Makefile device definition on common
    Device/tplink-safeloader-uimage definition
  - Merged switch section in network script
    (same configuration as tplink,tl-wdr3600
    and tplink,tl-wdr4300)

Signed-off-by: Karl-Felix Glatzer <karl.glatzer@gmx.de>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9563_tplink_archer-a7-v5.dts [new file with mode: 0644]
target/linux/ath79/dts/qca9563_tplink_archer-x7-v5.dtsi [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index 06fb8f4791c61492e1388a7adb6a6950400e0593..96cc5d5c1396bdec926e6b1ea0693a9f29b1f8cc 100755 (executable)
@@ -52,6 +52,13 @@ pcs,cr3000)
        ucidef_set_led_switch "lan3" "LAN3" "pcs:blue:lan3" "switch0" "0x10"
        ucidef_set_led_switch "lan4" "LAN4" "pcs:blue:lan4" "switch0" "0x02"
        ;;
+tplink,archer-a7-v5)
+       ucidef_set_led_switch "wan" "WAN" "tp-link:green:wan" "switch0" "0x02"
+       ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x04"
+       ucidef_set_led_switch "lan2" "LAN2" "tp-link:green:lan2" "switch0" "0x08"
+       ucidef_set_led_switch "lan3" "LAN3" "tp-link:green:lan3" "switch0" "0x10"
+       ucidef_set_led_switch "lan4" "LAN4" "tp-link:green:lan4" "switch0" "0x20"
+       ;;
 tplink,archer-c58-v1|\
 tplink,archer-c59-v1)
        ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x1E"
index 936344043806fd7d441a24700ad17846c4ed3c97..1d6cd4e774574c8d07ebc26be622a548b81e9785 100755 (executable)
@@ -134,6 +134,7 @@ ath79_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "0@eth1" "1:lan:4" "2:lan:3" "3:lan:2" "4:lan:1"
                ;;
+       tplink,archer-a7-v5|\
        tplink,tl-wdr3600|\
        tplink,tl-wdr4300)
                ucidef_add_switch "switch0" \
index 82c23e30794c40277d3743488dc764041af5c02f..9ecda22244360bd415b0c5801df2bfbd07c9d06d 100644 (file)
@@ -104,6 +104,7 @@ case "$FIRMWARE" in
                ath10kcal_extract "ART" 20480 2116
                ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
                ;;
+       tplink,archer-a7-v5|\
        tplink,archer-c7-v2)
                ath10kcal_extract "art" 20480 2116
                ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth1/address) -1)
diff --git a/target/linux/ath79/dts/qca9563_tplink_archer-a7-v5.dts b/target/linux/ath79/dts/qca9563_tplink_archer-a7-v5.dts
new file mode 100644 (file)
index 0000000..8cf86c0
--- /dev/null
@@ -0,0 +1,50 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9563_tplink_archer-x7-v5.dtsi"
+
+/ {
+       compatible = "tplink,archer-a7-v5", "qca,qca9563";
+       model = "TP-Link Archer A7 v5";
+};
+
+&mtdparts {
+       factory-uboot@0 {
+               label = "factory-uboot";
+               reg = <0x000000 0x020000>;
+               read-only;
+       };
+
+       uboot: u-boot@20000 {
+               label = "u-boot";
+               reg = <0x020000 0x020000>;
+               read-only;
+       };
+
+       firmware@40000 {
+               label = "firmware";
+               reg = <0x040000 0xec0000>;
+               compatible = "denx,uimage";
+       };
+
+       info: info@f40000 {
+               label = "info";
+               reg = <0xf40000 0x020000>;
+       };
+
+       config: config@f60000 {
+               label = "config";
+               reg = <0xf60000 0x050000>;
+       };
+
+       partition@fc0000 {
+               label = "partition-table";
+               reg = <0xfc0000 0x010000>;
+       };
+
+       art: art@ff0000 {
+               label = "art";
+               reg = <0xff0000 0x010000>;
+               read-only;
+       };
+};
diff --git a/target/linux/ath79/dts/qca9563_tplink_archer-x7-v5.dtsi b/target/linux/ath79/dts/qca9563_tplink_archer-x7-v5.dtsi
new file mode 100644 (file)
index 0000000..b182aa2
--- /dev/null
@@ -0,0 +1,202 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+       chosen {
+               bootargs = "console=ttyS0,115200n8";
+       };
+
+       aliases {
+               led-status = &system;
+       };
+
+       gpio_leds: leds {
+               compatible = "gpio-leds";
+
+               system: system {
+                       label = "tp-link:green:system";
+                       gpios = <&gpio 6 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               led_wlan2g: wlan2g {
+                       label = "tp-link:green:wlan2g";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               usb {
+                       label = "tp-link:green:usb";
+                       gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+                       default-state = "off";
+                       trigger-sources = <&hub_port0>;
+                       linux,default-trigger = "usbport";
+               };
+       };
+
+       gpio_keys: keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       label = "Reset button";
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+
+               wps {
+                       label = "WPS button";
+                       linux,code = <KEY_WPS_BUTTON>;
+                       gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+       gpio-export {
+               compatible = "gpio-export";
+
+               gpio_usb_power {
+                       gpio-export,name = "tp-link:power:usb";
+                       gpio-export,output = <1>;
+                       gpios = <&gpio 19 GPIO_ACTIVE_HIGH>;
+               };
+       };
+};
+
+&pcie {
+       status = "okay";
+};
+
+&uart {
+       status = "okay";
+};
+
+&gpio {
+       status = "okay";
+};
+
+&usb_phy0 {
+       status = "okay";
+};
+
+&usb0 {
+       #address-cells = <1>;
+       #size-cells = <0>;
+       status = "okay";
+
+       hub_port0: port@1 {
+               reg = <1>;
+               #trigger-source-cells = <0>;
+       };
+};
+
+&gpio_leds {
+       wlan5g {
+               label = "tp-link:green:wlan5g";
+               gpios = <&gpio 9 GPIO_ACTIVE_LOW>;
+               default-state = "off";
+               linux,default-trigger = "phy0tpt";
+       };
+
+       wan {
+               label = "tp-link:green:wan";
+               gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+               default-state = "off";
+       };
+
+       wan_fail {
+               label = "tp-link:orange:wan";
+               gpios = <&gpio 20 GPIO_ACTIVE_LOW>;
+               default-state = "off";
+       };
+
+       lan1 {
+               label = "tp-link:green:lan1";
+               gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+               default-state = "off";
+       };
+
+       lan2 {
+               label = "tp-link:green:lan2";
+               gpios = <&gpio 17 GPIO_ACTIVE_LOW>;
+               default-state = "off";
+       };
+
+       lan3 {
+               label = "tp-link:green:lan3";
+               gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               default-state = "off";
+       };
+
+       lan4 {
+               label = "tp-link:green:lan4";
+               gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               default-state = "off";
+       };
+
+       wps {
+               label = "tp-link:green:wps";
+               gpios = <&gpio 1 GPIO_ACTIVE_LOW>;
+               default-state = "off";
+       };
+};
+
+&spi {
+       status = "okay";
+       num-cs = <1>;
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               mtdparts: partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+               };
+       };
+};
+
+&mdio0 {
+       status = "okay";
+
+       phy-mask = <0>;
+
+       phy0: ethernet-phy@0 {
+               reg = <0>;
+               phy-mode = "sgmii";
+
+               qca,ar8327-initvals = <
+                       0x04 0x00080080 /* PORT0 PAD MODE CTRL */
+                       0x10 0x81000080 /* POWER_ON_STRIP */
+                       0x50 0xcc35cc35 /* LED_CTRL0 */
+                       0x54 0xcb37cb37 /* LED_CTRL1 */
+                       0x58 0x00000000 /* LED_CTRL2 */
+                       0x5c 0x00f3cf00 /* LED_CTRL3 */
+                       0x7c 0x0000007e /* PORT0_STATUS */
+                       >;
+       };
+};
+
+&eth0 {
+       status = "okay";
+
+       pll-data = <0x03000101 0x00000101 0x00001919>;
+
+       phy-mode = "sgmii";
+       mtd-mac-address = <&info 0x8>;
+       phy-handle = <&phy0>;
+};
+
+&wmac {
+       status = "okay";
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&info 0x8>;
+};
index 3688c69fa492b845ba0edb1e373a267de77b6532..2a883b253afeace85f3bf170eedd156d8abe04d6 100644 (file)
@@ -1,5 +1,17 @@
 include ./common-tp-link.mk
 
+define Device/tplink_archer-a7-v5
+  $(Device/tplink-safeloader-uimage)
+  ATH_SOC := qca9563
+  IMAGE_SIZE := 15104k
+  DEVICE_TITLE := TP-LINK Archer A7 v5
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  TPLINK_BOARD_ID := ARCHER-A7-V5
+  BOARDNAME := ARCHER-A7-V5
+  SUPPORTED_DEVICES += archer-a7-v5
+endef
+TARGET_DEVICES += tplink_archer-a7-v5
+
 define Device/tplink_archer-c58-v1
   $(Device/tplink-safeloader-uimage)
   ATH_SOC := qca9561
index 2959a212f805c059f89f37fe9d30448c4b9c27d3..358247e6267858119dbba4965592fdf4d7bb2d3d 100644 (file)
@@ -357,6 +357,46 @@ static struct device_info boards[] = {
                .last_sysupgrade_partition = "file-system"
        },
 
+       /** Firmware layout for the A7-V5 */
+       {
+               .id = "ARCHER-A7-V5",
+               .support_list =
+                       "SupportList:\n"
+                       "{product_name:Archer A7,product_ver:5.0.0,special_id:45550000}\n"
+                       "{product_name:Archer A7,product_ver:5.0.0,special_id:55530000}\n"
+                       "{product_name:Archer A7,product_ver:5.0.0,special_id:43410000}\n"
+                       "{product_name:Archer A7,product_ver:5.0.0,special_id:4A500000}\n"
+                       "{product_name:Archer A7,product_ver:5.0.0,special_id:54570000}\n",
+               .support_trail = '\x00',
+               .soft_ver = "soft_ver:1.0.0\n",
+
+               /* We're using a dynamic kernel/rootfs split here */
+               .partitions = {
+                       {"factory-boot", 0x00000, 0x20000},
+                       {"fs-uboot", 0x20000, 0x20000},
+                       {"firmware", 0x40000, 0xec0000},        /* Stock: name os-image base 0x40000 size 0x120000 */
+                                                               /* Stock: name file-system base 0x160000 size 0xda0000 */
+                       {"default-mac", 0xf40000, 0x00200},
+                       {"pin", 0xf40200, 0x00200},
+                       {"device-id", 0xf40400, 0x00100},
+                       {"product-info", 0xf40500, 0x0fb00},
+                       {"soft-version", 0xf50000, 0x00100},
+                       {"extra-para", 0xf51000, 0x01000},
+                       {"support-list", 0xf52000, 0x0a000},
+                       {"profile", 0xf5c000, 0x04000},
+                       {"default-config", 0xf60000, 0x10000},
+                       {"user-config", 0xf70000, 0x40000},
+                       {"certificate", 0xfb0000, 0x10000},
+                       {"partition-table", 0xfc0000, 0x10000},
+                       {"log", 0xfd0000, 0x20000},
+                       {"radio", 0xff0000, 0x10000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "file-system",
+       },
+
        /** Firmware layout for the C25v1 */
        {
                .id = "ARCHER-C25-V1",
@@ -1581,7 +1621,7 @@ static void build_image(const char *output,
            strcasecmp(info->id, "TLWR1043NV5") == 0) {
                const char mdat[11] = {0x00, 0x00, 0x00, 0x02, 0x00, 0x00, 0x00, 0x00, 0x01, 0x00, 0x00};
                parts[5] = put_data("extra-para", mdat, 11);
-       } else if (strcasecmp(info->id, "ARCHER-C7-V4") == 0 || strcasecmp(info->id, "ARCHER-C7-V5") == 0) {
+       } else if (strcasecmp(info->id, "ARCHER-A7-V5") == 0 || strcasecmp(info->id, "ARCHER-C7-V4") == 0 || strcasecmp(info->id, "ARCHER-C7-V5") == 0) {
                const char mdat[11] = {0x01, 0x00, 0x00, 0x02, 0x00, 0x00, 0xca, 0x00, 0x01, 0x00, 0x00};
                parts[5] = put_data("extra-para", mdat, 11);
        }