libunwind: requires glibc if arch in powerpc
authorYousong Zhou <yszhou4tech@gmail.com>
Thu, 30 May 2019 08:30:42 +0000 (08:30 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 30 May 2019 10:30:45 +0000 (10:30 +0000)
libunwind for powerpc depends on getcontext() from libc which musl-libc
does not provide because this API and its friends are supposed to be
"obsolescent" [1,2]

 [1] Subject: Re: setcontext/getcontext/makecontext missing?
     https://www.openwall.com/lists/musl/2016/02/04/5
 [2] http://pubs.opengroup.org/onlinepubs/009695399/functions/makecontext.html

Refs: https://github.com/openwrt/packages/issues/8548#issuecomment-497200058
Reported-by: Rosen Penev <rosenp@gmail.com>
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
package/libs/libunwind/Makefile

index 2e4b11b..c36cb5c 100644 (file)
@@ -32,7 +32,7 @@ define Package/libunwind
   CATEGORY:=Libraries
   TITLE:=The libunwind project
   URL:=http://www.nongnu.org/libunwind/
-  DEPENDS:=@(mips||mipsel||powerpc||i386||x86_64||arm||aarch64)
+  DEPENDS:=@((mips||mipsel||i386||x86_64||arm||aarch64)||(USE_GLIBC&&powerpc))
   ABI_VERSION:=8
 endef