kernel: fix lib-xor for ARM64
authorTim Harvey <tharvey@gateworks.com>
Fri, 6 Mar 2020 22:08:51 +0000 (14:08 -0800)
committerPetr Štetiar <ynezz@true.cz>
Sun, 8 Mar 2020 14:10:55 +0000 (15:10 +0100)
use LINUX_KARCH in directory path to avoid failures in non-arm targets.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
package/kernel/linux/modules/lib.mk

index ea29d08b55867c45c54afeb0da12e48674dd1cf2..e14c6b31c0103d6f074ba1b677564e448b355fbd 100644 (file)
@@ -187,10 +187,10 @@ define KernelPackage/lib-xor
   TITLE:=XOR blocks algorithm support
   HIDDEN:=1
   KCONFIG:=CONFIG_XOR_BLOCKS
-ifneq ($(wildcard $(LINUX_DIR)/arch/arm/lib/xor-neon.ko),)
+ifneq ($(wildcard $(LINUX_DIR)/arch/$(LINUX_KARCH)/lib/xor-neon.ko),)
   FILES:= \
     $(LINUX_DIR)/crypto/xor.ko \
-    $(LINUX_DIR)/arch/arm/lib/xor-neon.ko
+    $(LINUX_DIR)/arch/$(LINUX_KARCH)/lib/xor-neon.ko
   AUTOLOAD:=$(call AutoProbe,xor-neon xor)
 else
   FILES:=$(LINUX_DIR)/crypto/xor.ko