sdk: fix GCC and Python dangling symlinks
authorPetr Štetiar <ynezz@true.cz>
Thu, 8 Aug 2019 19:16:02 +0000 (21:16 +0200)
committerPetr Štetiar <ynezz@true.cz>
Mon, 12 Aug 2019 08:04:50 +0000 (10:04 +0200)
Force prereq again in SDK in order to fix GCC and Python dangling
symlinks:

 staging_dir/host/bin/g++ -> /builder/ath79_generic/ccache_cxx.sh
 staging_dir/host/bin/gcc -> /builder/ath79_generic/ccache_cc.sh
 staging_dir/host/bin/python -> /usr/bin/python3.5
 staging_dir/host/bin/python3 -> /usr/bin/python3.5

Ref: FS#2424
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/sdk/Makefile

index 0bed666d2172c14b77e161e775186c7e3325bbf5..2badc314297cd1a20423ea1aa8477d64ccac6d1c 100644 (file)
@@ -144,7 +144,8 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
        -rm -rf \
                $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/ccache \
                $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TARGET)/ccache \
        -rm -rf \
                $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/ccache \
                $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TARGET)/ccache \
-               $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TOOLCHAIN)/ccache
+               $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_TOOLCHAIN)/ccache \
+               $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/.prereq-build
 
        -rm -f $(SDK_BUILD_DIR)/feeds.conf.default
        $(if $(BASE_FEED),echo "$(BASE_FEED)" > $(SDK_BUILD_DIR)/feeds.conf.default)
 
        -rm -f $(SDK_BUILD_DIR)/feeds.conf.default
        $(if $(BASE_FEED),echo "$(BASE_FEED)" > $(SDK_BUILD_DIR)/feeds.conf.default)